logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Peter1000  
#1 Posted : Wednesday, June 5, 2019 6:19:19 AM(UTC)
Peter1000

Rank: Advanced Member

Groups: Registered
Joined: 1/25/2019(UTC)
Posts: 65
Switzerland

Was thanked: 11 time(s) in 7 post(s)
hi coders

changing a text field works fine with SelectedIndex but NOT with Selectedname

this works fine, browser returns "Function completed successfully."
http://localhost:8088/API/?Function=SetText&InputName=smallresult&SelectedIndex=0&Value=GER

this does NOT work, but browser returns also "Function completed successfully."
http://localhost:8088/API/?Function=SetText&InputName=smallresult&SelectedName=Home.text&Value=GER
http://localhost:8088/API/?Function=SetText&InputName=smallresult&SelectedName=Home&Value=GER

also i have no success with color changing, browser returns "No suitable Function could be found."
http://localhost:8088/API/?Function=SetTextColor&InputName=smallresult&SelectedIndex=0&Value=#FF0000


these are my fields
smallresult.PNG (10kb) downloaded 0 time(s).

what i am doing wrong? Thanks for your help

Peter
elgarf  
#2 Posted : Wednesday, June 5, 2019 3:24:51 PM(UTC)
elgarf

Rank: Advanced Member

Groups: Registered
Joined: 10/23/2015(UTC)
Posts: 303
Man
Russian Federation

Thanks: 14 times
Was thanked: 136 time(s) in 77 post(s)
@Peter1000,

1) Check your InputName. Maybe it should be "smallresult.gtzip"
2) Looks like SelectedName is case-sensitive, use "Home.Text" instead of "Home.text".
3) There is no SetTextColor function, it named SetTextColour.
Peter1000  
#3 Posted : Thursday, June 6, 2019 3:32:54 AM(UTC)
Peter1000

Rank: Advanced Member

Groups: Registered
Joined: 1/25/2019(UTC)
Posts: 65
Switzerland

Was thanked: 11 time(s) in 7 post(s)
no success for SelectedName :-(

this does NOT work, but browser returns "Function completed successfully."
http://localhost:8088/API/?Function=SetText&InputName=smallresult&SelectedName=Home.Text&Value=GER
http://localhost:8088/API/?Function=SetText&InputName=smallresult&SelectedName=Home&Value=GER
http://localhost:8088/API/?Function=SetText&InputName=smallresult.gtzip&SelectedName=Home.Text&Value=GER
http://localhost:8088/API/?Function=SetText&InputName=smallresult.gtzip&SelectedName=Home&Value=GER

a bit more success with COLOUR instead of color.... BUT
sending this via browser, imediately changes the alpha value to 0, no matter what i send.
this is white with alpha set to 254, FEFFFFFF, after sending this in browser or with HTTP over my client,
Before sending it:
Screen Shot 06-05-19 at 07.27 PM.PNG (108kb) downloaded 1 time(s).

After Sending this: http://localhost:8088/API/?Function=SetTextColour&InputName=smallresult&SelectedIndex=0&Value=#FEFFFFFF
it does not matter which value i send, can also be 0000FF for Blue
Screen Shot 06-05-19 at 07.28 PM.PNG (107kb) downloaded 0 time(s).

here is the smallresult.gtzip (15kb) downloaded 1 time(s). file
admin  
#4 Posted : Thursday, June 6, 2019 12:18:56 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,164
Man
Location: Gold Coast, Australia

Was thanked: 2285 time(s) in 1016 post(s)
Hi,

The names need to match exactly, for example HOME is all upper case in your title, so it also needs to be in your commands.
For the colour, the # is a reserved letter in HTTP, so you need to correctly encode it to %23

Here is a handy tool to ensure the URLS are encoded correctly:

https://meyerweb.com/eric/tools/dencoder/

Regards,

Martin
vMix
Peter1000  
#5 Posted : Friday, June 7, 2019 8:59:32 PM(UTC)
Peter1000

Rank: Advanced Member

Groups: Registered
Joined: 1/25/2019(UTC)
Posts: 65
Switzerland

Was thanked: 11 time(s) in 7 post(s)
Thanks Martin! Its getting closer :-)
My titles are updating only with Input=2, if they are not in the Preview Window. With InputName=smallresult, they update only, when active in the Preview window

UPDATES TIME, NO MATTER IF IN PREVIEW OR NOT
http://localhost:8088/API/?Function=SetText&Input=2&SelectedName=TIME.Text&Value=1234

UPDATES TIME ONLY IF IN PREVIEW
http://localhost:8088/API/?Function=SetText&InputName=smallresult&SelectedName=TIME.Text&Value=9999
http://localhost:8088/API/?Function=SetText&InputName=smallresult.gtzip&SelectedName=TIME.Text&Value=9999

Is this a feature or wanted?

Thanks

Peter
admin  
#6 Posted : Saturday, June 8, 2019 10:29:02 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,164
Man
Location: Gold Coast, Australia

Was thanked: 2285 time(s) in 1016 post(s)
InputName is not a valid property, it is always Input regardless of using numbers or names.
rickvoskamp  
#7 Posted : Saturday, June 8, 2019 11:07:52 PM(UTC)
rickvoskamp

Rank: Newbie

Groups: Registered
Joined: 2/3/2017(UTC)
Posts: 7

Thanks: 1 times
Meaby the problem is the # in the URL? Meaby you can use %23?

Edit: Sorry, i didn’t saw the post of the admin.
Peter1000  
#8 Posted : Saturday, June 8, 2019 11:30:02 PM(UTC)
Peter1000

Rank: Advanced Member

Groups: Registered
Joined: 1/25/2019(UTC)
Posts: 65
Switzerland

Was thanked: 11 time(s) in 7 post(s)
thanks again. works perfect.
sorry
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.