logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
rjmurdock  
#1 Posted : Sunday, February 3, 2019 12:32:37 AM(UTC)
rjmurdock

Rank: Advanced Member

Groups: Registered
Joined: 11/12/2012(UTC)
Posts: 44
Man
Location: Fort Walton Beach, FL USA

Thanks: 6 times
Was thanked: 2 time(s) in 2 post(s)
Having a problem using the new Elgato Stream Deck interface for vMix 22 beta. When I first boot up my laptop, connect my stream deck, and then open vMix, I have no problem seeing the vMix enabled key's of the stream deck when I'm assigning a shortcut to them. However, if I close vMix and reopen it, the stream deck keys are no longer recognized in vMix. On the deck itself, a yellow triangle with a question mark appears over the button.

I also have the same problem when I connect a midi controller to the laptop with the stream deck.

Any ideas of how to resolve this?
admin  
#2 Posted : Sunday, February 3, 2019 1:16:05 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,155
Man
Location: Gold Coast, Australia

Was thanked: 2265 time(s) in 1012 post(s)
There is a bug in the latest Stream Deck 4.0 update that prevents applications from connecting more than once.
We have reported this to Elgato, but so far no ETA on when they will fix it unfortunately.
rjmurdock  
#3 Posted : Wednesday, February 6, 2019 8:10:38 AM(UTC)
rjmurdock

Rank: Advanced Member

Groups: Registered
Joined: 11/12/2012(UTC)
Posts: 44
Man
Location: Fort Walton Beach, FL USA

Thanks: 6 times
Was thanked: 2 time(s) in 2 post(s)
OK, that seems to be what it is doing.

I'm using the work-around the YouTube user: "Eivind" came up with using the stream deck to make API calls over TCP/IP. Awesome solution which I've implemented. I'm using it for single line shortcut calls.

Here's the YouTube video link:
MickeyMJJ  
#4 Posted : Wednesday, April 17, 2019 10:33:45 AM(UTC)
MickeyMJJ

Rank: Advanced Member

Groups: Registered
Joined: 12/14/2018(UTC)
Posts: 32
France

Thanks: 5 times
I received today my Elgato Stream Desk, I also encounter the same problem. I hope that Elgato will react quickly, we are already pretty stressed on an event, so if we can not trust this material, it will be quickly painful. I tried by completely closing the "Stream Desk" software and opening it again, the link with VMIX is working again...
doggy  
#5 Posted : Wednesday, April 17, 2019 4:09:17 PM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 1,137
Belgium
Location: Belgium

Thanks: 64 times
Was thanked: 196 time(s) in 174 post(s)
we have been using 4 streamdecks (even controlling multiple laptops with one unit) for 4 days in a row with not one single issue
Granted we didnt use the vMix options but used it strait as is (shortcuts and website links(API calls)).Due to the nature of the production had to even change or add new buttons etc on the fly and move the settings from one unit to another or computer
MickeyMJJ  
#6 Posted : Wednesday, April 17, 2019 6:22:18 PM(UTC)
MickeyMJJ

Rank: Advanced Member

Groups: Registered
Joined: 12/14/2018(UTC)
Posts: 32
France

Thanks: 5 times
I think that with WEB / API calls, there should be no problem.But if you want to use the Stream Deck with visual feedback on the buttons, there is no choice but to manage the keys directly in VMIX.Hoping that Elgato is looking into the problem.
richardgatarski  
#7 Posted : Wednesday, April 17, 2019 7:38:07 PM(UTC)
richardgatarski

Rank: Advanced Member

Groups: Registered
Joined: 2/18/2014(UTC)
Posts: 1,357
Location: Stockholm

Thanks: 109 times
Was thanked: 211 time(s) in 176 post(s)
We have decided to go with Bitfocus Companion instead of vMix's built in support for Stream Deck. The visibility might be fixed in a future update, but worse for us is that it is impossible to move vMix Stream Deck settings between projects. In the Feature Request Bitofocus Companion support (for more flexible use of the Elgato Stream Deck) I explain this further.

Companion's latest "bleeding edge build" (8f4539c, sort of 1.4 beta) now also support KeyPress, StreamStart, StreamStop, and StreamStopAll. Makes it easier to use vMix for setting up the shortcuts/scripts, and then control it from a Stream Deck. If you want to be safe with the stable 1.4 version, it supports all vMix Shortcuts by using "Run custom command", eg with "KeyPress Value=F1".
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.