logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
FrankLeggett  
#1 Posted : Saturday, March 27, 2021 2:53:46 AM(UTC)
FrankLeggett

Rank: Advanced Member

Groups: Registered
Joined: 11/22/2018(UTC)
Posts: 81
United Kingdom
Location: Worthing

Thanks: 1 times
Was thanked: 3 time(s) in 2 post(s)
Hi,

I have a simple VB.net script that I am running before the stream starts and it plays a slidelshow then a few titles that I can update. I would like to add music to this but I haven't find a way to turn on the Audio input.

I have tried
input.find("21").Function("AudioOn")
but the audio on 21 is still not going to the output

Any tips?
stigaard  
#2 Posted : Saturday, March 27, 2021 8:46:34 AM(UTC)
stigaard

Rank: Advanced Member

Groups: Registered
Joined: 5/20/2015(UTC)
Posts: 477
Man
Denmark
Location: Copenhagen, Denmark

Thanks: 339 times
Was thanked: 96 time(s) in 77 post(s)
API.Function("AudioOn", Input:=21)
FrankLeggett  
#3 Posted : Saturday, March 27, 2021 6:31:35 PM(UTC)
FrankLeggett

Rank: Advanced Member

Groups: Registered
Joined: 11/22/2018(UTC)
Posts: 81
United Kingdom
Location: Worthing

Thanks: 1 times
Was thanked: 3 time(s) in 2 post(s)
thanks that works.

I have also tried SetVolumeFade
API.Function("SetVolumeFade", Value:=0, Duration:=500, Input:=21)
but I couldn't get that to work, obviously I'm misunderstanding the syntax. Any clues?
doggy  
#4 Posted : Saturday, March 27, 2021 7:25:55 PM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 2,927
Belgium
Location: Belgium

Thanks: 172 times
Was thanked: 534 time(s) in 435 post(s)
Originally Posted by: FrankLeggett Go to Quoted Post
thanks that works.

I have also tried SetVolumeFade
API.Function("SetVolumeFade", Value:=0, Duration:=500, Input:=21)
but I couldn't get that to work, obviously I'm misunderstanding the syntax. Any clues?


Please check in the shortcut list for details !!

Value should be volumelevel , duration !
FrankLeggett  
#5 Posted : Saturday, March 27, 2021 8:13:03 PM(UTC)
FrankLeggett

Rank: Advanced Member

Groups: Registered
Joined: 11/22/2018(UTC)
Posts: 81
United Kingdom
Location: Worthing

Thanks: 1 times
Was thanked: 3 time(s) in 2 post(s)
Thanks doggy the shortcut list isn't specific.

this is what the shortcut list says
"SetVolumeFade - Set volume gradually over x milliseconds. - Value = Volume 0-100,Milliseconds - Value,Input"

I have also tried
API.Function("SetVolumeFade", Value:=0, 500, Input:=21)
That causes an error when saving the script

If I understand you correctly I should instead enter
API.Function("SetVolumeFade", Volumelevel:=0, Duration:=500, Input:=21)

The shortcut list doesn't say add "Duration" and it doesn't say "Volumelevel" basically it isn't obvious unless you have experience with syntax
Papo  
#6 Posted : Sunday, March 28, 2021 1:12:02 PM(UTC)
Papo

Rank: Member

Groups: Registered
Joined: 6/16/2020(UTC)
Posts: 24
Peru

Thanks: 7 times
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.