logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
AlanZ  
#1 Posted : Thursday, January 10, 2019 11:39:25 AM(UTC)
AlanZ

Rank: Advanced Member

Groups: Registered
Joined: 7/11/2015(UTC)
Posts: 254
Location: NJ

Thanks: 4 times
Was thanked: 34 time(s) in 28 post(s)
I started playing with a Stream Deck Mini today with v22, and all was going well (including the cool use of thumbnails).

Then I shut down vMix. When I reopened vMix, it no longer recognizes the Stream Deck.
When I press keys on the deck, I get an alert triangle over the vMix logo.

I tried uninistalling the vMix app from the stream deck, but it never gets removed from the system;

I've also tried uninstalling the stream deck and uninstalling vMix... but so far, vMix and the deck still won't talk to each other.

So, and idea how to proceed?

Thanks!
AlanZ  
#2 Posted : Sunday, January 13, 2019 3:01:51 AM(UTC)
AlanZ

Rank: Advanced Member

Groups: Registered
Joined: 7/11/2015(UTC)
Posts: 254
Location: NJ

Thanks: 4 times
Was thanked: 34 time(s) in 28 post(s)
Anyone have an insight into how I can get the stream deck working again?
grinsekatz01  
#3 Posted : Sunday, January 13, 2019 9:20:22 AM(UTC)
grinsekatz01

Rank: Member

Groups: Registered
Joined: 6/4/2018(UTC)
Posts: 13
Austria
Location: Villach

Thanks: 3 times
Was thanked: 2 time(s) in 2 post(s)
same problem here...
admin  
#4 Posted : Sunday, January 13, 2019 12:36:49 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,006
Man
Location: Gold Coast, Australia

Was thanked: 2098 time(s) in 961 post(s)
Does it work again after restarting the computer?
Also, note that when deleting/adding plugin assignments to buttons again, the shortcuts need to be updated with
the new buttons, as existing shortcuts will be assigned to the old ones.

Check the logs in Documents\vMixStorage\logs to see if there are any StreamDeck related errors.
If not, drop an email to info@vmix.com.au so we can investigate further.

doggy  
#5 Posted : Sunday, January 13, 2019 3:57:57 PM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 914
Belgium
Location: Belgium

Thanks: 57 times
Was thanked: 155 time(s) in 139 post(s)
Same problem
admin  
#6 Posted : Sunday, January 13, 2019 5:06:25 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,006
Man
Location: Gold Coast, Australia

Was thanked: 2098 time(s) in 961 post(s)
doggy,

See my previous post so we can diagnose what is happening.

Thanks
doggy  
#7 Posted : Sunday, January 13, 2019 5:18:16 PM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 914
Belgium
Location: Belgium

Thanks: 57 times
Was thanked: 155 time(s) in 139 post(s)
Originally Posted by: admin Go to Quoted Post
doggy,

See my previous post so we can diagnose what is happening.

Thanks


Yes and all it says is that the streamdeck is enabled

BUT i might have found an issue
It was not responding to the vMix Key when oe of the custom functions of the streamdeck was added (Clock / CPU)
after removing them and unplugging/pluggin in end restarting vMix the streamdeck it seems all fine again

doggy  
#8 Posted : Sunday, January 13, 2019 5:22:52 PM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 914
Belgium
Location: Belgium

Thanks: 57 times
Was thanked: 155 time(s) in 139 post(s)
oops spoke to soon

noticed when i added a vMix shortcut when vMix was not running it would not respond again after starting vMix

adding the shortcut while vMix running did the trick (after removing it first before starting vMix)

fingers crossed and hope this helps


EDIT: ok its not consistent , its a hit and miss
rnhturner  
#9 Posted : Tuesday, January 15, 2019 4:35:07 AM(UTC)
rnhturner

Rank: Member

Groups: Registered
Joined: 8/4/2018(UTC)
Posts: 13

Having the same issue. I am on vmix22....38
Waxmann  
#10 Posted : Tuesday, January 15, 2019 10:16:19 PM(UTC)
Waxmann

Rank: Newbie

Groups: Registered
Joined: 1/15/2019(UTC)
Posts: 1
Germany
Location: Ehningen

same problem
admin  
#11 Posted : Tuesday, January 15, 2019 10:52:10 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,006
Man
Location: Gold Coast, Australia

Was thanked: 2098 time(s) in 961 post(s)
Hi all,

Just letting you know we have found a bug that occurs when connecting to the Stream Deck in some situations.
A vMix 22 beta update will likely be released tomorrow to address this.

Regards,

Martin
vMix
thanks 2 users thanked admin for this useful post.
doggy on 1/15/2019(UTC), grinsekatz01 on 1/16/2019(UTC)
admin  
#12 Posted : Wednesday, January 16, 2019 12:09:26 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,006
Man
Location: Gold Coast, Australia

Was thanked: 2098 time(s) in 961 post(s)
Just posted the update here:

https://forums.vmix.com/...eview-Released#post61288

Would be interested in hearing feedback on if this resolves the issues reported in this thread.
You may need to click Find again on each shortcut in vMix to detect the new button assignments and save them.
doggy  
#13 Posted : Wednesday, January 16, 2019 6:35:32 PM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 914
Belgium
Location: Belgium

Thanks: 57 times
Was thanked: 155 time(s) in 139 post(s)
Originally Posted by: admin Go to Quoted Post
Just posted the update here:

https://forums.vmix.com/...eview-Released#post61288

Would be interested in hearing feedback on if this resolves the issues reported in this thread.
You may need to click Find again on each shortcut in vMix to detect the new button assignments and save them.


So far its looking good

Activators: = super
- 2 color option possible ? for "OFF" state
- Would there be a possibility to add an on/off image ? not a must as one can set text but could be nice
doggy  
#14 Posted : Wednesday, January 16, 2019 7:00:37 PM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 914
Belgium
Location: Belgium

Thanks: 57 times
Was thanked: 155 time(s) in 139 post(s)
exported/imported Streamdeck profiles do not respond anymore without complete reconfiguring the keys
grinsekatz01  
#15 Posted : Thursday, January 17, 2019 4:17:52 AM(UTC)
grinsekatz01

Rank: Member

Groups: Registered
Joined: 6/4/2018(UTC)
Posts: 13
Austria
Location: Villach

Thanks: 3 times
Was thanked: 2 time(s) in 2 post(s)
Good job!! After testing about 2,5 hours with 22.0.0.42, Stream Deck seems to do its job now reliable. No fails in communication, no loosing of shortcuts or activators. Connecting the Stream Deck - only works if the Stream Deck App has been started before vMix and the Deck is already plugged in. Activators are a great benefit, thanks for that.
I will use the Stream Deck also for PTZ-controll so it will be very helpful, if something like a PTZ-motionspeed shortcut can be added.
Greets
Martin
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.