logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

48 Pages«<45464748>
Options
Go to last post Go to first unread
Joeboe  
#921 Posted : Saturday, April 1, 2023 9:49:20 PM(UTC)
Joeboe

Rank: Advanced Member

Groups: Registered
Joined: 4/16/2017(UTC)
Posts: 578
Location: jamaica

Thanks: 77 times
Was thanked: 32 time(s) in 31 post(s)
Update went smoothly, but for some reason, I can not get my templates to load....all the nicely designed layout has loaded , so I know the update went well....But, my template would not load...I see "Loading Panel" , but nothing is happening
raugert  
#922 Posted : Sunday, April 2, 2023 12:35:02 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 560
Canada
Location: Manitoba

Thanks: 107 times
Was thanked: 306 time(s) in 175 post(s)
Are all your templates not loading or is it only a certain one ? If it is only a certain one, then it may be corrupt. If so, you can email it to me and I'll see if I can fix it for you.

You should also save your templates using Panel Builder Desktop version 4.0.59 to be compatible with mobile devices.
Joeboe  
#923 Posted : Sunday, April 2, 2023 10:15:55 AM(UTC)
Joeboe

Rank: Advanced Member

Groups: Registered
Joined: 4/16/2017(UTC)
Posts: 578
Location: jamaica

Thanks: 77 times
Was thanked: 32 time(s) in 31 post(s)
None are loading, old or new,,,,,I sent a copy of the template, one is a zipped file. I forgot to signed as Joeboe, but you will see the 2 files only in the email....
raugert  
#924 Posted : Sunday, April 2, 2023 10:52:00 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 560
Canada
Location: Manitoba

Thanks: 107 times
Was thanked: 306 time(s) in 175 post(s)
Hi Joeboe,

Try not to use commas in the filename. It's usually not good practice.. This is what stopped it from loading.

You also had some unused objects outside of the template window. This is usually OK (although not recommended) for Desktop templates, but it's not good for iPad templates. This will prevent he templates from resizing properly on mobile devices.
thanks 1 user thanked raugert for this useful post.
Joeboe on 4/2/2023(UTC)
Joeboe  
#925 Posted : Sunday, April 2, 2023 2:13:02 PM(UTC)
Joeboe

Rank: Advanced Member

Groups: Registered
Joined: 4/16/2017(UTC)
Posts: 578
Location: jamaica

Thanks: 77 times
Was thanked: 32 time(s) in 31 post(s)
I just noticed that there is no way to load all icons at the same time as in earlier versions of PB...I have to load one at a time....
raugert  
#926 Posted : Monday, April 17, 2023 12:29:44 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 560
Canada
Location: Manitoba

Thanks: 107 times
Was thanked: 306 time(s) in 175 post(s)
There is a new update v1.0.10 for Android Tablets and now supports Android Phones (New). Go to Play store for latest version.

- Added compatibility with Panel Builder Desktop version 4.0.59 features
- Added "Fit to Screen" option in preferences - This will resize the template to the best of it's ability if device the size is different from the original template
- Can now be used on both Tablets and Phones - Ideally the templates should be designed to fit the device size.


enjoy,
Richard
thanks 2 users thanked raugert for this useful post.
Snooker Loopy on 4/17/2023(UTC), dmwkr on 4/17/2023(UTC)
Joeboe  
#927 Posted : Monday, April 17, 2023 8:18:11 PM(UTC)
Joeboe

Rank: Advanced Member

Groups: Registered
Joined: 4/16/2017(UTC)
Posts: 578
Location: jamaica

Thanks: 77 times
Was thanked: 32 time(s) in 31 post(s)
Originally Posted by: TuesdaysLive Go to Quoted Post
Have been playing around with this app, while waiting for my co-host to help with testing some aspects of it, and I have a couple of suggestions.


It would be helpful if one could aligh the text of a 'label' to either the top or bottom, in addition to leaving it centered (see picture).
UserPostedImage

It would, also, be helpful if some buttons could be set at a different color to show that they are 'active' and 'inactive'. This would be useful when using buttons to switch between multiple camera shots, indicating which shot is the currently active shot, much like the activators are used for lighting LEDs on MIDI controllers.

BTW, I love the way the Overlay functions work within the app.



Hi, I have been using this app from day one....and I have always been able to change the colours of my buttons to show active, and preview, the same professional switchers work...actually, I have even use my own designs on the buttons, so as to look more like a few pro switchers e.g:


This is one of my simpler ideas, which I use on a 2 cam layout for a laptop, and I place it over the Preview on the UI of vMix, as I seldom use the preview... I have many more layouts which I designed over the years that I no longer use....
PB MY IDEA.jpg (495kb) downloaded 1 time(s).



Here is the layout I am now using for syncing to my iPad...I designed and layed out the UI to my likings, and comfort..

PB audio page.jpg (169kb) downloaded 4 time(s). PB video.jpg (162kb) downloaded 1 time(s).
Joeboe  
#928 Posted : Tuesday, April 18, 2023 9:13:01 AM(UTC)
Joeboe

Rank: Advanced Member

Groups: Registered
Joined: 4/16/2017(UTC)
Posts: 578
Location: jamaica

Thanks: 77 times
Was thanked: 32 time(s) in 31 post(s)
I think there is a bug or 2 .....Sometimes PB locks up and is unresponsive and has to be closed via the Task Manager, and I just found that some icons do not tally anymore....The "Set Gain" does not tally....the actual gain is working, but the Icon does not tally to show how much the gain isselected...it worked before, but I was just setting up for an assignment when I noticed it
raugert  
#929 Posted : Tuesday, April 18, 2023 10:34:58 PM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 560
Canada
Location: Manitoba

Thanks: 107 times
Was thanked: 306 time(s) in 175 post(s)
Originally Posted by: Joeboe Go to Quoted Post
I think there is a bug or 2 .....Sometimes PB locks up and is unresponsive and has to be closed via the Task Manager, and I just found that some icons do not tally anymore....The "Set Gain" does not tally....the actual gain is working, but the Icon does not tally to show how much the gain isselected...it worked before, but I was just setting up for an assignment when I noticed it


You have some fairly complex templates. If the panel becomes unresponsive, it's usually because something is not programmed correctly within an object. Possibly a button pointing to a non-existing Input or a missing icon ? Do you maybe have some unused objects outside of the panel's visible window that might be the cause ? Although there is some error checking within the app, it's difficult to check for all the permutations.

As far as the "Set Gain" function goes, it never did tally as such. I'm not sure how you had it before ?
Joeboe  
#930 Posted : Wednesday, April 19, 2023 1:27:09 AM(UTC)
Joeboe

Rank: Advanced Member

Groups: Registered
Joined: 4/16/2017(UTC)
Posts: 578
Location: jamaica

Thanks: 77 times
Was thanked: 32 time(s) in 31 post(s)
The tally on 'Set Gain' used to tally, as that is why I use it in the first place...I would set a button to different levels, (4db, 8db, 16db, etc,) so that if audio is low, I could just bump it up accordingly...look at the images I posted above...'0' is off, and the others are db levels the same way the Buses tally. This simple app has a lot more possibilities than you may think....I try some things with this app that I do not see others doing...this is a really beautiful companion to vMix, and now I have my iPads syncing.....I am flying high....(showing off)....
lyco  
#931 Posted : Wednesday, April 26, 2023 10:53:10 AM(UTC)
lyco

Rank: Member

Groups: Registered
Joined: 6/9/2021(UTC)
Posts: 10
Senegal
Location: dakar

Thanks: 12 times
Was thanked: 1 time(s) in 1 post(s)
Hello Guys, I wanted to share the templates I created for instant replay and Vmix switcher on tablet. They are working just fine..gimme your thoughts or ask any question


For the requests:
*Is it possible to have a wheel icon (like the t-bar) to emulate the ReplayFasForward/ReplayFastBackward jog-shuttle controller?
* The ReplaySwapChanel function is missing. I used a script as a turnaround. That works fine but still....That would be nice to have it


3 questions:
Am I the only who are having video stuttering when I ReplayFasForward/ReplayFastBackward? The video is not smooth at all
Is there any VPB documentation? I'm still trying to figure out how to use certains options
Why can't I have tally icon activate when I press the ReplayCamera?

Regards y'all / Bonne soirée


Basic Switcher.PNG (556kb) downloaded 13 time(s).

Basic replay.PNG (419kb) downloaded 10 time(s).
thanks 1 user thanked lyco for this useful post.
Catmix on 5/4/2023(UTC)
Joeboe  
#932 Posted : Wednesday, April 26, 2023 9:12:59 PM(UTC)
Joeboe

Rank: Advanced Member

Groups: Registered
Joined: 4/16/2017(UTC)
Posts: 578
Location: jamaica

Thanks: 77 times
Was thanked: 32 time(s) in 31 post(s)
Nice....looks great
thanks 1 user thanked Joeboe for this useful post.
lyco on 4/27/2023(UTC)
dmwkr  
#933 Posted : Thursday, April 27, 2023 3:06:42 AM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 496

Thanks: 62 times
Was thanked: 115 time(s) in 104 post(s)
Hi Richard,

I ran across an issue with PB, and don't know if it is fixable or if I am doing it wrong.

Tallys don't seem to work like expected on inputs that are PTZ inputs. I ran across it with a PTZ camera, and tested it with a new preset and vMix's Virtual PTZ feature. When using a tally in PB (eg. PVW/PGM tally) on the original PTZ input, the tally only works on the _last_ PTZ position input created. It does not work on the original PTZ input and not on the other PTZ position inputs.

I found this older post from you regarding a similar issue, but am not sure if it should behave differently: https://forums.vmix.com/...er--Controller#post69441

So, if I had a choice :) I'd like the tally on the original PTZ input to work on _every_ PTZ position input (i.e. the orginal PTZ input _and_ the PTZ positions no. 1 to x tally the original input). Second best would be, if the behaviour for the original input was like for every other input (i.e. the original PTZ input tallies the original PTZ input).

Do you think it is possible to change the behaviour? Thank you!
raugert  
#934 Posted : Saturday, April 29, 2023 1:01:52 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 560
Canada
Location: Manitoba

Thanks: 107 times
Was thanked: 306 time(s) in 175 post(s)
Originally Posted by: lyco Go to Quoted Post
Hello Guys, I wanted to share the templates I created for instant replay and Vmix switcher on tablet. They are working just fine..gimme your thoughts or ask any question


For the requests:
*Is it possible to have a wheel icon (like the t-bar) to emulate the ReplayFasForward/ReplayFastBackward jog-shuttle controller?
* The ReplaySwapChanel function is missing. I used a script as a turnaround. That works fine but still....That would be nice to have it


3 questions:
Am I the only who are having video stuttering when I ReplayFasForward/ReplayFastBackward? The video is not smooth at all
Is there any VPB documentation? I'm still trying to figure out how to use certains options
Why can't I have tally icon activate when I press the ReplayCamera?




I have not focused much on using Panel Builder to build "Replay Controllers" as much as other functions. Adding a shuttle wheel is fairly complex but I will look into this for future updates..

The missing "ReplaySwapChannel" command was an oversight . I will add it in the next update.

The "Panel Builder Documentation" is available in a link in the first post of this thread.

I will look into adding tallies for the ReplayCamera functions in the next release.

regards,
Richard


Joeboe  
#935 Posted : Saturday, April 29, 2023 1:23:58 AM(UTC)
Joeboe

Rank: Advanced Member

Groups: Registered
Joined: 4/16/2017(UTC)
Posts: 578
Location: jamaica

Thanks: 77 times
Was thanked: 32 time(s) in 31 post(s)
Hi Richard, I hope that you can fix the "Tally" on the audio gain.....it worked well with earlier versions, but now it is not working....The tallies are important so I can see if, or how much gain I have added to an input.....
I know I have some complex templates, but if you only knew what a fantastic app you have created, you will be tempted also to do complex things...this is a great app.....

joeboe says so...
raugert  
#936 Posted : Saturday, April 29, 2023 2:06:45 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 560
Canada
Location: Manitoba

Thanks: 107 times
Was thanked: 306 time(s) in 175 post(s)
Originally Posted by: dmwkr Go to Quoted Post
Hi Richard,

I ran across an issue with PB, and don't know if it is fixable or if I am doing it wrong.

Tallys don't seem to work like expected on inputs that are PTZ inputs. I ran across it with a PTZ camera, and tested it with a new preset and vMix's Virtual PTZ feature. When using a tally in PB (eg. PVW/PGM tally) on the original PTZ input, the tally only works on the _last_ PTZ position input created. It does not work on the original PTZ input and not on the other PTZ position inputs.

I found this older post from you regarding a similar issue, but am not sure if it should behave differently: https://forums.vmix.com/...er--Controller#post69441

So, if I had a choice :) I'd like the tally on the original PTZ input to work on _every_ PTZ position input (i.e. the orginal PTZ input _and_ the PTZ positions no. 1 to x tally the original input). Second best would be, if the behaviour for the original input was like for every other input (i.e. the original PTZ input tallies the original PTZ input).

Do you think it is possible to change the behaviour? Thank you!


Yes the Virtual PTZ inputs behave a little different in the API XML in that they have the same "Input Name" as the original Input.

Having said that, in the meantime, you can manually enter the "Input number" in the buttons, rather than selecting the Input Name. That should give you the Tally for the selected Virtual PTZ Input. You just won't be able to move your Inputs around without modifying your template.

I should be able to fix this in the next release.
raugert  
#937 Posted : Saturday, April 29, 2023 2:20:20 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 560
Canada
Location: Manitoba

Thanks: 107 times
Was thanked: 306 time(s) in 175 post(s)
Originally Posted by: Joeboe Go to Quoted Post
Hi Richard, I hope that you can fix the "Tally" on the audio gain.....it worked well with earlier versions, but now it is not working....The tallies are important so I can see if, or how much gain I have added to an input.....
I know I have some complex templates, but if you only knew what a fantastic app you have created, you will be tempted also to do complex things...this is a great app.....

joeboe says so...


Sorry Joeboe, I can't reproduce the tallies on the "SetGain" buttons even back to version 29. The "SetGain" command never did produce a Tally.

Maybe I'm misunderstanding what you are looking for :(

Joeboe  
#938 Posted : Thursday, July 13, 2023 8:53:24 PM(UTC)
Joeboe

Rank: Advanced Member

Groups: Registered
Joined: 4/16/2017(UTC)
Posts: 578
Location: jamaica

Thanks: 77 times
Was thanked: 32 time(s) in 31 post(s)
Any new updates for PB?.......been quite a while now....
pm  
#939 Posted : Saturday, October 14, 2023 3:21:35 AM(UTC)
pm

Rank: Advanced Member

Groups: Registered
Joined: 11/28/2015(UTC)
Posts: 182

Thanks: 10 times
Was thanked: 32 time(s) in 27 post(s)
Hi

Is it possible to display the remaining time of a video/input on a button?

Has anyone found a solution for this?

Thanks! Patrick
User is suspended until 2/12/2032 11:59:45 AM(UTC) Joeboe69  
#940 Posted : Saturday, October 14, 2023 1:08:25 PM(UTC)
Joeboe69

Rank: Member

Groups: Registered
Joined: 7/1/2023(UTC)
Posts: 16
Barbados
Location: Bridgetown

Thanks: 2 times
Why would you want a display on the button....check the bottom picture in post #927, see where the player has the display of the length of the clip, and the time remaiming.....
Users browsing this topic
48 Pages«<45464748>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.