logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Registers.

Notification

Icon
Error

13 Pages«<910111213>
Options
Go to last post Go to first unread
admin  
#201 Posted : Sunday, January 31, 2021 12:15:57 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,789
Man
Location: Gold Coast, Australia

Was thanked: 3410 time(s) in 1303 post(s)
Reinstall vMix making sure all applications are closed. This issue means vMix was not installed correctly.
(Most likely due to other programs running at a time).
Build  
#202 Posted : Tuesday, February 2, 2021 8:51:28 AM(UTC)
Build

Rank: Newbie

Groups: Registered
Joined: 1/26/2021(UTC)
Posts: 5
United States
Location: Pittsburgh

Thanks: 1 times
I closed as many things as I could find in my tray, and in CMD and still nothing.
This issue doesn't happen on any of my other computers or cloud PCs. So I think I'll just reinstall windows at this point :P.

I've been having other windows issues that I thought were unrelated but it might just be something broken deep in windows after my PC shorted out with water damage and I had to replace the motherboard, GPU, and power supply.
My issue doesn't happen in v23 which is the most puzzling part. I also have issues with render times slowly climbing and spiking over time in both v23 and v24 on any computer I use. I don't know if anyone may have insight on that.

Anyway, thanks for the suggestion, sadly it did not work, but I probably just need to full reset my PC anyway. Thanks for all your work on this amazing software though! It's a real game changer for remote production. I appreciate
all the cool v24 features that have been added.
Radiotvpat1982  
#203 Posted : Thursday, February 4, 2021 5:00:02 AM(UTC)
Radiotvpat1982

Rank: Advanced Member

Groups: Registered
Joined: 7/24/2018(UTC)
Posts: 82
Location: Carrollton, GA

Thanks: 1 times
Was thanked: 10 time(s) in 8 post(s)
Potential VMIX 24 Bug

When clipping a reply event with multiple angles selected the use of the "Play Selected Event" does not play the selected even UNLESS you manually click off of that file and then back on.

I have a video of this I can share but when you do this it goes back to the last manual event you have clipped on each time even though the last replay event just clipped is highlighted.

My typical workflow for basketball is:
-5
Pick angles to take
Play Selected

Works great in 23 but will fail every time in 24.
DWAM  
#204 Posted : Thursday, February 4, 2021 7:49:20 AM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,721
Man
France
Location: Bordeaux, France

Thanks: 243 times
Was thanked: 776 time(s) in 586 post(s)
I think the "datasources" section in the "Shortcut Function Reference" of v24 manual is missing... Or I'm too tired...
admin  
#205 Posted : Thursday, February 4, 2021 12:34:54 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,789
Man
Location: Gold Coast, Australia

Was thanked: 3410 time(s) in 1303 post(s)
Originally Posted by: Radiotvpat1982 Go to Quoted Post
Potential VMIX 24 Bug

When clipping a reply event with multiple angles selected the use of the "Play Selected Event" does not play the selected even UNLESS you manually click off of that file and then back on.


Thanks, this will be fixed in the next update.

thanks 2 users thanked admin for this useful post.
Roi on 2/4/2021(UTC), eduardocfs on 2/5/2021(UTC)
admin  
#206 Posted : Friday, February 5, 2021 2:33:21 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,789
Man
Location: Gold Coast, Australia

Was thanked: 3410 time(s) in 1303 post(s)
vMix 24.0.0.44 beta released

https://cdn.vmix.com/download/vmix24preview.exe

* Fixed replay bug where using -5, -10 etc buttons resulting in Play Events button not working immediately after.
* Fixed issues with YouTube streams and social showing scheduledStartTime error
* Improved loading speed of Add Input -> Title substantially, as large number of templates was previously taking a while to load.
* Removed some mislabelled/incorrect GT templates. Any existing presets using these templates will prompt to ask for locating these title files.
The correct templates will still exist in the Program Files (x86)\vMix\Titles folder but may be named differently, especially stinger templates.

Regards,

Martin
vMix
thanks 12 users thanked admin for this useful post.
Roi on 2/5/2021(UTC), doggy on 2/5/2021(UTC), eduardocfs on 2/5/2021(UTC), STADIORADIO on 2/5/2021(UTC), Peter1000 on 2/5/2021(UTC), stevespaw on 2/5/2021(UTC), TheMadPear on 2/6/2021(UTC), ask on 2/6/2021(UTC), monamiga on 2/6/2021(UTC), kayllastudio on 2/7/2021(UTC), raugert on 2/7/2021(UTC), stigaard on 2/7/2021(UTC)
Roi  
#207 Posted : Saturday, February 6, 2021 9:38:33 PM(UTC)
Roi

Rank: Member

Groups: Registered
Joined: 6/18/2020(UTC)
Posts: 24
Man
Philippines
Location: Manila

Thanks: 50 times
Was thanked: 3 time(s) in 3 post(s)
vMix 24.0.0.44 bug

When I am using vMix 4 hours and up the vMix is not responding. Maybe in my machine?
Streamverse.tv  
#208 Posted : Sunday, February 7, 2021 7:02:58 AM(UTC)
Streamverse.tv

Rank: Advanced Member

Groups: Registered
Joined: 4/2/2016(UTC)
Posts: 36
Austria
Location: Austria

Thanks: 9 times
Was thanked: 1 time(s) in 1 post(s)
v24.0.0.44:
I was playing around with borders.

It is possible to have very, very thick borders. eg. 9999 and more.. not that I don't like thick but those big numbers result in vMix to freeze/crash for quite a long time. Please limit the max. amount of border thickness. same for radius.

Also when cropping a Layer/Multiview the border is shifted a significant amount from where it should be.
example

(and maybe add the option to "crop with radius"?)

BenC  
#209 Posted : Sunday, February 7, 2021 8:34:20 AM(UTC)
BenC

Rank: Newbie

Groups: Registered
Joined: 2/7/2021(UTC)
Posts: 5
South Africa

How can I use SetDynamicInput and Set DynamicValue with a function that takes 2 arguments in the value?

I built a whole project assuming this would be possible...

I wanted to use a script to choose dynamic values for the 3 arguments for the function SetMultiviewOverlay


Here's my code:

One script sets the layer to be changed, for example:

Function=SetDynamicValue1&Value=2

Another sets the input to be assigned to layer2, for example:

Function=SetDynamicInput2&Input=CAM1

And finally, another script sets the value for the input we are working on, eg:

Function=SetDynamicInput3&Input=VIEW5

Then my final script would look like this:

Function=SetMultiviewOverlay&Value=Dynamic1,Dynamic2&Input=Dynamic3


I was expecting this to be interpreted as:

Function=SetMultiviewOverlay&Value=2,CAM1&Input=VIEW5


in other words, assign CAM1 to layer 2 on the input called VIEW5




But it seems this doesn't work, unless I'm doing something wrong.

I tried with scripts and with shortcuts... nothing. If I made a mistake please let me know.

If not, I'm guessing the dynamic values don't work with Functions like SetMultiviewOverlay that need 2 arguments in the Value.


Please could this be implemented/fixed?

Thanks so much.
briann55  
#210 Posted : Monday, February 8, 2021 11:34:53 AM(UTC)
briann55

Rank: Newbie

Groups: Registered
Joined: 12/1/2020(UTC)
Posts: 3
United States

There are activators to indicate a camera (or PTZ preset) input is active in either Preview or Output, but this does not work if the (camera or PTZ preset) input is active in a Multiview layer. The Multiview is the active output, but vMix does not consider the camera active even though it is being used as a layer in the Multiview. Is this a bug or is such basic functionality missing from vMix? Is it difficult to add an activator to indicate a specific input is active in a Multiview or layer? I can switch which camera
is Multiview layer 3, but there is no activator to track when the camera is active.
admin  
#211 Posted : Monday, February 8, 2021 1:01:41 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,789
Man
Location: Gold Coast, Australia

Was thanked: 3410 time(s) in 1303 post(s)
Originally Posted by: Streamverse.tv Go to Quoted Post

Also when cropping a Layer/Multiview the border is shifted a significant amount from where it should be.


Add a high resolution input instead of the colour input and it will be fine.
The colour input is only a 32x32 pixel image so cropping will not be accurate due to the small number of pixels involved.
Any other normal input will look fine by comparison.
thanks 3 users thanked admin for this useful post.
Roi on 2/8/2021(UTC), doggy on 2/8/2021(UTC), Streamverse.tv on 2/8/2021(UTC)
admin  
#212 Posted : Monday, February 8, 2021 1:02:33 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,789
Man
Location: Gold Coast, Australia

Was thanked: 3410 time(s) in 1303 post(s)
Originally Posted by: BenC Go to Quoted Post
How can I use SetDynamicInput and Set DynamicValue with a function that takes 2 arguments in the value?


It's not designed to work like that unfortunately.
The full value you wish to use including comma needs to bet set in a single dynamicvalue you can't combine multiple dynamic values together.
BenC  
#213 Posted : Monday, February 8, 2021 1:15:38 PM(UTC)
BenC

Rank: Newbie

Groups: Registered
Joined: 2/7/2021(UTC)
Posts: 5
South Africa

Hi Martin

Here's a tough one for you on this Monday morning ;-)

vMix 24 is crashing and corrupting its settings when I enable NDI outputs.
When I enable the NDIs they do seem to work fine for that session.
Also, if I enable audio NDIs, vMix restarts and enables them just fine.

But two subsequent actions immediately cause vMix to hang consistently.

(1) If I go back into the NDI settings and change something, such as turning off the NDIs, then when I hit OK, the settings dialog and the whole interface hangs.
No controls are responsive, although videos go on playing on the outputs.
There's no way to recover and I have to forcibly close vMix.

(2) The same thing happens if I don't go back into settings, but instead if I try to close vMix.
The whole interface is non-responsive and it doesn't close. Then when I restart, the NDIs are not working.

It seems to happen whatever NDIs I enable (individual NDIs on Output1 etc, or when I enable audio NDIs for all audio buses).
It happens irrespective of whether I open a preset or not.

The only solution is to delete all the settings files in user/appdata and roll back to a previous config from before I enabled the NDIs.

So I guess there's something vmix doesnt like about my hardware setup that is leading to a problem writing the settings on exit or on switching NDIs off, when NDIs are running.
I think the problem may be related to having multiple NICs, although I need that since I have lots of NDI inputs.

Here's my setup:
vMix Pro 24.0.0.44 x64 (1080 25p)
Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz
Blackmagic Ultrastudio 4k
Blackmagic Duo 2
Nvidia Geforce GTX 1070 with 4 screens (with Fullscreen enabled on 2 of them)
Audient Evo4, Behringer UMC204HD
3 x AKAI APCmini control surfaces on 3 different channels
Plus 3 NICs, 2 of which are sending and receiving NDIs. One of the NICs is 10GBE over thunderbolt.
Ive tested the NICs individually with a few NDIs running on each.
Im using good Netgear switches with a different VLAN for each NIC and group of NDIs.

Its gonna be a hard issue to replicate given that its probably hardware specific.
But its very mission critical for me for a production this week.
I have 6 Vmix licenses, including Pro and 4 x 4k.

If there's any other info you need, or any files you'd like me to send you to sort this out, I'd be happy to oblige.


Thanks
BenC
admin  
#214 Posted : Monday, February 8, 2021 2:37:38 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,789
Man
Location: Gold Coast, Australia

Was thanked: 3410 time(s) in 1303 post(s)
Hi,

You will need to remove hardware one by one and test.
It could be a completely unrelated component such as a capture card corrupting things somewhere leading to a NDI issue and vice versa.
Start by removing the 10G nic and see if the issue still occurs, then try removing capture cards.

Try to work out the very minimum setup of hardware and inputs needed to trigger the issue, by a process of elimination you should be able to work out specifically what is causing it.

Regards,

Martin
vMix
doggy  
#215 Posted : Tuesday, February 9, 2021 3:54:51 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 3,413
Belgium
Location: Belgium

Thanks: 196 times
Was thanked: 618 time(s) in 506 post(s)
Hi Martin

Would it be possible for the Settings window to show updates when switching between sections?

As an example say one is creating a script that contains a SetOutputx function and starts the script one has to close the settings window first and reopen it to check the result (debug) in the output section. Pretty confusing )took me a while to realize why the function "didn't work")

On the same line it would really be very handy and time saving if the settings Window remained open when creating shortcuts or scripts and be able to test (I know make the main window active) those shortcuts (all or not linked to a script) without having to close the settings window each time and have to reopen for edit.

Appreciate your attention
thanks 1 user thanked doggy for this useful post.
DWAM on 2/9/2021(UTC)
DWAM  
#216 Posted : Tuesday, February 9, 2021 4:35:35 AM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,721
Man
France
Location: Bordeaux, France

Thanks: 243 times
Was thanked: 776 time(s) in 586 post(s)
Quote:
Would it be possible for the Settings window to show updates when switching between sections?


Yep +1000 for that.

The need to close and reopen after each update (in outputs, shortcuts, scripts and activators tabs) is really something that can be improved imho...

It's indeed very confusing when trying to set outputs via the API and the output tab does not reflect in real time which inputs/outputs are currently selected.

Maybe a click on a(nother) tab could trigger a global refresh ? This would be great (and time saving)
thanks 1 user thanked DWAM for this useful post.
doggy on 2/9/2021(UTC)
admin  
#217 Posted : Tuesday, February 9, 2021 12:11:24 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,789
Man
Location: Gold Coast, Australia

Was thanked: 3410 time(s) in 1303 post(s)
For important technical reasons this will not be possible. The settings window should not be kept open when using shortcuts, triggers or scripts.
Also, another reminder this is not a thread for feature requests.
thanks 2 users thanked admin for this useful post.
Roi on 2/9/2021(UTC), doggy on 2/9/2021(UTC)
Rinsky  
#218 Posted : Tuesday, February 9, 2021 10:20:40 PM(UTC)
Rinsky

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2013(UTC)
Posts: 450

Thanks: 38 times
Was thanked: 37 time(s) in 33 post(s)
I was playing around with the new IR input intensively for the last couple of days to give you some (hopefully final) feedback on it. I will list some things that came to my mind, that are still missing to have the most flexible workflows possible:

1. highlight active channel(s) with a indicator around the monitor windows (already mentioned in a previous post)
2. make it possible to create an event by pressing "mark out" first (already mentioned in a previous post)
3. there is no shortcut for "swap cameras between A and B"
4. there need to be more transition options than just a simple cut
5. there also needs to be a "automatically play with transition" option between A and B
6. channel control needs to stay with the "active" channel/active channel needs to be swapped as well
7. ability to uncheck all camera angles to choose the camera angles by just clicking on the A or B camera angle buttons.

Advanced/professional Workflow would be like this for example:

Events happens -> "Mark Out" -> Scroll back to the desired In Point and "Mark In" -> choose camera angle for Channel A -> Playback Channel A -> go to Channel B -> choose camera angle for Channel B and find the right in point -> wait until camera angle from channel A is finished and then swap/cut/fade/auto to channel B with different camera angle


The great thing about it is, that this way a completely professional and fast workflow would be possible and afterwards you could always create cliplists/playlists/highlight reels in a different event folder and then check the camera angles you want to have and copy the events etc. to make a playlists for intermissions or the end of the game.


Btw: I was working with the X-Keys Replay controller and I am still looking to find the perfect setup for it. Will share it when the new replay system is finished and me shortcut/button configuration setup is also done.
thanks 2 users thanked Rinsky for this useful post.
pm on 2/9/2021(UTC), stevespaw on 2/10/2021(UTC)
admin  
#219 Posted : Wednesday, February 10, 2021 1:21:28 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,789
Man
Location: Gold Coast, Australia

Was thanked: 3410 time(s) in 1303 post(s)
Hi,

You will need to submit a feature request for these, as the time for feature requests in 24 is now over as we work towards the final release.
For the Mark Out option, that has already been supported since the first release of replay, press Mark In for the out point and Mark Out for the input and it will work.

Regards,

Martin
vMix
thanks 1 user thanked admin for this useful post.
Roi on 2/10/2021(UTC)
Rinsky  
#220 Posted : Wednesday, February 10, 2021 1:42:07 AM(UTC)
Rinsky

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2013(UTC)
Posts: 450

Thanks: 38 times
Was thanked: 37 time(s) in 33 post(s)
Yeah, I was expecting it to be kinda late.

And regarding the Mark Out option:

I can't get the Mark Out to work in 24. Is this maybe a bug or just my stupidity?
Users browsing this topic
13 Pages«<910111213>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.