logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Maximus  
#1 Posted : Friday, February 2, 2024 4:53:11 AM(UTC)
Maximus

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2012(UTC)
Posts: 174
Location: Barbados

Thanks: 2 times
Was thanked: 24 time(s) in 24 post(s)
Hi,
I am looking for some guidance on remedying NDI drops on a new Laptop. The peculiar thing is it only drops when the source is from a vMix output (1-4). Any other NDI source such as Birddog cameras, Cinergy Playout Software, Kiloview SDI to NDI Converter are all perfect. It is only vMix sources that have a problem. I have ruled out the network as any other computer on the same network and cable works perfectly. I have even tried external USB to ethernet adapters with no luck.
The computer is a Lenovo 13th Gen Intel(R) Core(TM) i9-13900HX with 32Gigs of Ram and a 4080 graphics card running Windows 11 Home.

I have been struggling with this for a few months trying to resolve the problem. I have reinstalled Windows, made sure the Network driver was current, updated graphic drivers etc. I was running vMix26, but have since upgraded to vMix27, no change. The Problem also shows up on Studio Monitor.

Any suggestions are welcome.

Regards
mavik  
#2 Posted : Thursday, February 8, 2024 6:01:19 AM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 1,162
Man
Location: Germany

Thanks: 3 times
Was thanked: 167 time(s) in 149 post(s)
If the problem shows even up on studio monitor this must be a lack of resources. vMix is using full NDI as outputs. They are high bandwidth. Maybe take a look at the network utilization.
pm  
#3 Posted : Thursday, February 8, 2024 6:33:05 AM(UTC)
pm

Rank: Advanced Member

Groups: Registered
Joined: 11/28/2015(UTC)
Posts: 182

Thanks: 10 times
Was thanked: 32 time(s) in 27 post(s)
What's the negotiated speed of the network adapter? Is it 1GBit/s?

What type and chipset is the builtin network adapter?
Maximus  
#4 Posted : Friday, February 9, 2024 10:25:07 PM(UTC)
Maximus

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2012(UTC)
Posts: 174
Location: Barbados

Thanks: 2 times
Was thanked: 24 time(s) in 24 post(s)
Originally Posted by: mavik Go to Quoted Post
If the problem shows even up on studio monitor this must be a lack of resources. vMix is using full NDI as outputs. They are high bandwidth. Maybe take a look at the network utilization.


Hi Mavik,
It is unlikely a lack of resources as the specs of the computer are quite high (see original posts for specs) and this happens with only 1 input to the computer. Using the same network-switch-cable combination on a much lower specked computer the NDI feed has no problem, so it is not a network issue as far as I can tell. Also, non vMix NDI sources (Birddog, Kiloview etc.) work perfectly well, it is only vMix NDI sources that exhibit this issue. The problem exists on any vMix source from any computer on the network, so it is not from 1 source or 1 specific computer. So long as it is a vMix souce the drops are very high. I have tried Birddog Dynamo to view the traffic, and I can see all the drops on the vMix souces while every other NDI source is perfect.

Maxi
Maximus  
#5 Posted : Friday, February 9, 2024 10:29:06 PM(UTC)
Maximus

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2012(UTC)
Posts: 174
Location: Barbados

Thanks: 2 times
Was thanked: 24 time(s) in 24 post(s)
Originally Posted by: pm Go to Quoted Post
What's the negotiated speed of the network adapter? Is it 1GBit/s?

What type and chipset is the builtin network adapter?


Hi, it is a 1Gb adapter and I have also tried a 2.5Gb adapter. The default 1Gb adapter is Realtek chipset. As indicated, it is only with vMix sources that the issue exist. Othjer non vMix NDI sources are perfectly fine.

Maxi
mavik  
#6 Posted : Thursday, March 28, 2024 11:36:24 PM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 1,162
Man
Location: Germany

Thanks: 3 times
Was thanked: 167 time(s) in 149 post(s)
Have you tried updating the vMix NDI files manually to the latest available?
bostar  
#7 Posted : Wednesday, July 10, 2024 7:47:02 PM(UTC)
bostar

Rank: Newbie

Groups: Registered
Joined: 9/29/2022(UTC)
Posts: 1
Taiwan, Province Of China
Location: taipei

Sorry to rehash the thread. Did you find a solution for this as I have the same problem. Any NDI source to vMix plays perfectly but if NDI source is from another vMix PC, it starts to stutter.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.