logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

2 Pages<12
Options
Go to last post Go to first unread
JAIRODJ  
#21 Posted : Saturday, October 23, 2021 5:41:29 AM(UTC)
JAIRODJ

Rank: Advanced Member

Groups: Registered
Joined: 9/1/2015(UTC)
Posts: 120
Man
Location: Ecuador

Thanks: 2 times
Was thanked: 15 time(s) in 11 post(s)
hi, version 1.0.8 has bugs
- does not connect with vmix
- does not close the functions combobox, after selecting the command.
raugert  
#22 Posted : Saturday, October 23, 2021 5:46:46 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 504
Canada
Location: Manitoba

Thanks: 92 times
Was thanked: 270 time(s) in 152 post(s)
thanks Jairodj !!

I will remove the update for now until further testing .

regards,
Richard
raugert  
#23 Posted : Sunday, October 24, 2021 1:48:50 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 504
Canada
Location: Manitoba

Thanks: 92 times
Was thanked: 270 time(s) in 152 post(s)
Here is a new update.

https://cli.re/vMix-Script-Builder-1.0.9

changelog:

- URLEncoded Script now updates when changing fields
- can now copy selected text from compiled script
- added new commands in vMIx24
thanks 3 users thanked raugert for this useful post.
Joeboe on 10/24/2021(UTC), jet on 10/26/2021(UTC), billh2020 on 11/29/2021(UTC)
chaosmoon  
#24 Posted : Wednesday, October 27, 2021 6:24:36 PM(UTC)
chaosmoon

Rank: Newbie

Groups: Registered
Joined: 2/23/2021(UTC)
Posts: 3
Netherlands
Location: Amsterdam

Thanks: 2 times
Originally Posted by: raugert Go to Quoted Post
@ chaosmoon
..you can choose to disable the "Enhanced Security" option in the vMix Web settings. This should allow the Dynamic scripts to run again.

This worked, thanks!
lance_05  
#25 Posted : Thursday, January 27, 2022 1:04:08 PM(UTC)
lance_05

Rank: Newbie

Groups: Registered
Joined: 1/15/2022(UTC)
Posts: 4
Philippines
Location: Manila

Thanks: 1 times
I'm encountering error when using the SetOutput script generated.

It generates the following:
Function=SetOutput4&Input=VIDEO

The one I saw working from the forum is:
Function=SetOutput4&Value=Input&Input=VIDEO
raugert  
#26 Posted : Thursday, January 27, 2022 3:08:32 PM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 504
Canada
Location: Manitoba

Thanks: 92 times
Was thanked: 270 time(s) in 152 post(s)
The "SetOutput4" command requires the word "Input" in the value field when selecting an Input. (see Shortcut chapter in vMix User Guide) https://www.vmix.com/help24/ . You need to include this in the "Value" field of the Script Builder.
lance_05  
#27 Posted : Thursday, January 27, 2022 3:25:29 PM(UTC)
lance_05

Rank: Newbie

Groups: Registered
Joined: 1/15/2022(UTC)
Posts: 4
Philippines
Location: Manila

Thanks: 1 times
Originally Posted by: raugert Go to Quoted Post
The "SetOutput4" command requires the word "Input" in the value field when selecting an Input. (see Shortcut chapter in vMix User Guide) https://www.vmix.com/help24/ . You need to include this in the "Value" field of the Script Builder.


Right...
So in the builder, i need to:

1. Select SetOutput4
2. Leave Input Field as blank
3. Set its Value to INPUT&INPUT=VIDEO

For it to generate the same:

Function=SetOutput4&Value=INPUT&INPUT=VIDEO

I just expected that the builder will automatically re-arrange the fields or disable any field to match the vmix function's syntax.

Anyway, thank you so much for creating this app. This app is a huge help to us who just started using VMIX scripting.
raugert  
#28 Posted : Friday, January 28, 2022 2:35:33 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 504
Canada
Location: Manitoba

Thanks: 92 times
Was thanked: 270 time(s) in 152 post(s)
@lance_05

It is a bit confusing at first when using some of the shortcuts :)

The fields required for SetOutput4 in the Script Builder are actually:

1. Command = SetOutput4
2. Input = VIDEO
3. Value = Input (You have a choice of Output, Preview, Multiview, Input) In your case you need to enter the word "Input" as you are directing a specific Input to Output4
thanks 1 user thanked raugert for this useful post.
lance_05 on 1/28/2022(UTC)
raugert  
#29 Posted : Sunday, February 6, 2022 1:21:50 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 504
Canada
Location: Manitoba

Thanks: 92 times
Was thanked: 270 time(s) in 152 post(s)
UPDATE: Version 1.0.10

https://cli.re/vMix-Script-Builder-1.0.10

- fixed a bug where the "Input field" was not responding correctly if the "Port" number was changed from the default 8088
thanks 1 user thanked raugert for this useful post.
MickeyMJJ on 2/8/2022(UTC)
rnhturner  
#30 Posted : Sunday, March 13, 2022 4:44:15 AM(UTC)
rnhturner

Rank: Advanced Member

Groups: Registered
Joined: 8/4/2018(UTC)
Posts: 30

Thanks: 2 times
The following selection should not have a space in it:
SetImage VisibleOn

It works using SetImageVisibleOn

This is showing up for a few of those selections.
raugert  
#31 Posted : Sunday, March 13, 2022 6:04:48 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 504
Canada
Location: Manitoba

Thanks: 92 times
Was thanked: 270 time(s) in 152 post(s)
Thanks for the heads up. I’ll look into it.

Richard
raugert  
#32 Posted : Tuesday, March 22, 2022 2:14:04 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 504
Canada
Location: Manitoba

Thanks: 92 times
Was thanked: 270 time(s) in 152 post(s)
Update Version 1.0.11

https://cli.re/vMix-Script-Builder-1.0.11


- fixed SetImageVisibleOn
- added new commands for vMix25
thanks 1 user thanked raugert for this useful post.
eduardocfs on 3/22/2022(UTC)
Joeboe  
#33 Posted : Sunday, May 1, 2022 12:45:36 AM(UTC)
Joeboe

Rank: Advanced Member

Groups: Registered
Joined: 4/16/2017(UTC)
Posts: 520
Location: jamaica

Thanks: 64 times
Was thanked: 30 time(s) in 29 post(s)
Hi all, I am looking for a simple script where, when I play a clip by just clicking they play on the input window, it fades the audio up at about 6 secs., and when I pause it again, it fades it back to '0' at about the same rate
doggy  
#34 Posted : Sunday, May 1, 2022 2:00:53 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 4,219
Belgium
Location: Belgium

Thanks: 244 times
Was thanked: 758 time(s) in 618 post(s)
Originally Posted by: Joeboe Go to Quoted Post
Hi all, I am looking for a simple script where, when I play a clip by just clicking they play on the input window, it fades the audio up at about 6 secs., and when I pause it again, it fades it back to '0' at about the same rate



Check for play/pause state from the API XML of the clip and combine with the setvolumefade function(see shortcuts)
There is a post somewhere in this forum that has lots of scripting examples
raugert  
#35 Posted : Tuesday, July 12, 2022 1:57:55 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 504
Canada
Location: Manitoba

Thanks: 92 times
Was thanked: 270 time(s) in 152 post(s)
Update version 1.0.12

https://cli.re/vMix-Script-Builder-1.0.12

- Input field is now editable when using Input numbers rather than Input names.
Users browsing this topic
2 Pages<12
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.