logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
stojajir  
#1 Posted : Friday, July 5, 2024 10:30:20 PM(UTC)
stojajir

Rank: Newbie

Groups: Registered
Joined: 2/18/2019(UTC)
Posts: 2

Was thanked: 1 time(s) in 1 post(s)
Hello fellow vMix experts,

I am reaching out with a complicated and serious problem.

The Issue:
NDI input is dropping many frames on new Intel CPUs with E-cores on Windows 11 (11th gen and newer).
Why I think this is due to new intel laptops? I have ruled out every other possibility and tried numerous troubleshooting tips over the last few months. I have been using NDI for several years without major issues (most problems were network-related, but I don't believe this one is).

Steps to Replicate and Solution:
I have two identical laptops: Lenovo Legion 5 (15IAH7H) - Intel Core i7 12700H, 16GB DDR5 RAM, NVIDIA GeForce RTX 3060 6GB.
Both laptops are connected to the same router (MikroTik hAP ac2) on gigabit network.
On both laptops, I play the same video and send it via Output 1 to NDI.
Both laptops then play each other’s NDI source.
In vMix statistics, frames are dropping significantly.

Solution is to disable Core Parking and run vMix on Performance cores only.

Disable Core Parking:
  • Open Command Prompt (Win+R, type "cmd").
  • Copy and execute this command: powercfg -attributes SUB_PROCESSOR CPMINCORES -ATTRIB_HIDE.
  • Go to Control Panel -> Hardware and Sound -> Power Options -> Change plan settings -> Change advanced power settings -> Processor power management -> Processor performance core parking min cores -> Set to 100%.

    Run vMix on Performance Cores Only:
  • Launch vMix.
  • Open Task Manager.
  • In the "Details" tab, find vMix.exe -> right-click -> Set affinity.
  • Select only the first set of processor cores. The exact number depends on the processor and the number of P and E cores it has.
  • When these settings are applied, the issue is resolved and NDI works as expected. However, setting the affinity in Task Manager must be done every time vMix is launched or restarted.
Demonstration video: link

Excluded Problems:
vMix is using the dedicated NVIDIA drivers (newest game-ready drivers).
The laptop is set to the Best Performance power plan.
Network issues: I am almost certain this is NOT a network issue. The link is always 1Gbps when using NDI, and I've tried multiple different cables, unmanaged gigabit switches, the MikroTik router hAP ac2 and ax3, as well as different NICs (USB-C gigabit adapter). None of these changes made a difference.
Advanced adapter settings in Windows: Energy-Efficient Ethernet, Green Ethernet, and other power-saving functions were disabled without any effect.

Confirmation:
I have another set of older laptops without E-cores: Lenovo Legion Y530-15ICH - i7 8750H, GTX 1050 Ti, 16GB RAM. This issue is not present on these laptops at all.
I replicated the same setup in the exact environment and connection. They are also running the same Windows 11 version.
Demonstraion video: link

My Best Guess:
This might be an issue with the new Windows 11 scheduler, allowing vMix to use E-cores. I don't fully understand how this works, but I would assume that vMix should tell Windows not to use E-cores. Maybe Martin could shed some light on how this works.

I have tried to contact vMix support directly, but they were not helpful. They insisted that the issue is network-related.
Has anyone else encountered this issue? Could anyone please try to replicate it with the same setup?

Thank you very much for your cooperation and any tips you might have.

George
mavik  
#2 Posted : Monday, July 8, 2024 3:43:57 AM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 1,164
Man
Location: Germany

Thanks: 3 times
Was thanked: 167 time(s) in 149 post(s)
I was thinking that the hap is maybe not bringing the 1G in routing but if you say you exchanged the computers and the issue went away then it's obvious the computers itself.
I only run vMix on Xeon's (more lanes) and have zero issues with NDI. Even after a full day of 8-10 hours streaming the stats in vMix show 10-20 packets dropped, if not zero.
You already gone very deep into the windows settings as well. Maybe create a script that runs the necessary settings on start up so you don't have to worry.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.