logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
knbPixels  
#1 Posted : Thursday, June 6, 2024 2:45:21 AM(UTC)
knbPixels

Rank: Advanced Member

Groups: Registered
Joined: 2/7/2024(UTC)
Posts: 31
United States

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
I have a participant that will be sharing screen from a mobile phone for a demo. I want to mask their screen share to give it rounded corners. If I use the mask I created on a Zoom camera input, it works perfectly. If I use the mask on the live screen share from the phone, the mask gets compressed horizontally by a huge factor. I'm guessing it has something to do with the screen share not being 1920x1080. If I take a snapshot of that live share and mask it, it works fine. I tried to create a new input and put that live sharing input on it as a layer, and then mask it, but that doesn't work because the masking only effects the actual input (layer 0), and not any of the other layers.

How can I solve this issue?

Attaching pic of the phone share snap that does work, alongside the live input which doesn't work. image (8).png (408kb) downloaded 4 time(s).
knbPixels  
#2 Posted : Monday, June 10, 2024 11:53:06 PM(UTC)
knbPixels

Rank: Advanced Member

Groups: Registered
Joined: 2/7/2024(UTC)
Posts: 31
United States

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
Bump
dmwkr  
#3 Posted : Tuesday, June 11, 2024 4:05:10 PM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 524

Thanks: 62 times
Was thanked: 122 time(s) in 111 post(s)
Have you tried sending it to a mix input and masking the mix input?
knbPixels  
#4 Posted : Tuesday, June 11, 2024 10:37:56 PM(UTC)
knbPixels

Rank: Advanced Member

Groups: Registered
Joined: 2/7/2024(UTC)
Posts: 31
United States

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: dmwkr Go to Quoted Post
Have you tried sending it to a mix input and masking the mix input?



That seems to be working, so a decent work around at least...thanks for the idea!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.