logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
crnaman77  
#1 Posted : Thursday, February 22, 2024 9:43:00 AM(UTC)
crnaman77

Rank: Newbie

Groups: Registered
Joined: 2/22/2024(UTC)
Posts: 4
United States
Location: State

Thanks: 1 times
So, I have created "input at this position" inputs for all the ptz presets of all the cameras and assigned them each one to a stream deck button to load in preview. This all works fine. (stream deck xl, each long row represents one camera with an empty button on the end)

Then I was trying to create an activator for each input to turn the last button red when it is live, as a visual cue that that camera is live and not to try to ptz it.

The first activator I made works, but any activator I make after that for the other inputs do not work for the same button.

Why can't we have multiple activators for one button?

Thanks.
doggy  
#2 Posted : Thursday, February 22, 2024 4:32:34 PM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 5,078
Belgium
Location: Belgium

Thanks: 284 times
Was thanked: 920 time(s) in 759 post(s)
Originally Posted by: crnaman77 Go to Quoted Post
So, I have created "input at this position" inputs for all the ptz presets of all the cameras and assigned them each one to a stream deck button to load in preview. This all works fine. (stream deck xl, each long row represents one camera with an empty button on the end)

Then I was trying to create an activator for each input to turn the last button red when it is live, as a visual cue that that camera is live and not to try to ptz it.

The first activator I made works, but any activator I make after that for the other inputs do not work for the same button.

Why can't we have multiple activators for one button?

Thanks.


Try this

https://forums.vmix.com/...ng-for-Dummies#post98564

should do the trick

but why not the button for the specific camera PTZ position ? Then you have indication of Camera AND position
dmwkr  
#3 Posted : Thursday, February 22, 2024 7:10:53 PM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 513

Thanks: 62 times
Was thanked: 119 time(s) in 108 post(s)
Originally Posted by: crnaman77 Go to Quoted Post
Then I was trying to create an activator for each input to turn the last button red when it is live, as a visual cue that that camera is live and not to try to ptz it.


It is also possible to set an "OnTransitionIn" trigger on your virtual inputs, that sets the parent input (original input of the PTZ camera) as "ActiveInput". Then just use the activator for the parent input on your buttons. (Of course, this only works if you don't have individual Color Corrections on the virtual inputs.)

Also, Bitfocus Companion allows for multiple activators on one button.
thanks 1 user thanked dmwkr for this useful post.
crnaman77 on 2/22/2024(UTC)
crnaman77  
#4 Posted : Thursday, February 22, 2024 10:38:59 PM(UTC)
crnaman77

Rank: Newbie

Groups: Registered
Joined: 2/22/2024(UTC)
Posts: 4
United States
Location: State

Thanks: 1 times
Quote:
but why not the button for the specific camera PTZ position ?


Doggy, I have thumbnail enabled for preview of ptz shot on the ptz button and vmix insists this is priority and will not allow color change to stick.

Dmwkr, your suggestion is working and very simple, adding to that a delay longer than the transition time. Thanks.
doggy  
#5 Posted : Thursday, February 22, 2024 11:07:59 PM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 5,078
Belgium
Location: Belgium

Thanks: 284 times
Was thanked: 920 time(s) in 759 post(s)
Originally Posted by: crnaman77 Go to Quoted Post
Quote:
but why not the button for the specific camera PTZ position ?


Doggy, I have thumbnail enabled for preview of ptz shot on the ptz button and vmix insists this is priority and will not allow color change to stick.



Ok as you failed to mention that , but using the DynamicInputx works just fine (tested) for your end row button

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.