logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
kismetgerald  
#1 Posted : Thursday, November 17, 2022 4:25:28 AM(UTC)
kismetgerald

Rank: Member

Groups: Registered
Joined: 4/3/2020(UTC)
Posts: 14
United States
Location: Severn

Thanks: 1 times
Hi Folks,

Quick question - what am I doing wrong with my audio setup? Whenever I go to a specific audio input and I turn down that input's headphone mix, it does not have any effect and I still hearing that input in my headphone.

I'm using a Behringer UMC404HD digital audio interface, and this is how I have things routed (see screenshot as well):

  • vMix Master --> Default Playback Device

  • vMix Headphone --> Wireless Headphone

  • vMix Bus A --> Main Out L/R

  • vMix Bus B --> Line 1 (Virtual Audio Cable)


During my production, I often set the default playback device of the computer to the Wireless headphone so that I can monitor things in my headphone. But now that I'm writing this out, I'm wondering if perhaps I'm shooting myself in the foot by doing this.

Would I be better off explicitly setting the Master bus to None, since I already have Bus A routing audio to the Main Out L/R of the UMC404HD?

vMix Audio Output Setup
kismetgerald  
#2 Posted : Thursday, November 17, 2022 9:00:06 AM(UTC)
kismetgerald

Rank: Member

Groups: Registered
Joined: 4/3/2020(UTC)
Posts: 14
United States
Location: Severn

Thanks: 1 times
I managed to answer my own question. I needed to set the Master to None. Posting a screenshot in case someone finds it useful.

vMix Audio Output Setting
elvis55  
#3 Posted : Thursday, November 17, 2022 6:41:26 PM(UTC)
elvis55

Rank: Advanced Member

Groups: Registered
Joined: 3/17/2017(UTC)
Posts: 395
Switzerland
Location: Luzern - Schweiz

Thanks: 59 times
Was thanked: 54 time(s) in 48 post(s)
Select the output to send the Master audio mix to. This is the default audio mix
used for streaming, recording and external output.

Select the output to send the Headphones audio mix to.
This mix is the same as Master Output except when Solo is enabled on an input.
When Solo is enabled on an input only that input will be heard.

https://www.vmix.com/hel...ex.htm?AudioOutputs.html
kismetgerald  
#4 Posted : Friday, November 18, 2022 1:29:01 AM(UTC)
kismetgerald

Rank: Member

Groups: Registered
Joined: 4/3/2020(UTC)
Posts: 14
United States
Location: Severn

Thanks: 1 times
Thanks @elvis55.

From my usage experience I can tell that audio will always be present on the Master bus and will always make it to the Recording and Stream destinations, as it's internal to vMix. Assigning an output for Master is only necessary if one actually needs to the sound to exit vMix and make it to another audio device (usually external to vMix). However, in my case, I'm dedicating Bus A for this, so assigning the same output to Master was creating duplication for me and which manifested in me not being able to use the input headphone control like it was meant.

So the solution, in my situation, was to simply set Master to None.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.