logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
nomski  
#1 Posted : Friday, September 3, 2021 6:06:13 PM(UTC)
nomski

Rank: Advanced Member

Groups: Registered
Joined: 10/14/2016(UTC)
Posts: 48
Location: Sheffield

Having a real issue getting 1080p50 to work smoothly over NDI and wondered if anyone had any insights/suggestions to get us sorted.

Current setup for testing is BMD URSA Broadcast at 1080p50
Camera goes SDI into a Kiloview E1 encoder set to NDI HX, NDI HX2, unicast or multicast makes no difference
Encoder goes into a Netgear M4250 24 port switch with the NDI profile enabled on the ports
Laptop is a gaming laptop with an RTX 2060, i7, 32GB RAM, SSD etc.
Laptop is into the Netgear switch also with NDI profile enabled
Laptop has Gigabit port
vMix preset has nothing in it except the camera input and is set to high performance mode

Issues/tests so far:
If I open the statistics view, it sheds frames at an alarming rate and therefore we get stuttering feed
If I step it down to 30p or 50i, it's fine
If I tick the "increase buffer" box before adding the input it runs fairly ok at 50p but still drops a few frames

Based on the fact that if I lower the rate of data (via frame reductions) or increase the buffer it gets better it seems like I'm having some kind of buffering issue. What I don't know is what the buffer is (RAM etc.) or how big or small it can be. And also if there is a setting/spec we can change that will increase the throughput that means that we do not need to run the increased buffer at all.

Any help would be greatly appreciated!
nomski  
#2 Posted : Monday, September 6, 2021 10:54:56 PM(UTC)
nomski

Rank: Advanced Member

Groups: Registered
Joined: 10/14/2016(UTC)
Posts: 48
Location: Sheffield

I'm assuming that's a negative.
roverradio  
#3 Posted : Tuesday, September 7, 2021 2:52:25 PM(UTC)
roverradio

Rank: Advanced Member

Groups: Registered
Joined: 5/6/2016(UTC)
Posts: 64
Location: CLE, OH USA

Was thanked: 2 time(s) in 2 post(s)
What does vmix report GPU/CPU stats as (lower left)? What does performance monitor report NIC throughput as?

There's definitely a major issue somewhere in your chain. I'm sure someone has written up an NDI troubleshooting/performance checklist somewhere.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.