logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
ocrtalk  
#1 Posted : Thursday, July 29, 2021 7:26:27 AM(UTC)
ocrtalk

Rank: Member

Groups: Registered
Joined: 2/5/2021(UTC)
Posts: 26
United States
Location: Fort Worth

Thanks: 3 times
I may be trying to sync my videos with the wrong tools, so please correct me if I'm wrong. I've got multiple RTMP inputs and the video is not lined up (testing by raising my hand to see if all cameras match). I've used the Delay setting in the Advanced tab for the input. This works but then it creates this weird color overlay where the original video is like a ghost image over the new delayed version. What am I doing wrong here? vMix Capture 28 July 2021 16-21-56.png (2,435kb) downloaded 1 time(s).
mavik  
#2 Posted : Thursday, July 29, 2021 10:16:28 PM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 746
Man
Location: Germany

Thanks: 3 times
Was thanked: 115 time(s) in 103 post(s)
I use this video to sync up devices

The video delay uses your local system for the temp storage of data. That might be an issue.
ocrtalk  
#3 Posted : Friday, July 30, 2021 2:09:03 AM(UTC)
ocrtalk

Rank: Member

Groups: Registered
Joined: 2/5/2021(UTC)
Posts: 26
United States
Location: Fort Worth

Thanks: 3 times
Further development: I can pull up the feeds in VLC and all videos are in sync with each other, but in VMix they still are not.

If I turn off the audio in Larix Braodcaster, Vmix plays all videos in sync with each other.
ocrtalk  
#4 Posted : Friday, July 30, 2021 2:23:26 AM(UTC)
ocrtalk

Rank: Member

Groups: Registered
Joined: 2/5/2021(UTC)
Posts: 26
United States
Location: Fort Worth

Thanks: 3 times
I upped the RTMP's buffer size and this seems to have taken care of the issue! Whoo!
2021-07-29_11-22-09.png (6kb) downloaded 1 time(s).
ocrtalk  
#5 Posted : Friday, July 30, 2021 3:08:46 AM(UTC)
ocrtalk

Rank: Member

Groups: Registered
Joined: 2/5/2021(UTC)
Posts: 26
United States
Location: Fort Worth

Thanks: 3 times
After all of that, all is good. But now I do have multiple camera sources coming in. Some from phones over RTMP and some Mevo Start cameras over the local network. The delay on the RTMP sources is longer than the Mevo cameras. To get them synced up, is the delay in the Advanced Input options the best way to do this?
ocrtalk  
#6 Posted : Tuesday, August 3, 2021 11:02:56 PM(UTC)
ocrtalk

Rank: Member

Groups: Registered
Joined: 2/5/2021(UTC)
Posts: 26
United States
Location: Fort Worth

Thanks: 3 times
Still looking for an answer to this. Anyone know the best way to sync up NDI/RTMP inputs? or to add delay to certain inputs?
mavik  
#7 Posted : Wednesday, August 4, 2021 5:09:04 AM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 746
Man
Location: Germany

Thanks: 3 times
Was thanked: 115 time(s) in 103 post(s)
One option is to NTP all devices to the same time.
Then the sync should be done by the delay.
ocrtalk  
#8 Posted : Wednesday, August 4, 2021 5:27:05 AM(UTC)
ocrtalk

Rank: Member

Groups: Registered
Joined: 2/5/2021(UTC)
Posts: 26
United States
Location: Fort Worth

Thanks: 3 times
Thank you! I believe this is what I've been searching for. Is NTP something that can be done with software, or just hardware?

mavik  
#9 Posted : Wednesday, August 4, 2021 5:21:20 PM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 746
Man
Location: Germany

Thanks: 3 times
Was thanked: 115 time(s) in 103 post(s)
NTP is just by software. Make sure you use the same server for all the equipment.
thanks 1 user thanked mavik for this useful post.
ocrtalk on 8/4/2021(UTC)
ocrtalk  
#10 Posted : Wednesday, August 4, 2021 9:56:57 PM(UTC)
ocrtalk

Rank: Member

Groups: Registered
Joined: 2/5/2021(UTC)
Posts: 26
United States
Location: Fort Worth

Thanks: 3 times
So how do you handle that when some of the cameras are phones sending their feed over cell signal with Larix Broadcaster?
Users browsing this topic
Similar Topics
Dropped Frames, DueToSourceFrameRate, MAJOR Audio/Video Sync Issues when Editing, Please help! (General Discussion)
by Ragnvald 3/20/2017 1:33:18 AM(UTC)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.