logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Martin Block  
#1 Posted : Thursday, August 6, 2020 11:20:30 AM(UTC)
Martin Block

Rank: Member

Groups: Registered
Joined: 7/17/2020(UTC)
Posts: 13
Philippines
Location: Makati City

Thanks: 4 times
Hi,

I am trying to work with SRT for the first time.
I watched all tutorials but even when I follow all instructions to the letter, nothing happens.

I have the Larix iOS app and I am connected to my Wifi network A.
I set up the SRT connection to the public IP of my vMix PC, running on my network B, using port 11001.
On my vMix PC, I enabled SRT in Settings and selected Rendezvous mode with hostname being the public IP of my network A and I also selected port 11001 (should not matter that it is the same)
I also selected the same in the input settings (public IP of my network A and I also selected port 11001)

I disabled the firewall in my router (there is no port forwarding feature)
Unfortunately, nothing happens.

Anybody knows what I am doing wrong?

Thanks in advance

Cheers
admin  
#2 Posted : Thursday, August 6, 2020 1:01:19 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,527
Man
Location: Gold Coast, Australia

Was thanked: 2793 time(s) in 1164 post(s)
vMix will need to be set to Listener mode for SRT, as Larix does not connect using Rendezvous
thanks 1 user thanked admin for this useful post.
eduardocfs on 8/8/2020(UTC)
Martin Block  
#3 Posted : Thursday, August 6, 2020 1:51:02 PM(UTC)
Martin Block

Rank: Member

Groups: Registered
Joined: 7/17/2020(UTC)
Posts: 13
Philippines
Location: Makati City

Thanks: 4 times
Thanks. I tried that as well with the same result...
Martin Block  
#4 Posted : Thursday, August 6, 2020 2:00:05 PM(UTC)
Martin Block

Rank: Member

Groups: Registered
Joined: 7/17/2020(UTC)
Posts: 13
Philippines
Location: Makati City

Thanks: 4 times
I go to general settings and make vMix listener
Then I create and input and set this as well to listen with the same port. (Most of the time I get an error listening on SRT socket message) but after trying various time
and clearing old settings it will accept the input.
But then, still no feed being received from Larix....
dmwkr  
#5 Posted : Thursday, August 6, 2020 2:54:25 PM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 212

Thanks: 31 times
Was thanked: 50 time(s) in 45 post(s)
As both are on the same network, I'd try a connection to the local IP first. If it's still not working, there's a Larix/vMix configuration issue to work out, otherwise a router/firewall issue.
Martin Block  
#6 Posted : Thursday, August 6, 2020 3:10:36 PM(UTC)
Martin Block

Rank: Member

Groups: Registered
Joined: 7/17/2020(UTC)
Posts: 13
Philippines
Location: Makati City

Thanks: 4 times
thank you. when I connected it to the local network. It worked.
But still not when I want to connect from the "outside" network.
Any ideas?
Peter1000  
#7 Posted : Thursday, August 6, 2020 3:39:39 PM(UTC)
Peter1000

Rank: Advanced Member

Groups: Registered
Joined: 1/25/2019(UTC)
Posts: 159
Switzerland

Thanks: 4 times
Was thanked: 37 time(s) in 28 post(s)
PM me, i try to help

SRT connection manual

EDIT:
I've adjusted the ports in the Wiki. I hope the community can approve port 52001.
Martin Block  
#8 Posted : Thursday, August 6, 2020 5:16:59 PM(UTC)
Martin Block

Rank: Member

Groups: Registered
Joined: 7/17/2020(UTC)
Posts: 13
Philippines
Location: Makati City

Thanks: 4 times
Thanks very much. I have a couple of meetings coming up, so I will first try again with the manual you sent.
If I still have issues, I will definitely PM you :-)

Cheers
Peter1000  
#9 Posted : Thursday, August 6, 2020 8:22:10 PM(UTC)
Peter1000

Rank: Advanced Member

Groups: Registered
Joined: 1/25/2019(UTC)
Posts: 159
Switzerland

Thanks: 4 times
Was thanked: 37 time(s) in 28 post(s)
the port has to be the same on both sides.
i think 11001 is used for something else.
try using ports from 52000 on upwards, and open these in your Router. If you open Ports in this range, you help also vMixcall to make peer to peer connections.
elvis55  
#10 Posted : Friday, August 7, 2020 3:08:38 AM(UTC)
elvis55

Rank: Advanced Member

Groups: Registered
Joined: 3/17/2017(UTC)
Posts: 279
Switzerland
Location: Luzern - Schweiz

Thanks: 32 times
Was thanked: 39 time(s) in 35 post(s)
Originally Posted by: Peter1000 Go to Quoted Post
the port has to be the same on both sides.
i think 11001 is used for something else.
try using ports from 52000 on upwards, and open these in your Router. If you open Ports in this range, you help also vMixcall to make peer to peer connections.


Nur eine kleine Anmerkung. Ich Denke, der in Ihrem Manual empfohlene Port 1935 UDP ist auch nicht ideal.
Der Port 1935 ist normalerweise der Standard Port für RTMP
Gut, wenn niemand RTMP benutzt, kann es für SRT funktionieren.
Habe es nicht getestet, da ich noch einen RTMP Server auf meinem PC verwende.


Just a small note. I think the port 1935 UDP recommended in your manual is not ideal either.
Port 1935 is usually the standard port for RTMP
Well, if no one is using RTMP, it can work for SRT.
Didn't test it as I still use an RTMP server on my PC.

List of standardized ports.
thanks 1 user thanked elvis55 for this useful post.
doggy on 8/7/2020(UTC)
Peter1000  
#11 Posted : Friday, August 7, 2020 5:49:43 AM(UTC)
Peter1000

Rank: Advanced Member

Groups: Registered
Joined: 1/25/2019(UTC)
Posts: 159
Switzerland

Thanks: 4 times
Was thanked: 37 time(s) in 28 post(s)
exactly for this reason is mentioned in almost all SRT manuals port 1935. 1935 is defined for videotransport.
For us, all ports work for SRT from 1931-1951. but because of vmixcall, we switched to ports above 52000. this was done in the same move.
elvis55  
#12 Posted : Friday, August 7, 2020 6:29:28 AM(UTC)
elvis55

Rank: Advanced Member

Groups: Registered
Joined: 3/17/2017(UTC)
Posts: 279
Switzerland
Location: Luzern - Schweiz

Thanks: 32 times
Was thanked: 39 time(s) in 35 post(s)
Originally Posted by: Peter1000 Go to Quoted Post
exactly for this reason is mentioned in almost all SRT manuals port 1935. 1935 is defined for videotransport.
For us, all ports work for SRT from 1931-1951. but because of vmixcall, we switched to ports above 52000. this was done in the same move.


Well, if you say that, it will be so.
I have now looked at a few instructions, and none of them found a reference to port 1935 for SRT.


Port (Default 9710) - Port at which data is sent or pulled from. These ports must be open (outgoing or incoming) on your network for data to flow properly


In the use case described here the sender/source will run in calling mode reading UDP multicast from 224.0.0.1 port 2244 and writing SRT to hjortsberg.org on port 6600. The receiver will run in listening mode reading SRT from port 6600 and writing UDP multicast to 224.0.0.1 port 2255. So the UDP stream goes from caller to listener

Enter the port number (must be between 1 and 65535)

SRT_Alliance_Deployment_Guide

Seite 18
Follo  
#13 Posted : Friday, August 7, 2020 9:52:15 AM(UTC)
Follo

Rank: Member

Groups: Registered
Joined: 10/10/2019(UTC)
Posts: 12
Man
Germany
Location: Bonn

Was thanked: 4 time(s) in 1 post(s)
Hey Martin,

have you forwarded the port from your Router to the IP from the vMix machine?

1. set a stic IP for your vMix Computer or go into the router settings and check if the vMix computer will get the same IP everytime.(example: 192.168.0.10).
2. the go into your router settings an forward the port that you using for srt to the IP from your vmix Computer.
3. Set vMix srt to listener.
4. stream with latrix Broadcaste as a caller to the public internet IP (WAN from your router)

That should work then.

I hope this helps you..



Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.