logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

2 Pages12>
Options
Go to last post Go to first unread
Quinton  
#1 Posted : Friday, March 8, 2019 3:13:58 AM(UTC)
Quinton

Rank: Advanced Member

Groups: Registered
Joined: 1/13/2018(UTC)
Posts: 53

Thanks: 7 times
Was thanked: 3 time(s) in 2 post(s)
Just trying to up a scoreboard by +1 using streamdeck only, without using vmix shortcuts.
How would the api function work (or can it not)?
I can do it with vmix shortcuts easily enough, but can't seem to get it working in a browser.

With the API you only have SetText,Value,Input, but if you want to do it using a url you need "Title Too" like..
localhost:8088/api/?Function=SetText&Input=1&Title=AwayScore&Value=+1

Any ideas how this can be done with a direct Function?

+1.png (17kb) downloaded 0 time(s).
doggy  
#2 Posted : Friday, March 8, 2019 3:27:51 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 1,346
Belgium
Location: Belgium

Thanks: 70 times
Was thanked: 228 time(s) in 201 post(s)
What is wrong with letting the streamdeck use a vmix shortcut or api call ?
How else would a streamdeck be able to do it ?
Quinton  
#3 Posted : Friday, March 8, 2019 3:35:13 AM(UTC)
Quinton

Rank: Advanced Member

Groups: Registered
Joined: 1/13/2018(UTC)
Posts: 53

Thanks: 7 times
Was thanked: 3 time(s) in 2 post(s)
Originally Posted by: doggy Go to Quoted Post
What is wrong with letting the streamdeck use a vmix shortcut or api call ?
How else would a streamdeck be able to do it ?


I am able to do most things without using vmix shortcuts, just directly using a localhost api function.
Is it not possible to add or take away 1 to a score through a browser link?
If so, what would that link be as you also need to use a "title" to get it to work so it gets to the right place.
doggy  
#4 Posted : Friday, March 8, 2019 3:35:18 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 1,346
Belgium
Location: Belgium

Thanks: 70 times
Was thanked: 228 time(s) in 201 post(s)
or as of vMix 22

Knowledge base
Quinton  
#5 Posted : Friday, March 8, 2019 3:42:13 AM(UTC)
Quinton

Rank: Advanced Member

Groups: Registered
Joined: 1/13/2018(UTC)
Posts: 53

Thanks: 7 times
Was thanked: 3 time(s) in 2 post(s)
I know how to use the streamdeck and vmix, that is not a problem.
I want to know if its possible to use the API to count up a score +1 using localhost function alone.
SetText does not seem to have a "title" option, only value,input
doggy  
#6 Posted : Friday, March 8, 2019 4:15:40 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 1,346
Belgium
Location: Belgium

Thanks: 70 times
Was thanked: 228 time(s) in 201 post(s)
for title use SelectedIndex or SelectedName depending if you use the index or the name of
but +=1 doesnt work for value addition
doggy  
#7 Posted : Friday, March 8, 2019 4:27:39 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 1,346
Belgium
Location: Belgium

Thanks: 70 times
Was thanked: 228 time(s) in 201 post(s)
Actually this works

http://localhost:8088/api/?Function=SetText&Input=1&SelectedIndex=1&Value=%2b%3d1

for +=1
Quinton  
#8 Posted : Friday, March 8, 2019 6:14:46 AM(UTC)
Quinton

Rank: Advanced Member

Groups: Registered
Joined: 1/13/2018(UTC)
Posts: 53

Thanks: 7 times
Was thanked: 3 time(s) in 2 post(s)
Originally Posted by: doggy Go to Quoted Post
Actually this works

http://localhost:8088/api/?Function=SetText&Input=1&SelectedIndex=1&Value=%2b%3d1

for +=1


That works perfectly, many thanks once again.
Out of interest how was the %2b%3d1 for (+=1) worked out as I need -=1 too :)
doggy  
#9 Posted : Friday, March 8, 2019 6:23:31 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 1,346
Belgium
Location: Belgium

Thanks: 70 times
Was thanked: 228 time(s) in 201 post(s)
ASCII URL Encoding

see toward bottom of page https://www.w3schools.com/tags/ref_urlencode.asp
thanks 1 user thanked doggy for this useful post.
Quinton on 3/8/2019(UTC)
MartLeib  
#10 Posted : Friday, March 8, 2019 6:25:39 AM(UTC)
MartLeib

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2017(UTC)
Posts: 57

Was thanked: 11 time(s) in 10 post(s)
Originally Posted by: Quinton Go to Quoted Post
Originally Posted by: doggy Go to Quoted Post
Actually this works

http://localhost:8088/api/?Function=SetText&Input=1&SelectedIndex=1&Value=%2b%3d1

for +=1


That works perfectly, many thanks once again.
Out of interest how was the %2b%3d1 for (+=1) worked out as I need -=1 too :)


-%3D1
Quinton  
#11 Posted : Friday, March 8, 2019 6:45:29 AM(UTC)
Quinton

Rank: Advanced Member

Groups: Registered
Joined: 1/13/2018(UTC)
Posts: 53

Thanks: 7 times
Was thanked: 3 time(s) in 2 post(s)
Thanks..I'm picking this up slowly but surely :)
I find it much easier doing it this way, as trying to find the shortcut I just made within vmix can be quite hard I think the way it is.
Quinton  
#12 Posted : Saturday, June 29, 2019 2:27:56 AM(UTC)
Quinton

Rank: Advanced Member

Groups: Registered
Joined: 1/13/2018(UTC)
Posts: 53

Thanks: 7 times
Was thanked: 3 time(s) in 2 post(s)
Sorry for posting this in a couple of places, but I need to try and get this working before tomorrow..
Has the Input format for vmix and companion app changed, since the last time I used it?
Trying to set up a goal up/down pause time.set time etc, and seems its now not the same as last time. I just entered "PauseCountdown Input=1" which worked to pause the clock, but now I am trying to add +1 to a particular score, before it would have been like this, but seems that is not working anymore?
Anyone Help out why its not working anymore? SetText&Input=1&SelectedIndex=3&Value=%2b%3d1
raugert  
#13 Posted : Saturday, June 29, 2019 2:58:34 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 159
Location: Canada

Thanks: 18 times
Was thanked: 90 time(s) in 52 post(s)
Try using SelectedName instead of SelectedIndex. (Note: If you really want to use SelectedIndex.. remember it starts at 0 ). You might be sending it to the wrong field in your xaml title.
doggy  
#14 Posted : Saturday, June 29, 2019 3:28:29 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 1,346
Belgium
Location: Belgium

Thanks: 70 times
Was thanked: 228 time(s) in 201 post(s)
is there an initial value in the textfield ?
Quinton  
#15 Posted : Saturday, June 29, 2019 4:25:34 AM(UTC)
Quinton

Rank: Advanced Member

Groups: Registered
Joined: 1/13/2018(UTC)
Posts: 53

Thanks: 7 times
Was thanked: 3 time(s) in 2 post(s)
Sending to right field, as it works perfectly when entering it in a browser, just doesnt work with companion.
There is already a number (score) entered to begin with.
Would be grateful if anyone has an answer to this, as I want to use the companion emulator remotely on a phone to change scores, which would be much easier that changing a datasource.
Just doesnt seem to want to work, even though it did a few months ago.
Quinton  
#16 Posted : Saturday, June 29, 2019 4:45:00 AM(UTC)
Quinton

Rank: Advanced Member

Groups: Registered
Joined: 1/13/2018(UTC)
Posts: 53

Thanks: 7 times
Was thanked: 3 time(s) in 2 post(s)
Seems like a lot of things arent working in companion now.
For example ..
http://localhost:8088/api/?Function=ChangeCountdown&Input=1&Value=00:45:00&SelectedIndex=0
This would set the time to 45 mins in a soccer match for the start of half time, no way I can see that works in companion...works fine in a browser.

In companion pause/restart countdown is simply PauseCountdown Input=1 which does work, so I am def connected properly.
http://localhost:8088/api/?Function=SetText&Input=1&SelectedIndex=1&Value=%2b%3d1
This should add 1 to the score, again using a browser not a problem but doesnt work anymore in companion.
doggy  
#17 Posted : Saturday, June 29, 2019 5:03:39 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 1,346
Belgium
Location: Belgium

Thanks: 70 times
Was thanked: 228 time(s) in 201 post(s)
Is there a companion group, forum or page as it really looks like a companion problem and not a vMix one ?
Quinton  
#18 Posted : Saturday, June 29, 2019 5:10:34 AM(UTC)
Quinton

Rank: Advanced Member

Groups: Registered
Joined: 1/13/2018(UTC)
Posts: 53

Thanks: 7 times
Was thanked: 3 time(s) in 2 post(s)
Originally Posted by: doggy Go to Quoted Post
Is there a companion group, forum or page as it really looks like a companion problem and not a vMix one ?


There is indeed, I already posted there but no luck.
Just posted here to see if I was doing something stupid, that was resolved easily last time, would love just to use a single brwoser page for the shortcuts with the buttons clearly showing. Seems like I will have to try and do it a different way.
kjones9999  
#19 Posted : Friday, July 5, 2019 1:58:45 PM(UTC)
kjones9999

Rank: Advanced Member

Groups: Registered
Joined: 8/20/2014(UTC)
Posts: 356

Thanks: 28 times
Was thanked: 67 time(s) in 44 post(s)
Are you using the general Post Http in companion? If not that is what is needed to make an API call through companion.
Quinton  
#20 Posted : Friday, July 5, 2019 5:48:27 PM(UTC)
Quinton

Rank: Advanced Member

Groups: Registered
Joined: 1/13/2018(UTC)
Posts: 53

Thanks: 7 times
Was thanked: 3 time(s) in 2 post(s)
Originally Posted by: kjones9999 Go to Quoted Post
Are you using the general Post Http in companion? If not that is what is needed to make an API call through companion.


Can you point me in the right direction where the Post HTTP is in companion, I was trying to use the run custom command in the dropdown, I dont see anything anywhere for http?

Users browsing this topic
2 Pages12>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.