logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

28 Pages«<2021222324>»
Options
Go to last post Go to first unread
KoryK10  
#421 Posted : Tuesday, May 19, 2020 7:42:11 AM(UTC)
KoryK10

Rank: Newbie

Groups: Registered
Joined: 5/13/2020(UTC)
Posts: 3
United States
Location: Minneapolis

No worries. My iPad is older and can't update beyond 10 so it won't work for me. Do you know if there are any similar restrictions with older android tablets?


Originally Posted by: raugert Go to Quoted Post
Hi KoryK10,

Unfortunately, Apple have some new compliance rules for iOS applications running the newer iOS. This has caused an issue on some iPads still using iOS 10. Hopefully this will be rectified in the next update.

I know some older iPads cannot be update any further that iOS 10 but if you can update your iPad to a newer iOS , it should fix the problem.

sorry about the inconvenience,
Richard


raugert  
#422 Posted : Tuesday, May 19, 2020 7:58:05 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 336
Canada
Location: Manitoba

Thanks: 52 times
Was thanked: 186 time(s) in 106 post(s)
I haven't tried on older Android tablets, but it should work on anything with Lollipop OS and above.
KnKproductions  
#423 Posted : Thursday, May 28, 2020 12:05:51 AM(UTC)
KnKproductions

Rank: Advanced Member

Groups: Registered
Joined: 4/6/2019(UTC)
Posts: 88
United States
Location: Florida

Thanks: 8 times
Was thanked: 11 time(s) in 9 post(s)
this site can help with icon creation if you don't want to do it in photoshop...

https://www.elgato.com/en/gaming/keycreator

lots of pre-made ones to choose from and modify. thought it might help with customization
Geoff B  
#424 Posted : Thursday, May 28, 2020 2:42:54 PM(UTC)
Geoff B

Rank: Advanced Member

Groups: Registered
Joined: 5/10/2020(UTC)
Posts: 81
Man
United States
Location: Sacramento, California

Thanks: 11 times
Was thanked: 3 time(s) in 3 post(s)
When using PB over the internet, it disconnects often. Is there anything I can do to keep the app connected to my machine?
raugert  
#425 Posted : Thursday, May 28, 2020 3:25:44 PM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 336
Canada
Location: Manitoba

Thanks: 52 times
Was thanked: 186 time(s) in 106 post(s)
@Geoff B

When you say over the internet, do you mean from a remote location through a DDNS server, or is it from a computer on the local network ? Also what type of computer and OS are you using ? Usually when you get disconnected, it's something to do with the network settings somewhere. If you can give me a little more detail on your setup that would be great.

thanks,
Richard
christianm  
#426 Posted : Wednesday, June 3, 2020 5:12:26 PM(UTC)
christianm

Rank: Member

Groups: Registered
Joined: 9/7/2018(UTC)
Posts: 21
Location: Australia

Thanks: 4 times
Hey Richard. Hope your well. On your next update are you able to slip the run external command function into the script builder as I was not able to locate it there. I am using that function with great effect to start and stop a teleprompter as an individual button but would like to link those actions to pre exisotng broader scripts in have already created. Thanks ;)

Christian.
raugert  
#427 Posted : Thursday, June 4, 2020 1:07:59 PM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 336
Canada
Location: Manitoba

Thanks: 52 times
Was thanked: 186 time(s) in 106 post(s)
Hi Christian,

All is well. Quite busy with Live streams so haven't had much time to code lately. Nice to hear you are using external commands. The reason it's not available in the Script Builder, is that the script is sent as a vMix Dynamic script, therefore the timing and command structure is done within vMix itself. External commands in Panel Builder are independent of VMix and cannot be included in the script as such.

Are you looking to trigger the external command at a certain point in the script, or can it be triggered when the script starts ? If so, there may be something I can do..

cheers,
Richard
christianm  
#428 Posted : Thursday, June 4, 2020 9:58:39 PM(UTC)
christianm

Rank: Member

Groups: Registered
Joined: 9/7/2018(UTC)
Posts: 21
Location: Australia

Thanks: 4 times
Good to hear you are keeping busy! The aim was to schedule the teleprompter start/stop/next marker to existing scripted buttons but that said your explanation makes sense. Honestly it was a nice to have but unless you have a solution to hand I am managing as is. As demonstrated by your coding exploits I'm sure you understand that once you start automating things there is no limit! Haha.

Christian.
Yvo.Hx  
#429 Posted : Friday, June 5, 2020 12:58:50 AM(UTC)
Yvo.Hx

Rank: Member

Groups: Registered
Joined: 12/29/2017(UTC)
Posts: 11

Thanks: 1 times
- I want to make buttons for the six categories (lRED, GREEN, ORANGE, PURPLE, AQUA and BLUE). How can that be done.

An additional sugestion:
Is to have an option to bring a title to the panel, or a TitleList such as Playlist.
raugert  
#430 Posted : Friday, June 5, 2020 3:07:52 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 336
Canada
Location: Manitoba

Thanks: 52 times
Was thanked: 186 time(s) in 106 post(s)
You can use the Colored Buttons and select the color with the color picker. These buttons remain dim until they are tallied where they become brighter.
Yvo.Hx  
#431 Posted : Friday, June 5, 2020 8:32:51 AM(UTC)
Yvo.Hx

Rank: Member

Groups: Registered
Joined: 12/29/2017(UTC)
Posts: 11

Thanks: 1 times
Originally Posted by: raugert Go to Quoted Post
You can use the Colored Buttons and select the color with the color picker. These buttons remain dim until they are tallied where they become brighter.


The question is with which function should I assign (choose) for a category button
Cupofjoe959  
#432 Posted : Friday, June 5, 2020 10:44:24 AM(UTC)
Cupofjoe959

Rank: Newbie

Groups: Registered
Joined: 5/5/2020(UTC)
Posts: 4
United States
Location: Florida

Thanks: 3 times
I love this program but I'm running into a few issues with the Panel Builder. I already have a DDNS Server set up ( JoesExample.DDNS.NET) and have Port 8088 open. That port is also shared by the built-in Vmix Web Controller. When we try logging in from a computer outside our network (LAN) using the domain name we set up for the DDNS Server and Port 8088, the only thing the person sees is the Web Controller from Vmix. They do not see anything from Panel Builder.

Panel Builder and the VMIX Production system are on the same computer. When I tried putting in the DDNS Server Domain name in Panel Builders Preferences, it would not synch (GO GREEN) with VMIX, which was open to the show we built a template for with Panel Builder. Again, both programs are on the same computer. Only the local IP address with port 8088 would synch up with Vmix in the Preferences section.

I'm trying to get two members of the production team to operate from outside our local network while utilizing the Panels we built inside Panel Builder. Both of these team members are
connected to the production machine via VMIX CALL. Now, I just need them to be able to operate the panels from a remote location. Is this possible? I'm hoping for it to function just like the web controller does. Send out our IP address with Port 8088 and have access to the Panels we just created.

Thank you again for your time and consideration. I'm a big fan of Vmix and could not be happier to have found Panel Builder. Any help would be greatly appreciated.

Thanks!

Joe
raugert  
#433 Posted : Friday, June 5, 2020 11:57:25 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 336
Canada
Location: Manitoba

Thanks: 52 times
Was thanked: 186 time(s) in 106 post(s)
Hi Joe,

If I am reading your situation correctly, I think you might have a workflow issue. The Panel Builder software does not have a web API as such.

The Panel Builder software can control vMix from a local or remote computer, but must be installed on any computer that is "controlling" vMix. In other words the remote computer would have the Panel Builder software installed in order to control vMix through the web (setting the vMix IP as JoesExample.DDNS.NET) . You would install Panel Builder on your two team members' computers and they could then control vMix simultaneously. They could also use their own panels that are designed to suit their needs if you like.

Hope this helps, Don't hesitate to ask for more assistance.

cheers,
Richard
thanks 1 user thanked raugert for this useful post.
Cupofjoe959 on 6/6/2020(UTC)
Cupofjoe959  
#434 Posted : Saturday, June 6, 2020 12:11:33 AM(UTC)
Cupofjoe959

Rank: Newbie

Groups: Registered
Joined: 5/5/2020(UTC)
Posts: 4
United States
Location: Florida

Thanks: 3 times
Originally Posted by: raugert Go to Quoted Post
Hi Joe,

If I am reading your situation correctly, I think you might have a workflow issue. The Panel Builder software does not have a web API as such.

The Panel Builder software can control vMix from a local or remote computer, but must be installed on any computer that is "controlling" vMix. In other words the remote computer would have the Panel Builder software installed in order to control vMix through the web (setting the vMix IP as JoesExample.DDNS.NET) . You would install Panel Builder on your two team members' computers and they could then control vMix simultaneously. They could also use their own panels that are designed to suit their needs if you like.

Hope this helps, Don't hesitate to ask for more assistance.

cheers,
Richard


Can't thank you enough for clearing that up for me. One last question, Can I create a Panel and email to one of my team members so they can run it on their computer inside of Panel Builder? If we are dealing with MAC computers and I create a Panel on a PC, will it be compatible with the MAC if I send that file to a team member? I have a MAC computer inside my LAN and I'm trying to open a Panel File that I created on a PC and it just keeps saying "Loading Panel" Thank you again Richard!
Cupofjoe959  
#435 Posted : Saturday, June 6, 2020 1:16:03 AM(UTC)
Cupofjoe959

Rank: Newbie

Groups: Registered
Joined: 5/5/2020(UTC)
Posts: 4
United States
Location: Florida

Thanks: 3 times
Not sure if I'm doing something wrong but it appears that I can't get any of the preference settings to save on my MAC that's running Catalina 10.15
I also can't seem to get anything to load. The Panel Builder just says Loading Panel and goes nowhere.

I created a panel on my MAC and saved it.

Closed down the app and reopened it. None of the settings I saved in the Preferences were there and when I tried to load the panel I just made, it does the same thing. Just says loading Panel.
Not sure if anyone else is experiencing this. Not sure what to do. I have no issues on my PC but can't seem to get anything on the MAC to work. Thanks!

Joe
raugert  
#436 Posted : Saturday, June 6, 2020 1:36:47 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 336
Canada
Location: Manitoba

Thanks: 52 times
Was thanked: 186 time(s) in 106 post(s)
It appears that some Mac Catalina issues are related to the new security requirements for apps. (Apps will have to be notarized, and code-signed. etc) It’s becoming more complicated with Apple, so I will probably include an installer to make it easier. The issue you’re having with Catalina is probably related to this.

Here’s what seems to work on Catalina for now:

1. Download zipped files from forum
2. Create a new folder where you want to group the files (it can be on the Desktop or even in the Applications folder)
3. Copy only the "vMix Panel Builder" file to this folder.
4. Launch the app from that folder. (You can make an alias if you like.)
5. The first time you launch it, It will say it cannot be opened from unidentified developer (select cancel)
6. Open “System Preferences” Go to Security and Privacy” and select Open Anyway
7. The app should load and create the required UserIcon and Log Folders and prefs file.
8. It will load next time without having to go through the process again.

Let me know if it works for you..



thanks 1 user thanked raugert for this useful post.
Cupofjoe959 on 6/6/2020(UTC)
Cupofjoe959  
#437 Posted : Saturday, June 6, 2020 2:30:10 AM(UTC)
Cupofjoe959

Rank: Newbie

Groups: Registered
Joined: 5/5/2020(UTC)
Posts: 4
United States
Location: Florida

Thanks: 3 times
Originally Posted by: raugert Go to Quoted Post
It appears that some Mac Catalina issues are related to the new security requirements for apps. (Apps will have to be notarized, and code-signed. etc) It’s becoming more complicated with Apple, so I will probably include an installer to make it easier. The issue you’re having with Catalina is probably related to this.

Here’s what seems to work on Catalina for now:

1. Download zipped files from forum
2. Create a new folder where you want to group the files (it can be on the Desktop or even in the Applications folder)
3. Copy only the "vMix Panel Builder" file to this folder.
4. Launch the app from that folder. (You can make an alias if you like.)
5. The first time you launch it, It will say it cannot be opened from unidentified developer (select cancel)
6. Open “System Preferences” Go to Security and Privacy” and select Open Anyway
7. The app should load and create the required UserIcon and Log Folders and prefs file.
8. It will load next time without having to go through the process again.

Let me know if it works for you..






That did the trick. Easy enough workaround. Thank you once again for the help, Richard! Can't wait to see what the future holds with Panel Builder!
Geoff B  
#438 Posted : Saturday, June 6, 2020 1:47:37 PM(UTC)
Geoff B

Rank: Advanced Member

Groups: Registered
Joined: 5/10/2020(UTC)
Posts: 81
Man
United States
Location: Sacramento, California

Thanks: 11 times
Was thanked: 3 time(s) in 3 post(s)
Originally Posted by: raugert Go to Quoted Post
@Geoff B

When you say over the internet, do you mean from a remote location through a DDNS server, or is it from a computer on the local network ? Also what type of computer and OS are you using ? Usually when you get disconnected, it's something to do with the network settings somewhere. If you can give me a little more detail on your setup that would be great.

thanks,
Richard


Richard,

The goal is to control it from a remote location. For now, it's on a separate network in my house. Not using a DDNS server, because I have a static IP address. Controlling computer running PB is a MacBook Pro on MacOS Mojave.

Could the problem be that since both computers are on the same public IP address, the PB machine is seeing the commands coming back at it on port 8088?

raugert  
#439 Posted : Sunday, June 7, 2020 12:59:08 AM(UTC)
raugert

Rank: Advanced Member

Groups: Registered
Joined: 8/5/2017(UTC)
Posts: 336
Canada
Location: Manitoba

Thanks: 52 times
Was thanked: 186 time(s) in 106 post(s)
Hi Geoff,

The static public IP from your ISP should have no bearing on the communications between vMix and PB within your local network. The port is not an issue as vMix is the server and PB is the client. The fact that you can connect to vMix but it disconnects often, points to something in your network (router, switch etc.). It would be a good idea to make this work locally, before venturing into remote control.

I'm assuming you might have set a static IP for vMix and using DHCP on your Mac ? Not that it matters, but it might help troubleshoot.
Do you have a network switch or other router in your network ?

Please email me at info@studio793.ca so we can further our discussion. I'll be happy to help you out.

thanks,
Richard
Geoff B  
#440 Posted : Sunday, June 7, 2020 3:03:20 AM(UTC)
Geoff B

Rank: Advanced Member

Groups: Registered
Joined: 5/10/2020(UTC)
Posts: 81
Man
United States
Location: Sacramento, California

Thanks: 11 times
Was thanked: 3 time(s) in 3 post(s)
Originally Posted by: raugert Go to Quoted Post
Hi Geoff,

The static public IP from your ISP should have no bearing on the communications between vMix and PB within your local network. The port is not an issue as vMix is the server and PB is the client. The fact that you can connect to vMix but it disconnects often, points to something in your network (router, switch etc.). It would be a good idea to make this work locally, before venturing into remote control.

I'm assuming you might have set a static IP for vMix and using DHCP on your Mac ? Not that it matters, but it might help troubleshoot.
Do you have a network switch or other router in your network ?

Please email me at info@studio793.ca so we can further our discussion. I'll be happy to help you out.

thanks,
Richard


Thanks so much, I'll send you an email!

Users browsing this topic
28 Pages«<2021222324>»
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.