logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
tony marone  
#1 Posted : Tuesday, February 1, 2011 11:40:01 AM(UTC)
tony marone

Rank: Advanced Member

Groups: Registered
Joined: 1/16/2010(UTC)
Posts: 48
Man
Location: usa

Was thanked: 3 time(s) in 2 post(s)
Hi Martin,

Sorry if this is an old question but . .

I have a problem with output video from my vmix system. I really need to get this resolved because I have a big project coming up this weekend and may have to use the old SD analog switcher.

Here are the system specs and equipment in use:

4 Canon XH-A1 cameras
4 Blackmagic Component to HD-SDI converters
2 Blackmagic Decklink Duos input cards
1 Blackmagic Intensity Pro input card

I7-950 processor
Gigabyte X58A-UD3R motherboard
6 gigs DDR3 ram
Sapphire Radeon HD5570 1mb graphics card
Windows 7 Ultimate 64 bit running in high performance mode

System runs at 4 to 7% processor with 4 cameras connected. I have the cameras set to 60i which according to Canon's website is really 59.94i.
vMix is set for 1920x1080 at 59.94i or 29.97p with deinterlace turned on. Output is set to 1920x1080 at 59.94i or 29.97p in widescreen mode. I also have the synchronize video with monitor refresh set under performance tab. The graphics card is also set for 1920x1080 at 29hz on the second monitor.

My problem is that I can see granularity in movement. It is very irritating. It is not like 24fps film movement. The movement of objects moving sideways on the screen is not constant but is somewhat jerky at irregular intervals. Also there is some tearing going on with or without the synchronize checked.
Also, an object moving very quickly sideways on the screen will have double images on either side, not every other line, but on every line as though field 1 and field 2 were reversed.

For what it is worth, when I play back a video in wmv avi or mp4 format, I do not see these problems. I know they are 24fps progressive and figure this is why.

If I connect a camera directly to a monitor the motion is smooth as silk just as you would expect.

I have long suspected that DirectShow was not a good way to do professional video. I hope I am wrong!

I pray that I just have overlooked some setting in getting this right.

What cameras do you use in your test setup? Please give me model numbers so I can look at their specs.

Do you have any footage of cameras going through your system? The youtube video is great for promotion, but does not show what happens in the real world with cameras connected.

I wish I had access to a 60p capable camera to see if this is the problem. Using the Canon XH-A1 at 30p has its own set of problems and when it is connected directly to a monitor in that mode, the motion is crappy also but at least smooth and without tearing.

I appreciate all the hard work you have done on vMix and think it is awesome. I have spent days working on this problem trying many combinations of settings and need some help to get my setup working right!

Thanks,
Tony
admin  
#2 Posted : Tuesday, February 1, 2011 9:51:52 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,460
Man
Location: Gold Coast, Australia

Was thanked: 2665 time(s) in 1124 post(s)
Hi Tony,

The next version of vMix has some changes that may improve things, but in my testing camera inputs are usually the smoothest, sometimes video files can be jerky due to a bad decoder but camera inputs are usually something that can be relied on.

To get an idea of how things are setup:

1. Are you running Windows 7 in aero mode? If so, disable the synchonize checkbox as tearing will already be eliminated by aero.
2. If you are not running aero mode, try running in that mode as it means Windows 7 synchronises video to a single frame rate.
3. Check the Windows monitor refresh rate in windows is set to 60i.
4. What sort of monitor is being used?

Note that deinterlacing will make movement less fluid simply because it is combining fields. You can use vMix in interlace only mode by unticking deinterlace and making sure all inputs and outputs run at the same framerate and resolution, but this is not recommended as vMix is designed primarily to work with progressive sources.

Also, if you have an NVIDIA graphics card lying around that might be worth testing, some ATI cards appear to struggle with all the video.

If you like, email info@vmix.com.au and request a beta of vMix 2011 as I would be interested to see if it improves things.

Regards,

Martin
vMix
Users browsing this topic
Similar Topics
HDV input stutters (video not smooth) in Vmix (General Discussion)
by ab7 10/17/2010 10:37:29 AM(UTC)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.