logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

4 Pages<1234>
Options
Go to last post Go to first unread
admin  
#41 Posted : Saturday, February 3, 2024 11:36:14 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 5,162
Man
Location: Gold Coast, Australia

Was thanked: 4175 time(s) in 1498 post(s)
Originally Posted by: gorbva Go to Quoted Post
API.XML Bug in version 27.0.0.64
If i set Input volume by API function it doesn't affect to API.XML file!
API.XML input volume is changed only when i change it manually.


Can you please email support and send a support report so we can investigate further:
https://www.vmix.com/contact-us.aspx
doggy  
#42 Posted : Saturday, February 3, 2024 11:46:04 PM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 5,098
Belgium
Location: Belgium

Thanks: 285 times
Was thanked: 922 time(s) in 761 post(s)
Originally Posted by: gorbva Go to Quoted Post
Originally Posted by: admin Go to Quoted Post
Originally Posted by: gorbva Go to Quoted Post
API.XML Bug in version 27.0.0.64
If i set Input volume by API function it doesn't affect to API.XML file!
API.XML input volume is changed only when i change it manually.


We've just checked and can confirm SetVolume in the API also updates the XML as expected and is working correctly.
Note that audio values in different places have different means, you can use the formulas below to convert as needed:
https://www.vmix.com/kno...44/vmix-api-audio-levels


Maybe SetVolume works fine, i do not use it in my script, but SetVolumeFade function does NOT affect to API.XML


it does affect the meterF1 and meterF2
gorbva  
#43 Posted : Sunday, February 4, 2024 12:22:13 PM(UTC)
gorbva

Rank: Member

Groups: Registered
Joined: 12/4/2019(UTC)
Posts: 22
Russian Federation

Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: doggy Go to Quoted Post
Originally Posted by: gorbva Go to Quoted Post
Originally Posted by: admin Go to Quoted Post
Originally Posted by: gorbva Go to Quoted Post
API.XML Bug in version 27.0.0.64
If i set Input volume by API function it doesn't affect to API.XML file!
API.XML input volume is changed only when i change it manually.


We've just checked and can confirm SetVolume in the API also updates the XML as expected and is working correctly.
Note that audio values in different places have different means, you can use the formulas below to convert as needed:
https://www.vmix.com/kno...44/vmix-api-audio-levels


Maybe SetVolume works fine, i do not use it in my script, but SetVolumeFade function does NOT affect to API.XML


it does affect the meterF1 and meterF2


meterF1 and meterF2 stores value of level bar. It always changed when someone speak to microphone (for example), or music played.
clair  
#44 Posted : Sunday, February 4, 2024 11:26:20 PM(UTC)
clair

Rank: Member

Groups: Registered
Joined: 5/30/2014(UTC)
Posts: 15
Location: tokyo

Thanks: 6 times
I found a bug causing hang-ups.

In environments utilizing the audio interface with ASIO drivers, if an ASIO device is selected for the output channel, vMix hangs up without exiting when vMix is closed.

Environment
OS: Windows 11
Audio Interface: TASCAM US16x08
IceStream  
#45 Posted : Monday, February 5, 2024 1:21:14 AM(UTC)
IceStream

Rank: Advanced Member

Groups: Registered
Joined: 3/7/2012(UTC)
Posts: 2,605
Man
Location: Canada

Thanks: 33 times
Was thanked: 501 time(s) in 470 post(s)
@ clair,

This is a known bug with the TASCAM drivers which they have never fixed in years (so nothing vMix can do).
Essentially, vMix never gets confirmation from the device when attempting to disconnect and shut down and so hangs while it awaits a response.
The "workaround" is to disconnect the device manually prior to shutting down vMix.


Ice
thanks 2 users thanked IceStream for this useful post.
clair on 2/6/2024(UTC), sinc747 on 2/9/2024(UTC)
Simsyuk  
#46 Posted : Tuesday, February 6, 2024 12:29:03 AM(UTC)
Simsyuk

Rank: Advanced Member

Groups: Registered
Joined: 8/16/2019(UTC)
Posts: 340
United Kingdom

Thanks: 72 times
Was thanked: 21 time(s) in 17 post(s)
Zoom Security Issue!

It might just be me, but it appears that guests on Zoom are joining without being directed to the waiting room first. I've gone through the Zoom settings, and the waiting room feature is definitely activated.

Furthermore, even when I attempt to place a guest into the waiting room, they seem to be allowed back in immediately. Does anyone have any insights on this, please?
admin  
#47 Posted : Tuesday, February 6, 2024 1:27:53 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 5,162
Man
Location: Gold Coast, Australia

Was thanked: 4175 time(s) in 1498 post(s)
Yes, that is by design. Zoom in vMix is designed solely for bringing in raw video and audio feeds and is not intended to duplicate all the features of the Zoom Meeting app including waiting rooms.
Therefore if you decide to Host a meeting in vMix it will automatically bring in participants from any waiting rooms.

If you want full control over waiting rooms, host the Zoom Meeting using the dedicated app instead, and Join using vMix.
thanks 1 user thanked admin for this useful post.
Simsyuk on 2/6/2024(UTC)
Simsyuk  
#48 Posted : Tuesday, February 6, 2024 6:41:03 AM(UTC)
Simsyuk

Rank: Advanced Member

Groups: Registered
Joined: 8/16/2019(UTC)
Posts: 340
United Kingdom

Thanks: 72 times
Was thanked: 21 time(s) in 17 post(s)
Originally Posted by: admin Go to Quoted Post
Yes, that is by design. Zoom in vMix is designed solely for bringing in raw video and audio feeds and is not intended to duplicate all the features of the Zoom Meeting app including waiting rooms.
Therefore if you decide to Host a meeting in vMix it will automatically bring in participants from any waiting rooms.

If you want full control over waiting rooms, host the Zoom Meeting using the dedicated app instead, and Join using vMix.



Thank you for your quick response, I've figured out a way around it. Thanks.
spililel  
#49 Posted : Tuesday, February 6, 2024 8:43:47 PM(UTC)
spililel

Rank: Newbie

Groups: Registered
Joined: 2/6/2024(UTC)
Posts: 1

Thanks: 1 times
Hello!
It seems that border function has been broken with this update.
For example, with Thiсkness (8) and Radius (180) there is an invisible rectangular that lays on top of border and breaks it.
Would be glad if that was fixed.
[img=https://ibb.co/RHn9VyN]Problem[/img]
admin  
#50 Posted : Tuesday, February 6, 2024 10:24:58 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 5,162
Man
Location: Gold Coast, Australia

Was thanked: 4175 time(s) in 1498 post(s)
Originally Posted by: spililel Go to Quoted Post
Hello!
It seems that border function has been broken with this update.
For example, with Thiсkness (8) and Radius (180) there is an invisible rectangular that lays on top of border and breaks it.
Would be glad if that was fixed.
[img=https://ibb.co/RHn9VyN]Problem[/img]


You will need to ensure both the border thickness is large enough and border radius is small enough to cover the corners of the rectangle completely.
Borders in vMix were never intended to overlap the way you have here, and the cuts you see are necessary in order to support the new animated borders feature in 27.
thanks 1 user thanked admin for this useful post.
spililel on 2/7/2024(UTC)
dmwkr  
#51 Posted : Thursday, February 8, 2024 10:18:39 PM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 521

Thanks: 62 times
Was thanked: 119 time(s) in 108 post(s)
Before vMix 27, you were able to fine tune the volume level with the up/down keys in the Audio Mixer of the inputs if you had clicked on the input in the Audio Mixer. The up/down keys now fine tune the pan level. Volume level seems more useful to me. :)
robertskiba  
#52 Posted : Tuesday, February 13, 2024 6:56:41 PM(UTC)
robertskiba

Rank: Member

Groups: Registered
Joined: 8/22/2021(UTC)
Posts: 26
Man
Germany

Thanks: 2 times
Was thanked: 4 time(s) in 4 post(s)
Wouldn't it be a good idea to include the zoom plugin and all the .net-files you need into the vmix .exe?

I don't think that the plus of needed disk space is a topic for anybody but you could always be sure to have installed everything you need in the right version.
thanks 1 user thanked robertskiba for this useful post.
Cris_AV on 2/13/2024(UTC)
gefiltafish  
#53 Posted : Wednesday, February 14, 2024 11:43:46 PM(UTC)
gefiltafish

Rank: Advanced Member

Groups: Registered
Joined: 12/5/2017(UTC)
Posts: 32
Location: Zagreb

Thanks: 8 times
Hi!

I'm having a following bug: when I open settings of some input or add input or any other additional screen on my 4k monitor it automatically just minimizes and I have to click on it again from taskbar to make it available again, although sometimes not even making it active again helps so I have to try again and again.
ckvideo  
#54 Posted : Sunday, February 25, 2024 9:36:34 PM(UTC)
ckvideo

Rank: Member

Groups: Registered
Joined: 3/21/2022(UTC)
Posts: 14
Germany

Thanks: 1 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: admin Go to Quoted Post
vMix 27 has been released!

Visit the download page below to download and view all the changes:

http://www.vmix.com/software/download.aspx

Feedback

Please report any bugs or questions in this thread.

Thanks,

Martin
vMix


Hi,
thanks to the dev team for this release (and the Audio Bus Manager, hurrraay!).

I think I found a bug that has been there for a while:

If you set up a shortcut that involves putting in parameters (i.E. the AudioBus function) there is no UI text pane in the shortcut setup dialog to enter these parameters.

A quick crosscheck showed the same problem for the function call StreamingSetURL, where a text input is needed. It looks like the parameter input pane is generally missing/invisible for many functions.

The problem was on the last Version of vMix 27 both in the English and German UI settings.

If you could please fix this, it would make many shortcuts suddenly usable. (And we could finally integrate our Nanokontrol MIDI controller with the audio mixer.)

Thanks,

Christian
admin  
#55 Posted : Sunday, February 25, 2024 9:48:46 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 5,162
Man
Location: Gold Coast, Australia

Was thanked: 4175 time(s) in 1498 post(s)
Hi Christian,

I can confirm these functions all show the Value text box as expected, but only if you assign them to an actual button.

However, if you try to assign to a MIDI dial etc that is variable, then these boxes will not be visible as vMix assumes you want to control the value of the shortcut, such as volume
and it would just cause chaos if it allowed you to do this for shortcuts that expect text.

If you have tried to assign to a MIDI button and it still does not work, then for whatever reason the MIDI manufacturer has decided to display that button to vMix as a dial, so try another button instead.

Regards,

Martin
vMix
thanks 1 user thanked admin for this useful post.
ckvideo on 2/26/2024(UTC)
ckvideo  
#56 Posted : Monday, February 26, 2024 6:06:29 AM(UTC)
ckvideo

Rank: Member

Groups: Registered
Joined: 3/21/2022(UTC)
Posts: 14
Germany

Thanks: 1 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: admin Go to Quoted Post
Hi Christian,

I can confirm these functions all show the Value text box as expected, but only if you assign them to an actual button.

However, if you try to assign to a MIDI dial etc that is variable, then these boxes will not be visible as vMix assumes you want to control the value of the shortcut, such as volume
and it would just cause chaos if it allowed you to do this for shortcuts that expect text.

If you have tried to assign to a MIDI button and it still does not work, then for whatever reason the MIDI manufacturer has decided to display that button to vMix as a dial, so try another button instead.

Regards,

Martin
vMix


Thanks Martin,

I was using the Korg nanoKONTROL 2 which has 8 faders with three buttons each. A button gives velocity 0 and 127 for up and down. This seems to be MIDI standard. I was trying to assign these buttons for bus routings. This does not work as described above. However, using the shortcut with the keyboard and Streamdeck is fine. I found a workaround: First define the shortcut with a keyboard key, enter the parameter and than change the trogger back to the MIDI key. Works. Maybe there is a chance for the programmers to detect the 0/127 play on MIDI buttons and than show the parameter pane.

Best regards,

Christian
dmwkr  
#57 Posted : Wednesday, April 10, 2024 4:09:02 AM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 521

Thanks: 62 times
Was thanked: 119 time(s) in 108 post(s)
Excuse me, I quote myself:

Originally Posted by: dmwkr Go to Quoted Post
Before vMix 27, you were able to fine tune the volume level with the up/down keys in the Audio Mixer of the inputs if you had clicked on the input in the Audio Mixer. The up/down keys now fine tune the pan level. Volume level seems more useful to me. :)


That is still true, and there is another behaviour when using the keyboard, that I believe is different than before, and seems counterproductive: When selecting an input in a Mix input (drop-down list for Preview or Output) via mouse, it seems to be impossible to "un-focus" the drop-down list. I believe it was possible to click anywhere on the vMix GUI to un-focus it. Now, a shortcut eg. on the "Home / Pos1" key won't work, but will select the first entry ("None") in the drop-down list that was used last.

Edit: It will un-focus when clicking any other button, but it would still be nice to un-focus by just clicking anywhere, without having to trigger an actual function.
doggy  
#58 Posted : Monday, April 22, 2024 2:37:13 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 5,098
Belgium
Location: Belgium

Thanks: 285 times
Was thanked: 922 time(s) in 761 post(s)
IMO a major instant replay bug.

tags are only updated to the "replay2.xml" when doing a start/stop of the instant replay recording !

Would be usefull if they were for those that want to script reading them for display and such
doggy  
#59 Posted : Tuesday, April 23, 2024 5:38:28 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 5,098
Belgium
Location: Belgium

Thanks: 285 times
Was thanked: 922 time(s) in 761 post(s)
Originally Posted by: doggy Go to Quoted Post
IMO a major instant replay bug.

tags are only updated to the "replay2.xml" when doing a start/stop of the instant replay recording !

Would be usefull if they were for those that want to script reading them for display and such


additionally:
reordering the events are also only updated by first doing a start/stop recording

or opening/closing de replay configuration also updates the "replay2.xml" file
IMO any change should be updated

would definatly help with this script ;-) https://forums.vmix.com/...ition-via-API#post113912
admin  
#60 Posted : Tuesday, April 23, 2024 12:52:34 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 5,162
Man
Location: Gold Coast, Australia

Was thanked: 4175 time(s) in 1498 post(s)
Originally Posted by: doggy Go to Quoted Post
IMO a major instant replay bug.

tags are only updated to the "replay2.xml" when doing a start/stop of the instant replay recording !

Would be usefull if they were for those that want to script reading them for display and such


Please note replay2.xml is used internally for vMix Replay and is not designed or intended to be used externally or via scripting.
Saving to a file with every change is not ideal for performance reasons, so a lot of things in vMix are kept in memory while running.
Users browsing this topic
4 Pages<1234>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.