logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
clintonsdamedia  
#1 Posted : Tuesday, February 6, 2024 2:07:51 AM(UTC)
clintonsdamedia

Rank: Newbie

Groups: Registered
Joined: 2/4/2024(UTC)
Posts: 3
United States

Thanks: 1 times
Hi, I am a total newbie to forums and I apologize in advance if I am not doing this correctly!!!

I am now in charge of our church's tech equipment and we livestream our services weekly using vMix. It was set up in 2020 and that person has moved away. Everything was working fine until last summer/fall when a windows automatic update caused several problems.

Our system is Win10 running vMix 4K. We have an HDMI cable running from speaker podium to desktop PC, and that cable plugs into Blackmagic Decklink mini recorder 4 card installed in PC. We would add an input for the Decklink recorder, and presentation slides would be able to be displayed in vMix livestream.
vMix no longer receives the presentation slides, it only displays a black screen for the screen capture input.

I'm computer literate, but weak on networking. We updated drivers last Dec. but that didn't help. I tried to disable and re-enable the Decklink card but that didn't help either.

Attached is a screenshot of NDI/Desktop capture choices. There is an image on the Decklink Mini Recorder 4K square, but that is not what is currently being displayed on the Powerpoint presentation from the podium. I have no idea where that image is coming from


I would be grateful for any suggestions or guidance on this!


Oops sorry, I don't see a way to attach a screenshot - please disregard that comment
clintonsdamedia  
#2 Posted : Tuesday, February 6, 2024 3:03:26 AM(UTC)
clintonsdamedia

Rank: Newbie

Groups: Registered
Joined: 2/4/2024(UTC)
Posts: 3
United States

Thanks: 1 times
So apparently the resolution and frame rate for the decklink are incorrect....they are showing up as 1280-720 and 29.97p, should be 1920-1080, 59.94p.
I'm having no luck trying to change this - any ideas?
dmwkr  
#3 Posted : Tuesday, February 6, 2024 4:08:55 AM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 529

Thanks: 62 times
Was thanked: 125 time(s) in 114 post(s)
Not sure if I'm able to guide you, but you seem to mix "NDI/Desktop Capture" (via network) and "Camera Capture" (via HDMI). Even if you are trying to capture the desktop of a PC, for capturing it via the Decklink, you have to add it as a "Camera".

Some hints to narrow in on the source of error:

- The laptop on the podium has to recognize the Decklink Card as a second screen. Does it?
- Make sure when adding the Decklink Card in vMix as Camera that you choose "HDMI" as input.
- Update the Decklink Software to the latest version.
- Try a different HDMI source instead of the laptop.
- Try a different HDMI receiver/display instead of the Decklink Card, eg. the monitor of the desktop PC.
- Try a different HDMI cable.
thanks 1 user thanked dmwkr for this useful post.
clintonsdamedia on 2/6/2024(UTC)
clintonsdamedia  
#4 Posted : Tuesday, February 6, 2024 5:12:07 AM(UTC)
clintonsdamedia

Rank: Newbie

Groups: Registered
Joined: 2/4/2024(UTC)
Posts: 3
United States

Thanks: 1 times
Thank you so much for your help! I am indeed confusing the desktop capture with camera capture. And I am even more confused now because I have the presentation slides coming in to vMix, but it is via the NDI/Desktop Capture input.

I tried using the Camera input and I receive the following error "Selected Video Format is not supported by this device: bmdModeHD1080p2997 Error HRESULT E_FAIL has been returned from a call to a COM component. I had selected Decklink MiniRecorder 4K for my camera, and HDMI for input. Resolution shows 1920x1080 and frame rate of NTSC 29.97p.

So I tried using an iPad at the podium, it is plugged into a USB C/HDMI dongle. The slideshow is coming in to vMix fine, but I had to select the NDI/Desktop Capture to get the presentation slides.

Is it possible that the HDMI cable is plugging into the Decklink card and that is being treated as network input? I was not here when the HDMI cabling was run, but I'm told it comes from podium, under flooring, and into the Decklink card in the desktop PC.


(I had the laptop slideshow coming in to vMix also for a bit, but I am having other problems with the laptop so I just took that out of the equation.)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.