logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
bobdrad  
#1 Posted : Monday, May 2, 2022 5:29:50 AM(UTC)
bobdrad

Rank: Newbie

Groups: Registered
Joined: 5/2/2022(UTC)
Posts: 2
United States
Location: Washington

We have what should be a very powerful PC but are experiencing frequent stutters which are likely due to dropped frames.
We'd love any feedback about things we could tune or investigate to address this issue.

CPU: i7-9700f@3GHz (8 cores)
Memory: 16GB
Graphics: NVidia Geforce GTX 1660 Super (1830 MHz, Total avail graphic mem: 14GB, Dedicated Video mem: 6144MB GDDR6, PCI Express x4 Gen 3, Shared System Memory 8151MB)
Capture: Blackmagic DeckLink SDI 4K

I ran stats during our last stream:
DropStats.jpg (87kb) downloaded 2 time(s).

I'm not clear on how to interpret these stats to identify our problem.
Do you have any suggestions on things we could investigate?
bobdrad  
#2 Posted : Monday, May 23, 2022 4:13:10 AM(UTC)
bobdrad

Rank: Newbie

Groups: Registered
Joined: 5/2/2022(UTC)
Posts: 2
United States
Location: Washington

Does anyone have suggestions as to what we could investigate here?
maxmarrie  
#3 Posted : Wednesday, May 25, 2022 3:02:32 PM(UTC)
maxmarrie

Rank: Newbie

Groups: Registered
Joined: 5/25/2022(UTC)
Posts: 1
Pakistan

I dont have any suggestion about this thing
IceStream  
#4 Posted : Wednesday, May 25, 2022 8:49:56 PM(UTC)
IceStream

Rank: Advanced Member

Groups: Registered
Joined: 3/7/2012(UTC)
Posts: 2,485
Man
Location: Canada

Thanks: 32 times
Was thanked: 472 time(s) in 444 post(s)
@ bobdrad

This page in the vMix documentation might be of some assistance with interpreting the Statistics:
https://www.vmix.com/help25/Statistics.html


Ice
Andreas O  
#5 Posted : Thursday, May 26, 2022 3:05:18 AM(UTC)
Andreas O

Rank: Member

Groups: Registered
Joined: 2/9/2021(UTC)
Posts: 17
Norway
Location: Oslo

Thanks: 2 times
I'm not an expert, just a fresh amateur.

Judging solely by the statistics, it might indicate your CPU/graphics card can't reliably process the frames from the Decklink card quickly enough. The frame interval numbers indicate that your camera might be running at 60FPS. Is that right? (21 11 18 16 -- 1000/number gives FPS value) That is also a lot of variation between frames - between 50 and 100 frames per second. At a best, amateur guess your computer might be having trouble keeping up with a 60 FPS source?

If your camera is running at 60FPS, try to bring it down to 30FPS to see if it stabilises. If it's not set to 60 FPS, well, I've obviously misread the entire thing. Also make sure that both your camera and your VMIX have the same framerate setting or your computer will be working unnecessarily hard to convert one to the other. Most stream platforms can't render 60FPS in live streams at any rate. (Places like Vimeo will show the 60FPS in archived video, though)

Also check the bitrate of the video input isn't unnecessarily high. I wouldn't do 4K/30 on that rig, especially if you're getting full 4K bitrate video in. (~160mbit)

Set up a test stream for an hour with a high-bitrate video with a lot of motion, on a loop. Like this: http://bbb3d.renderfarming.net/

Check in from time to time and see how your CPU and GPU performance is doing. Take note if performance is stable.

Again, just an amateur here, but hopefully it gives you some leads to chase down. If nothing else to rule them out. :)

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.