logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

2 Pages12>
Options
Go to last post Go to first unread
FAndreas  
#1 Posted : Saturday, March 4, 2017 7:34:19 PM(UTC)
FAndreas

Rank: Advanced Member

Groups: Registered
Joined: 5/16/2014(UTC)
Posts: 63
Man
Location: Germany

Hi,

I posted this question already on BMD forum.
But maybe someone already experienced this issue?

I have a PC setup with one Decklink Duo 2 and the following components:

Canon Legria (Vixia) HF G30 -> BMD HDMI to SDI converter -> Decklink Duo 2 port
Canon Legria (Vixia) HF G40 -> BMD Hdmi to SDI converter -> Decklink Duo 2 port

I am not able to get a stable 1080p50 signal on any of the Decklink ports in Media Express. Sometimes a short picture flickering, but no stable video feed. When I switch the cameras to 1080i50 or 720p50 I have a stable feed on Media Express.

I changed:
SDI cables
BMD HDMI to SDI converters with liqoo HDMI to SDI converters
HDMI cable from cameras to converter.

When I plug both Canon cameras to my Samsung TV I get a stable 1080p50 image.
When I change one of the Canon HF cameras with a Canon EOS 80D DSLR I get a stable 1080p50 video feed on Media Express on PC.

So it's definitley the combination of Canon HF G30/G40 and Decklink Duo 2 with 1080p50.

I would appreciate any help.
DWAM  
#2 Posted : Saturday, March 4, 2017 8:00:34 PM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,288
Man
France
Location: Bordeaux, France

Thanks: 193 times
Was thanked: 655 time(s) in 502 post(s)
Hi Andreas

I don't think HF G30 supports 1080p50 on HDMI out. It only supports fake 1080p50 recordings on SD where each 1080i50 interlaced frame is blended to progressive.

Don't have HF G40 but like you I never had 1080p50 out even when all options are set correctly and HDMI out set to 1080p. BMD Desktop Utility shows 1080p25 even when cam is on 1080p50.

Same with BMD Mini recorder HDMI input.

Guillaume

FAndreas  
#3 Posted : Saturday, March 4, 2017 8:30:16 PM(UTC)
FAndreas

Rank: Advanced Member

Groups: Registered
Joined: 5/16/2014(UTC)
Posts: 63
Man
Location: Germany

Hi Guillaume,

Yes, I remember that Media Express shows "detected 1080p25" when I set cameras to 1080p50.
Mhh, but I am wondering why my Samsung TV tells me in the info box that it is a 1080p50 source?
And in the menue there's an output option for 50p, mmh. Very strange.

Andreas.
DWAM  
#4 Posted : Saturday, March 4, 2017 8:50:22 PM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,288
Man
France
Location: Bordeaux, France

Thanks: 193 times
Was thanked: 655 time(s) in 502 post(s)
You're right, maybe it's an issue with BMD cards and not the Canon. Tomorrow I will try with a Magewell dongle to see if I can get 1080p50 out of my HF G30.

Quote:
And in the menue there's an output option for 50p

Which menu are you talking about? The recording section or the HDMI out setting ?
The only setting where I can select 1080p50 is recording. For HDMI out setting I can only choose between 1080i or 1080p with no indication of framerate.

Also the HDMI status on the cam shows 1080p25 when I choose 1080p50 for recording and 1080p for HDMI out. Is this same for you?

FAndreas  
#5 Posted : Saturday, March 4, 2017 9:14:06 PM(UTC)
FAndreas

Rank: Advanced Member

Groups: Registered
Joined: 5/16/2014(UTC)
Posts: 63
Man
Location: Germany

Sorry, my fault.
The Canon HDMI output menue does not contain any image rates. There's only 1080p, 1080i, etc. like you said. I misinterpreted the options.
I'll check HDMI Status info and report.
Thank you.
FAndreas  
#6 Posted : Sunday, March 5, 2017 2:21:11 PM(UTC)
FAndreas

Rank: Advanced Member

Groups: Registered
Joined: 5/16/2014(UTC)
Posts: 63
Man
Location: Germany

Hi Guillaume,

I checked it:
HDMI Status in Canon menue tells me 1920x1080p but no framerates.
I also tested again with Media Express and it definitley detects a 25p stream.
I now believe that my TV does not tell the truth with 50p.

I sent a support request to Canon and Blackmagic Design.
Will see what especially Canon will say to HDMI output of this two cameras.
DWAM  
#7 Posted : Sunday, March 5, 2017 2:42:47 PM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,288
Man
France
Location: Bordeaux, France

Thanks: 193 times
Was thanked: 655 time(s) in 502 post(s)
Andreas

I tried the HF G30 with Magewell XI100DUSB-HDMI this afternoon.

Using Dongle Helper (the magewell utility to check the signal) I was able to choose 1080p50 but I have no proof it is really p50.
Same with vMix, it accepts 1080p50 for this input but nothing proves it is really 50 fps.

Keep us posted...

Bis bald,
Guillaume
thanks 1 user thanked DWAM for this useful post.
stigaard on 3/6/2017(UTC)
FAndreas  
#8 Posted : Saturday, March 11, 2017 5:56:35 AM(UTC)
FAndreas

Rank: Advanced Member

Groups: Registered
Joined: 5/16/2014(UTC)
Posts: 63
Man
Location: Germany

I have response from Canon.

The Canon HF G30/40 definitely outputs 1080p50 over HDMI when camera is set to 1080p.

No response from Blackmagic until now.

Maybe the problem is a combination of the different parts? Not sure.
DWAM  
#9 Posted : Saturday, March 11, 2017 11:33:17 AM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,288
Man
France
Location: Bordeaux, France

Thanks: 193 times
Was thanked: 655 time(s) in 502 post(s)
Hi Andreas

thanks for the feedback. I'm very surprised by this answer because I never saw Decklinks cards detecting 50p, but only 25p. Maybe it's 50PsF?

I'll check again. I have Declink Mini Recorder, Ultra Studio Thunderbolt and Decklink Duo 2.

Let me know if you achieve to get 50p from Canons or get an answer from BMD.
Guillaume
FAndreas  
#10 Posted : Sunday, March 12, 2017 4:05:41 PM(UTC)
FAndreas

Rank: Advanced Member

Groups: Registered
Joined: 5/16/2014(UTC)
Posts: 63
Man
Location: Germany

A user on Blackmagic Design Forum gets 1080p50 with HF G40 and Atem Television Studio HD.
But only when he inputs over HDMI direct. With a BMD HDMI to SDI converter it doesn't work.
Seems to be a similar problem.
DWAM  
#11 Posted : Sunday, March 12, 2017 4:35:43 PM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,288
Man
France
Location: Bordeaux, France

Thanks: 193 times
Was thanked: 655 time(s) in 502 post(s)
Yep this might be the reason I agree. That's also what I said before having 1080p50 with direct HDMI thru Magewell dongle. I doubted it was really 1080p50 but why not after all?
Too bad I can't try with Atem, I have first version that won't support 1080p50, only 1080i50.
richardgatarski  
#12 Posted : Sunday, March 12, 2017 5:41:20 PM(UTC)
richardgatarski

Rank: Advanced Member

Groups: Registered
Joined: 2/18/2014(UTC)
Posts: 1,469
Location: Stockholm

Thanks: 116 times
Was thanked: 228 time(s) in 191 post(s)
My bet is on that the converter is the bad guy.
We have a bunch of G30s. I am pretty well,5 sure of, convinced etc, that they deliver 1080p50.

DWAM  
#13 Posted : Monday, March 13, 2017 4:23:10 PM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,288
Man
France
Location: Bordeaux, France

Thanks: 193 times
Was thanked: 655 time(s) in 502 post(s)
I did more testing with HF G30 and several HDMI2SDI converters to a BMD Decklink Duo 2.
Camera set to 1080p50 for recording options, HDMI out set to 1080p

- With BMD Mini Converter (old model the big one) I get 1080p50 stable either in Desktop Video Utility and vMix
- With BMD Mini Converter (new model the small one) I get 1080p50 stable either in Desktop Video Utility and vMix
- With Chinese Converters (many brands, the black cheap models from ebay or amazon) I get 1080p25 everywhere

One thing is curious: Activating the Cinema mode when in 1080p50 switches to 1080i50 on screen but Desktop Video Utility still shows 1080p50.
I read somewhere that Cinema mode was limited to 25p (which is coherent for cinema when this cam cannot do 24p).
This is very confusing.

But in the end yes, 1080p50 is possible even with BMD converters and SDI cables.

I did not try with different HDMI cables between the cam and the converters. This could also interfere with frequency support.

Guillaume
thanks 1 user thanked DWAM for this useful post.
stigaard on 3/13/2017(UTC)
FAndreas  
#14 Posted : Thursday, April 20, 2017 10:16:24 AM(UTC)
FAndreas

Rank: Advanced Member

Groups: Registered
Joined: 5/16/2014(UTC)
Posts: 63
Man
Location: Germany

Thank you guys for testing!
After all this time, I still have no solution from Blackmagic.
They examine the problem in development. That's what they said in the last mail.

@Guillaume
Did I understand you correctly that you get a stable 1080p50 with a BMD Micro Converter HDMI to SDI to Decklink Duo 2?
That would be exactly what I can not do.

Regards
Andreas
DWAM  
#15 Posted : Thursday, April 20, 2017 10:53:32 AM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,288
Man
France
Location: Bordeaux, France

Thanks: 193 times
Was thanked: 655 time(s) in 502 post(s)
Quote:
Did I understand you correctly that you get a stable 1080p50 with a BMD Micro Converter HDMI to SDI to Decklink Duo 2?
That would be exactly what I can not do.


Hi Andreas

yes you understood correctly. Using BMD converters with a HF G30 (correctly set) I have stable 1080p50 inside vMix through a BMD Decklink Duo 2.
Make sure Cinema Mode is not interfering with the output.

Guillaume
FAndreas  
#16 Posted : Wednesday, April 26, 2017 9:03:32 AM(UTC)
FAndreas

Rank: Advanced Member

Groups: Registered
Joined: 5/16/2014(UTC)
Posts: 63
Man
Location: Germany

Very strange.
I do not use cinema mode (the button on the top of the camera) and I tried every freaking setting.
Sorry, but I have absoluteley no idea what i missed here?

Just to tripple check. :) This adapter HDMI-SDI?
https://www.blackmagicde...products/microconverters
Iam using latest firmware on this. Maybe that's the difference?

You set recording to MP4 odr AVCHD? I tried both with and without 50p recording.
I definitley set HDMI output to 50p and as I said before, my TV show that it is 50p (info box).

I tried different HDMI and SDI cables. I have latest firmware on Decklink Duo 2.

Could you help me out please? :)

Thanks,
Andreas.
stigaard  
#17 Posted : Wednesday, April 26, 2017 9:11:00 AM(UTC)
stigaard

Rank: Advanced Member

Groups: Registered
Joined: 5/20/2015(UTC)
Posts: 431
Man
Denmark
Location: Copenhagen, Denmark

Thanks: 289 times
Was thanked: 86 time(s) in 69 post(s)
A little research gave me this page: https://www.atomos.com/cameras/canon-hf-g30

Which states that the output resolution for 1080 is 25p / 30p (and 50i / 60i).

When going down to 720p it supports 50p and 60p.

It is not an official Canon page, but i bet that Atomos is pretty reliable.

I recommend using Canon G30 HDMI output in 720p50/60 for high-motion footage like sports.

/ Jens Stigaard
DWAM  
#18 Posted : Wednesday, April 26, 2017 2:26:17 PM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,288
Man
France
Location: Bordeaux, France

Thanks: 193 times
Was thanked: 655 time(s) in 502 post(s)
Hi

A quick video demonstrating the Canon HF G30 outputting 1080p50 through both models of BMD HDMI2SDI converters to a BMD Decklink Duo2 for vMix.



Andreas,
first set your Canon for 1080p in HDMI settings.
Movie format is AVCHD
Start with Recording Mode set to 24 Mbps LPCM, I sometimes have issues when set to 28 Mbps for initial connection with the Micro Converter only (with mini converter it always work). Once 1080p50 is detected, then you can switch to 28 Mbps LPCM 50p. Anyway, in both modes HDMI outputs 50p, it only changes the framerate for recording.

Bis bald
Guillaume

thanks 1 user thanked DWAM for this useful post.
Ario on 6/13/2019(UTC)
FAndreas  
#19 Posted : Wednesday, May 3, 2017 4:33:33 AM(UTC)
FAndreas

Rank: Advanced Member

Groups: Registered
Joined: 5/16/2014(UTC)
Posts: 63
Man
Location: Germany

Hei Guillaume,

thank you very much for your response and this great video... :)
Sorry for coming back so late but I was very busy.

Unfortunately I am not able to get 50p working with your hints.
I tried it exactly the why you did but I have no luck and no more ideas.

I wonder why it works with you.

Mach's gut. :)
Andreas
DWAM  
#20 Posted : Wednesday, May 3, 2017 4:59:42 AM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,288
Man
France
Location: Bordeaux, France

Thanks: 193 times
Was thanked: 655 time(s) in 502 post(s)
That's weird! Are you sure you previously set your vMix project for 50p? That's what makes the Decklink output 25 or 50 frames.
Users browsing this topic
2 Pages12>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.