logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
NiBTour  
#1 Posted : Tuesday, August 23, 2016 7:32:15 PM(UTC)
NiBTour

Rank: Advanced Member

Groups: Registered
Joined: 3/28/2016(UTC)
Posts: 126
Man
United States
Location: SACRAMENTO

Thanks: 1 times
Was thanked: 15 time(s) in 14 post(s)
Specs:
Laptop
DELL Precision 7510 Win 10 Pro
Intel i7-6920HQ 2.9 Quad Core with Thunderbolt 3 (Controller 1575)
Nvidia Quadro M2000M 4GB + Intel HD 530
32Gigs
512GB M.s SSD

Software:
Vmix 17.0.107
Decklink drivers 10.7.1

Chassis
Connected to a Sonnet Echo SE II via Thunderbolt
With 1x Decklink Duo 2 card in the 16x slot (nothing else in the chassis)

*Note I have used this card with vMix before using the same SDI cables, same splitters and cameras without issue. The difference is in regards to the laptop and chassis


So once everything is setup vMix recognizes the BMD card without issue and I get feeds from my two inputs just fine. All CPU levels and the render Time all well within their respected limits (8%/ 4ms).

The issue comes intermittent and it does reflect on the recordings as well but vMix doesn’t seem to see any drop frames or anything. If it does see a source dropped frame its 1 or 2 but doesn’t line up with the intermittent flicker of a black frame. Basically both feeds will be fine and then one will just flicker and the other one would be fine and then the second feed would just flicker. It’s like milliseconds but enough for me to notice it and during a few hours it could happen 60+ times but vMix will say 2 dropped frames via source so the two don’t seem to line up.

I’ve re-installed all new drivers for the laptop and thunderbolt as well as the BDM card. I even tried switching slots in the Sonnet with no difference. I tried replacing cables and everything but it seems to be on the Sonnet side feeding vMix. It’s like the black flicker comes in to vMix as part of the feed and not a result of a dropped frame or something. At this point I’m not sure what to try and BDM support ticket has been open but this BDM product works fine in other setups just not in the Sonnet so I’m sure it’s something of a setting or I just don’t know at this point.

Has anyone seen intermittent flickers of a black frame from BDM feeding your laptop via Thunderbolt and the Sonnet Echo SE II?

Does anyone have advice on what I should try and what settings I should have in vMix (such as the Performance settings with the GPU and Optimus Graphics compatibility which I have checked) or in BDM or anything? Help 

UPDATE 8/23

So after replacing all the drivers cables and anything i could replace i did with the exception of the Sonnit and the BMD Duo 2. And unfortunately i still get the glitch. Whats strange is vMix does not see this has a dropped frame and the logs show 0 dropped frames even though it happens a few times a minute. When i record it and move the the frame that glitched its just a solid black frame lasting half a second. I have connected 2 cameras up to 6 cameras and there is no difference in time they glitch and they do not all glitch at the same time. Some won't do it for minutes at a time.

some cameras i've used:

Marshall VC345-CBS over SDI
Canon Vixia mini via a BMD converter from HDMI to SDI
Canon A35 over SDI

Ive tested all these over HDMI and they run fine but not via the sonnet using Thunderbolt 2.

i'm going to try to call DELL next but i'm not sure whatelse to try. I might just ditch it all together.


What laptops are known to work well with vMix and via a Sonnet Echo SE II with two BND decklink cards?

-king
NiBTour  
#2 Posted : Wednesday, August 31, 2016 12:56:05 AM(UTC)
NiBTour

Rank: Advanced Member

Groups: Registered
Joined: 3/28/2016(UTC)
Posts: 126
Man
United States
Location: SACRAMENTO

Thanks: 1 times
Was thanked: 15 time(s) in 14 post(s)
Anyone? What setup are people using with the Sonnet Echo SE II and Decklink Duo 2 cards that work?
Kelvin  
#3 Posted : Wednesday, August 31, 2016 12:10:49 PM(UTC)
Kelvin

Rank: Advanced Member

Groups: Registered
Joined: 2/9/2013(UTC)
Posts: 232
Location: Katy, Texas

Was thanked: 36 time(s) in 36 post(s)
I'm using that Sonnet box with my Asus ROG751 running Windows 8.1. The cards in the box are a Magewell 4xSDI card and an BMD Intensity Pro. Everything works fine with Windows 8.1. I have another SSD with Windows 10 installed and occasionally I get a BSOD. Will be doing more troubleshooting on the Win10 system over the winter. Will continue windows 8.1 through October at least.

NiBTour  
#4 Posted : Wednesday, August 31, 2016 10:00:51 PM(UTC)
NiBTour

Rank: Advanced Member

Groups: Registered
Joined: 3/28/2016(UTC)
Posts: 126
Man
United States
Location: SACRAMENTO

Thanks: 1 times
Was thanked: 15 time(s) in 14 post(s)
Kelvin wrote:
I'm using that Sonnet box with my Asus ROG751 running Windows 8.1. The cards in the box are a Magewell 4xSDI card and an BMD Intensity Pro. Everything works fine with Windows 8.1. I have another SSD with Windows 10 installed and occasionally I get a BSOD. Will be doing more troubleshooting on the Win10 system over the winter. Will continue windows 8.1 through October at least.



i think the problem is Thunderbolt 2 to 3 conversion or its the Sonnett box itself. using an external raid works fine and so does the BDM card itself in another machine so its either the chassis or the converter. so i got a different converter and chassis just to test. BDM got back to me but they don't support chassis workflows and to be honest i don't think its a BDM issue since the card works unless its some SDI thing
NiBTour  
#5 Posted : Friday, September 2, 2016 5:16:41 AM(UTC)
NiBTour

Rank: Advanced Member

Groups: Registered
Joined: 3/28/2016(UTC)
Posts: 126
Man
United States
Location: SACRAMENTO

Thanks: 1 times
Was thanked: 15 time(s) in 14 post(s)
Kelvin wrote:
I'm using that Sonnet box with my Asus ROG751 running Windows 8.1. The cards in the box are a Magewell 4xSDI card and an BMD Intensity Pro. Everything works fine with Windows 8.1. I have another SSD with Windows 10 installed and occasionally I get a BSOD. Will be doing more troubleshooting on the Win10 system over the winter. Will continue windows 8.1 through October at least.




So i finally got the replacements i needed to see if i could better troubleshoot and isolate the issue. Well, it turns out even though the BDM Decklink Duo 2's worked fine in another computer they simply don't work with Thunderbolt 3 adapter and the sonnet echo SE II. The cards will recognize and will display data but glitches and sends black frames that seem not to register as drop frames in vMix or even BDM's own studio software but they are there.

I was able to replace every piece of hardware one at a time to isolate the issue and the only piece that caused the issue was the BDM's. Magewell and AJA's worked fine with both Thunderbolt 2 and 3 adapters under Win 10 Pro 64bit and the Sonnet Echo with Dell Precision 7510. BDM didn't want to get involved even when it was only their card that failed due to they didn't support chassis workflows but i still know the cards work fine, they just don't work with the systems included in my tests. i wish i knew what caused it since their not dropped frames and they are not coming from the sources.

anyway i already started ditching BDM products where i can for AJA since they just worked so much better and ive always had driver and picky issues with BDM. I still love a lot of their gear but it always seemed like the solution was go back to 10.6.5 when their on 7 or wait until that vendor releases a driver. anyway i also tested the AJA io 4k and love it!

i also came across this gem https://www.akitio.com/expansion/thunder3-pcie-box but haven't found it available yet although it says you can buy it now wand they released it in August.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.