logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

57 Pages«<23456>»
Options
Go to last post Go to first unread
elgarf  
#61 Posted : Friday, July 8, 2016 9:25:43 AM(UTC)
elgarf

Rank: Advanced Member

Groups: Registered
Joined: 10/23/2015(UTC)
Posts: 458
Man
Russian Federation

Thanks: 20 times
Was thanked: 205 time(s) in 127 post(s)
That's minimum example of image binding.
As I told, I thought about image widget, but SetImage function doesn't accept url's.
File Attachment(s):
MinimumImageSourceBinding.xaml (1kb) downloaded 155 time(s).

You cannot view/download attachments. Try to login or register.
thanks 1 user thanked elgarf for this useful post.
corporatejames on 7/8/2016(UTC)
Jedda  
#62 Posted : Friday, July 8, 2016 3:22:17 PM(UTC)
Jedda

Rank: Advanced Member

Groups: Registered
Joined: 3/21/2016(UTC)
Posts: 68
Location: Sweden

Thanks: 13 times
Was thanked: 3 time(s) in 3 post(s)
elgarf wrote:
@Jedda, you can start both timers without noticeable delay.

Button script can contain a lot of functions, which are executed sequentially. So you can start as many timers as you want almost in one time.

With new "link" ability you can also start timers, provided by controller.

Better solution is to try :)


Sounds good that it's doable, but I'm a bit unsure as to how to do it. This is what it looks like right now, but how do I make a button that can start/pause all these 4 clocks at the same time?

Of course I'm aware that I'll most likely have to adjust all the times manually if I for example pause too late and need to adjust the game clock. But that's perfectly fine, as long as I can start and stop all clocks with one click.
Jedda attached the following image(s):
time.jpg (110kb) downloaded 65 time(s).

You cannot view/download attachments. Try to login or register.
corporatejames  
#63 Posted : Friday, July 8, 2016 9:19:43 PM(UTC)
corporatejames

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2015(UTC)
Posts: 364
Man
Australia
Location: Sydney

Thanks: 280 times
Was thanked: 75 time(s) in 61 post(s)
elgarf wrote:
That's minimum example of image binding.
As I told, I thought about image widget, but SetImage function doesn't accept url's.


Can confirm this method works :) Updating XAMl now for further testing. I have tried on my Team Roster title and its working from HomeBG.
Going to update all the Player Profile images and test Starting5. Happy Days.
corporatejames  
#64 Posted : Friday, July 8, 2016 10:54:46 PM(UTC)
corporatejames

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2015(UTC)
Posts: 364
Man
Australia
Location: Sydney

Thanks: 280 times
Was thanked: 75 time(s) in 61 post(s)
Starting 5 working from CMS Database XML feed to load player images.
corporatejames  
#65 Posted : Saturday, July 9, 2016 11:05:18 PM(UTC)
corporatejames

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2015(UTC)
Posts: 364
Man
Australia
Location: Sydney

Thanks: 280 times
Was thanked: 75 time(s) in 61 post(s)
@elgarf Are you able to add disable widget function? So we can turn off the ExternalData widgets when not needed one by one?
Eg While I'm testing so I don't change a widget I have already setup I make a copy of it and make changes or add functions
but the other one is still active at the same time so I temporarily change the xml url so it return no rows.
Be great if can turn off a widget so it doesn't read the xml file or send data back to vmix.
Not sure if easy to add but would be handy.

Also Application link when on another pc seems to be brock with 17.0.0.100 was working with earlier versions.
Only just notice today when I copied latest template and vmicUTC to my laptop. It looks like its not pulling the inputs
from the external IP. If I open the local Vmix its pulls the inputs from local even though the IP is a network IP and says connected.
Update state doesn't resolve the issue. Status just reads Update State (Yellow).
elgarf  
#66 Posted : Sunday, July 10, 2016 2:41:55 AM(UTC)
elgarf

Rank: Advanced Member

Groups: Registered
Joined: 10/23/2015(UTC)
Posts: 458
Man
Russian Federation

Thanks: 20 times
Was thanked: 205 time(s) in 127 post(s)
Maybe I broke loading state from external ip with latest update. I'll look at this.
Disabling widgets is ok, I'll think on this.
thanks 1 user thanked elgarf for this useful post.
corporatejames on 7/10/2016(UTC)
corporatejames  
#67 Posted : Sunday, July 10, 2016 3:40:39 AM(UTC)
corporatejames

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2015(UTC)
Posts: 364
Man
Australia
Location: Sydney

Thanks: 280 times
Was thanked: 75 time(s) in 61 post(s)
elgarf wrote:
Maybe I broke loading state from external ip with latest update. I'll look at this.
Disabling widgets is ok, I'll think on this.


No worries. Yeah not sure why it stopped working.
corporatejames  
#68 Posted : Wednesday, July 13, 2016 7:57:33 AM(UTC)
corporatejames

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2015(UTC)
Posts: 364
Man
Australia
Location: Sydney

Thanks: 280 times
Was thanked: 75 time(s) in 61 post(s)
elgarf wrote:
Maybe I broke loading state from external ip with latest update. I'll look at this.
Disabling widgets is ok, I'll think on this.


Any luck at having a look into the external issue? No worries if busy.

elgarf  
#69 Posted : Wednesday, July 13, 2016 9:06:44 AM(UTC)
elgarf

Rank: Advanced Member

Groups: Registered
Joined: 10/23/2015(UTC)
Posts: 458
Man
Russian Federation

Thanks: 20 times
Was thanked: 205 time(s) in 127 post(s)
Sometime later, @corporatejames.
RC_31  
#70 Posted : Thursday, July 14, 2016 8:28:58 AM(UTC)
RC_31

Rank: Member

Groups: Registered
Joined: 8/4/2015(UTC)
Posts: 24
Location: Spain

Thanks: 9 times
Was thanked: 1 time(s) in 1 post(s)
THIS IS AMAZING. THANKS A LOT!!!!!!
elgarf  
#71 Posted : Thursday, July 14, 2016 12:15:09 PM(UTC)
elgarf

Rank: Advanced Member

Groups: Registered
Joined: 10/23/2015(UTC)
Posts: 458
Man
Russian Federation

Thanks: 20 times
Was thanked: 205 time(s) in 127 post(s)
@corporatejames, I've fixed bug with external PC. Disabling widgets will be later.
@Jedda,
1) go to the properties window of timer
2) check "Start" checkbox in the hotkeys section
3) input some text into "Link" textfield - this will be name of event
4) repeat with other timers
5) create button widget
6) add command into script section of button widget properties
7) select ExecLink command into commands list
8) write text, which you have writed in 3rd event of this instruction into "String" field
9) now, when you push button, all timers will start
10) repeat same events for stop button
@RC_31, thanks!

Updated first post
thanks 1 user thanked elgarf for this useful post.
corporatejames on 7/14/2016(UTC)
Jedda  
#72 Posted : Thursday, July 14, 2016 4:49:47 PM(UTC)
Jedda

Rank: Advanced Member

Groups: Registered
Joined: 3/21/2016(UTC)
Posts: 68
Location: Sweden

Thanks: 13 times
Was thanked: 3 time(s) in 3 post(s)
Big thanks for that guide elgarf, will for sure have a look at this when I get some time. Either way, this is already an awesome tool. It has already helped out a bunch, especially after there has started to be a few minor issues with Raynignons football tool with some vMix updates.
Jedda  
#73 Posted : Thursday, July 14, 2016 7:28:38 PM(UTC)
Jedda

Rank: Advanced Member

Groups: Registered
Joined: 3/21/2016(UTC)
Posts: 68
Location: Sweden

Thanks: 13 times
Was thanked: 3 time(s) in 3 post(s)
elgarf wrote:
@corporatejames, I've fixed bug with external PC. Disabling widgets will be later.
@Jedda,
1) go to the properties window of timer
2) check "Start" checkbox in the hotkeys section
3) input some text into "Link" textfield - this will be name of event
4) repeat with other timers
5) create button widget
6) add command into script section of button widget properties
7) select ExecLink command into commands list
8) write text, which you have writed in 3rd event of this instruction into "String" field
9) now, when you push button, all timers will start
10) repeat same events for stop button
@RC_31, thanks!

Updated first post


Got around to try this now, but when I click the start/pause/stop buttons that I've created, nothing happens. Any idea what I'm doing wrong? Attached a screenshot of how the all the time properties look and the button properties. None of the timers start when pressing the start button.
Jedda attached the following image(s):
utc.jpg (292kb) downloaded 106 time(s).

You cannot view/download attachments. Try to login or register.
corporatejames  
#74 Posted : Thursday, July 14, 2016 8:17:16 PM(UTC)
corporatejames

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2015(UTC)
Posts: 364
Man
Australia
Location: Sydney

Thanks: 280 times
Was thanked: 75 time(s) in 61 post(s)
Jedda wrote:
elgarf wrote:
@corporatejames, I've fixed bug with external PC. Disabling widgets will be later.
@Jedda,
1) go to the properties window of timer
2) check "Start" checkbox in the hotkeys section
3) input some text into "Link" textfield - this will be name of event
4) repeat with other timers
5) create button widget
6) add command into script section of button widget properties
7) select ExecLink command into commands list
8) write text, which you have writed in 3rd event of this instruction into "String" field
9) now, when you push button, all timers will start
10) repeat same events for stop button
@RC_31, thanks!

Updated first post


Got around to try this now, but when I click the start/pause/stop buttons that I've created, nothing happens. Any idea what I'm doing wrong? Attached a screenshot of how the all the time properties look and the button properties. None of the timers start when pressing the start button.


Have you downloaded the latest version from the start of this forum? I had that fault when I first asked for feature and @elgarf fixed it in the next update that the ExecLink
worked correctly.
thanks 1 user thanked corporatejames for this useful post.
Jedda on 7/15/2016(UTC)
elgarf  
#75 Posted : Thursday, July 14, 2016 10:33:06 PM(UTC)
elgarf

Rank: Advanced Member

Groups: Registered
Joined: 10/23/2015(UTC)
Posts: 458
Man
Russian Federation

Thanks: 20 times
Was thanked: 205 time(s) in 127 post(s)
@Jedda, if you use the last version, please, share .vmc file?
thanks 1 user thanked elgarf for this useful post.
Jedda on 7/15/2016(UTC)
corporatejames  
#76 Posted : Friday, July 15, 2016 1:46:12 AM(UTC)
corporatejames

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2015(UTC)
Posts: 364
Man
Australia
Location: Sydney

Thanks: 280 times
Was thanked: 75 time(s) in 61 post(s)
@elgarf confirmed external IP working again. Thanks
elgarf  
#77 Posted : Friday, July 15, 2016 6:07:30 AM(UTC)
elgarf

Rank: Advanced Member

Groups: Registered
Joined: 10/23/2015(UTC)
Posts: 458
Man
Russian Federation

Thanks: 20 times
Was thanked: 205 time(s) in 127 post(s)
@corporatejames, as I understood, you need only disable external data widgets?
corporatejames  
#78 Posted : Friday, July 15, 2016 7:22:01 AM(UTC)
corporatejames

Rank: Advanced Member

Groups: Registered
Joined: 8/2/2015(UTC)
Posts: 364
Man
Australia
Location: Sydney

Thanks: 280 times
Was thanked: 75 time(s) in 61 post(s)
elgarf wrote:
@corporatejames, as I understood, you need only disable external data widgets?


Yeah I think so at this time. Always thinking of great ways you can use it. Just a handy feature.

Ideally would be to have that feature I mention before of SetText and SetImage tickbox on the ExternalData widget
title mappings. So basically if you tick the box to enable setimage the data value for that title mapping would be
a path to image eg C:\images\image.png etc otherwise the field is the normal setText which you have now.

Your binding xaml hack is working (thanks) but just much easier to bind within the Widget so don't need a lot of extra titles just to store the image paths.
Jedda  
#79 Posted : Friday, July 15, 2016 8:32:19 AM(UTC)
Jedda

Rank: Advanced Member

Groups: Registered
Joined: 3/21/2016(UTC)
Posts: 68
Location: Sweden

Thanks: 13 times
Was thanked: 3 time(s) in 3 post(s)
corporatejames wrote:
Jedda wrote:
elgarf wrote:
@corporatejames, I've fixed bug with external PC. Disabling widgets will be later.
@Jedda,
1) go to the properties window of timer
2) check "Start" checkbox in the hotkeys section
3) input some text into "Link" textfield - this will be name of event
4) repeat with other timers
5) create button widget
6) add command into script section of button widget properties
7) select ExecLink command into commands list
8) write text, which you have writed in 3rd event of this instruction into "String" field
9) now, when you push button, all timers will start
10) repeat same events for stop button
@RC_31, thanks!

Updated first post


Got around to try this now, but when I click the start/pause/stop buttons that I've created, nothing happens. Any idea what I'm doing wrong? Attached a screenshot of how the all the time properties look and the button properties. None of the timers start when pressing the start button.


Have you downloaded the latest version from the start of this forum? I had that fault when I first asked for feature and @elgarf fixed it in the next update that the ExecLink
worked correctly.


That was it, now it works just like I want it to :) Thanks guys!
thanks 1 user thanked Jedda for this useful post.
corporatejames on 7/15/2016(UTC)
elgarf  
#80 Posted : Wednesday, July 20, 2016 5:07:33 AM(UTC)
elgarf

Rank: Advanced Member

Groups: Registered
Joined: 10/23/2015(UTC)
Posts: 458
Man
Russian Federation

Thanks: 20 times
Was thanked: 205 time(s) in 127 post(s)
Updated with ability of disabling External Widget and new "Multi State" widget, which translates commands from master vMix system to slave vMix system (so, you can control two or more vMix systems with same configuration through one controller).

First post
thanks 1 user thanked elgarf for this useful post.
corporatejames on 7/20/2016(UTC)
Users browsing this topic
Guest
57 Pages«<23456>»
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.