logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
msugg  
#1 Posted : Wednesday, December 23, 2015 11:31:08 AM(UTC)
msugg

Rank: Newbie

Groups: Registered
Joined: 12/23/2015(UTC)
Posts: 2

Using Windows 10 on laptop with a GeForce 940m.

If I use the nvidia control panel to force vMix to use the nvidia card, then I get this memory error at launch. If I allow vMix to use the integrated intel graphics, then it will launch, but it crashes after about 2 hours.

I have a second laptop, different hardware and windows 7. On that machine, vMix will launch with the nvidia card select in the nvidia control panel and run forever without crashing.

Anyone run into this?
DYosua  
#2 Posted : Wednesday, December 23, 2015 9:53:38 PM(UTC)
DYosua

Rank: Advanced Member

Groups: Registered
Joined: 2/24/2014(UTC)
Posts: 43
Man
United States
Location: Maine, USA

Thanks: 23 times
Was thanked: 14 time(s) in 12 post(s)
I recently purchased an Acer Aspire Nitro Black Edition i7 laptop with the NVIDIA GeForce GTX 960m and have run into the same error when attempting to open with the dedicated card. The program loads fine using Integrated graphics, although I haven't experienced any crashes while using them.

The basic specs of the laptop are:
Intel i7-6700HQ CPU @ 2.60GHz
Windows 10
16GB DDR4 RAM
NVIDIA GeForce GTX 960m (4GB version)
Intel HD Graphics 530
DYosua attached the following image(s):
vMix Error.jpg (35kb) downloaded 4 time(s).

You cannot view/download attachments. Try to login or register.
admin  
#3 Posted : Thursday, December 24, 2015 3:19:49 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,243
Man
Location: Gold Coast, Australia

Was thanked: 2365 time(s) in 1036 post(s)
Hi guys,

So far I have only heard reports on this error on some laptops but as of yet have been unable to recreate it on the laptops
I have access to.

The usual things to try first are to install the very latest Intel and Nvidia drivers (Nvidia just released an update this week)
and make sure Windows 10 is completely up to date.
Also try running dxdiag and confirming that the display model listed under all the Display x tabs are "WDDM 2.0" and not an older version such as 1.1 or 1.2

Failing that, if there is a relatively cheap laptop still for sale that someone knows definitely causes this issue
we might just have to buy it and run some tests to isolate the problem.

Based on the error report, the error is coming from the Nvidia driver, but any more than that is hard to figure out without
the laptop to test with.

Regards,

Martin
vMix
Kalink  
#4 Posted : Monday, January 4, 2016 3:37:27 PM(UTC)
Kalink

Rank: Member

Groups: Registered
Joined: 9/1/2015(UTC)
Posts: 24

Was thanked: 1 time(s) in 1 post(s)
admin wrote:
Hi guys,

So far I have only heard reports on this error on some laptops but as of yet have been unable to recreate it on the laptops
I have access to.

The usual things to try first are to install the very latest Intel and Nvidia drivers (Nvidia just released an update this week)
and make sure Windows 10 is completely up to date.
Also try running dxdiag and confirming that the display model listed under all the Display x tabs are "WDDM 2.0" and not an older version such as 1.1 or 1.2

Failing that, if there is a relatively cheap laptop still for sale that someone knows definitely causes this issue
we might just have to buy it and run some tests to isolate the problem.

Based on the error report, the error is coming from the Nvidia driver, but any more than that is hard to figure out without
the laptop to test with.

Regards,

Martin
vMix


Hi, I got notebook Acer Predator 15 with Nvidia 980m 4GB ram, and have same issiue here. On intel gpu it works, and when i switch on Nvidia i got this message. i have latest drivers from acer and as well i tried nvidia's drivers...please help :( cant be problem with 4GB ram on gpu card?
Ash  
#5 Posted : Monday, January 4, 2016 5:58:08 PM(UTC)
Ash

Rank: Advanced Member

Groups: Registered
Joined: 11/19/2013(UTC)
Posts: 120
Location: Hobart Tasmania Australia

Thanks: 13 times
Was thanked: 8 time(s) in 7 post(s)
Hi

I had exact same problem on ASUS G750 Laptop with Intel GPU and NVidia 880M.

Works with Intel GPU but not with NVidia driver.

Had to go back to 8.1

Kalink  
#6 Posted : Monday, January 4, 2016 8:55:41 PM(UTC)
Kalink

Rank: Member

Groups: Registered
Joined: 9/1/2015(UTC)
Posts: 24

Was thanked: 1 time(s) in 1 post(s)
I cannot, there are no drivers for 8.1 on my notebook...or i can use for win 10?
Kelvin  
#7 Posted : Monday, January 4, 2016 11:15:08 PM(UTC)
Kelvin

Rank: Advanced Member

Groups: Registered
Joined: 2/9/2013(UTC)
Posts: 228
Location: Katy, Texas

Was thanked: 36 time(s) in 36 post(s)
I have an ASUS ROG G751JY. It only has the NVidia 980M. I primarily run Win 8.1, but just recently did a clean install of Windows 10 on a separate SSD for testing. Does this error occur immediately on startup of vMix or sometime later? For me, launching the program worked fine, haven't had time for further testing yet.
Kalink  
#8 Posted : Tuesday, January 5, 2016 6:10:41 AM(UTC)
Kalink

Rank: Member

Groups: Registered
Joined: 9/1/2015(UTC)
Posts: 24

Was thanked: 1 time(s) in 1 post(s)
It is doing from start, Vmix dont even see Nvidia card in list (performance tab), only Intel GPU.
My idea was to use desktop on intel gpu and do exclusively vmix on 980m

Update: I cant go to win 8.1, no drivers work :/
msugg  
#9 Posted : Tuesday, January 5, 2016 3:53:10 PM(UTC)
msugg

Rank: Newbie

Groups: Registered
Joined: 12/23/2015(UTC)
Posts: 2

I've now done this with 4 different pieces of hardware - Asus x2, Acer, Dell. Each machine has some sort of nvida moble gpu, not the same one exactly.

With Windows 10, the vMix settings > performance tab will only see the intel GPU. If you disable that GPU in the windows device manager, it launches vMix using the "microsoft basic rendering whatnot". If you use the nvidia control panel to force vMix into using the nvida card vMix fails to load and displays a memory error.

With Windows 8.1, vMix selects the nvida card (seen in settings > performance) and runs forever without crashing.

Oddly, my Dell machine is pretty nice and it will run vMix well in Win 10 without its nvida card. However the machine costs about x2 as much as a win 8 machine using a dedicated card.

I can't believe that people from vMix cannot reproduce this situation. It happens like clockwork no matter what hardware I use. Seems like all that is required is a laptop with windows 10 and an nvida geforce M.

I'm looking to put together a sustainable solution that I can purchase multiple times. Buying laptops with win 8 is getting harder and harder. Does anyone have a fix for dedicated graphics in windows 10?
DYosua  
#10 Posted : Tuesday, January 5, 2016 6:21:55 PM(UTC)
DYosua

Rank: Advanced Member

Groups: Registered
Joined: 2/24/2014(UTC)
Posts: 43
Man
United States
Location: Maine, USA

Thanks: 23 times
Was thanked: 14 time(s) in 12 post(s)
Strangely enough, my issues were fixed shortly after Martin's post. I am running the current version of vMix (16.0.0.112) with the same NVIDIA drivers as before (10.18.13.5362, released on July 22, 2015). I have tried it several times and have restarted the laptop and have run into no further issues...
Kalink  
#11 Posted : Thursday, January 7, 2016 2:34:12 AM(UTC)
Kalink

Rank: Member

Groups: Registered
Joined: 9/1/2015(UTC)
Posts: 24

Was thanked: 1 time(s) in 1 post(s)
Unfortunatly those drivers dont work with my HW...i can do only acer's 353.0 and latest 361.53...no difference...at least i can do customized gpu encoding 1080@50p with 980m :)
PTZOptics  
#12 Posted : Saturday, February 13, 2016 12:44:45 PM(UTC)
PTZOptics

Rank: Advanced Member

Groups: Registered
Joined: 12/16/2015(UTC)
Posts: 32
Location: Philadelphia

Thanks: 6 times
Was thanked: 8 time(s) in 6 post(s)
OK,

Yes, I had the same problem. We ran all the updates and still had the same issue. Then one of our IT guys asked me to launch the vMix (x64) without and external monitor connected to the computer! HOLY MOLY it works. Then once vMix (x64) is opened up I can connect a 2nd monitor if needed!
admin  
#13 Posted : Monday, February 15, 2016 5:41:07 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,243
Man
Location: Gold Coast, Australia

Was thanked: 2365 time(s) in 1036 post(s)
We are aware of this error on some systems and it is caused by bug in Windows 10 when using Optimus graphics.
The fix as has been pointed out is to make sure only the laptop screen is in use before starting vMix and add the second screen later.

If that does not help you can also start vMix on integrated graphics and go to Settings -> Performance and turn off both FlipEx options
and then restart vMix using the dedicated graphics.

This will result in lower performance on the Fullscreen output but will at least allow you to consistently run vMix with a second display
on the systems where this bug is apparent.

Regards,

Martin
vMix
Kalink  
#14 Posted : Wednesday, February 17, 2016 12:41:43 PM(UTC)
Kalink

Rank: Member

Groups: Registered
Joined: 9/1/2015(UTC)
Posts: 24

Was thanked: 1 time(s) in 1 post(s)
Holly s**t, disabling both FlipEx options helped! Now i can do FHD 50p editing, streaming and anything!

Thanks Martin for your post!
krzychuz  
#15 Posted : Tuesday, June 21, 2016 5:47:54 AM(UTC)
krzychuz

Rank: Member

Groups: Registered
Joined: 6/4/2016(UTC)
Posts: 11
Man
Location: Warsaw, Poland

Thanks: 2 times
Was thanked: 3 time(s) in 3 post(s)
I'm bringing this topic up because I experience this problem on two laptops (one of them is MSI GS40 with i7-6700HQ and GTX 970M).
The error message is same as posted by DYosua
Quote:
The fix as has been pointed out is to make sure only the laptop screen is in use before starting vMix and add the second screen later.

Running vMix with no additional screens connected also leads me to this error.

Quote:
If that does not help you can also start vMix on integrated graphics and go to Settings -> Performance and turn off both FlipEx options
and then restart vMix using the dedicated graphics.

Turning FlipEx off makes running vMix possible but the Fullscreen output is blank.

I'm running the latest version, 17.0.0.92, and I made sure all my drivers are up to date.
Are there any new solutions or can I expect this bug to be resolved soon?
Thanks
admin  
#16 Posted : Tuesday, June 21, 2016 11:03:43 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,243
Man
Location: Gold Coast, Australia

Was thanked: 2365 time(s) in 1036 post(s)
Hi,

As an update, we have asked NVIDIA to look at these bugs in their Optimus driver and unfortunately
so far their response has been that they aren't interested in fixing them!

(Basically they are saying Optimus is only designed to work with a limited number of applications, mostly games)

So I need to investigate what workarounds might be available.
In particular for the blank fullscreen problem could users confirm the resolution of their laptop display and any displays being connected?
This information is found by running the msinfo32 app and looking under Components -> Display

Thanks,

Martin
vMix
admin  
#17 Posted : Saturday, June 25, 2016 8:47:12 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,243
Man
Location: Gold Coast, Australia

Was thanked: 2365 time(s) in 1036 post(s)
Please see thread below with a beta test that should fix Optimus problems for a number of users:

http://forums.vmix.com/d....aspx?g=posts&t=6476
thanks 1 user thanked admin for this useful post.
sinc747 on 6/26/2016(UTC)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.