logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
sphbecker  
#1 Posted : Tuesday, May 7, 2024 5:57:18 AM(UTC)
sphbecker

Rank: Newbie

Groups: Registered
Joined: 12/27/2023(UTC)
Posts: 5
United States
Location: Texas

Thanks: 1 times
Bringing NDI sources into vMix v27 has a MASSIVE quality drop that I didn't see with v26. Example attached. As you can see, it looks like the 1080p signal was lowered to 480p and scaled back to 1080p, in the sloppiest way possible.

I can confirm the issue is not with NDI itself. I can open Studio Monitor on the same computer running vMix, and the image is crystal clear there, but looks terrible in vMix. I even tried capturing the source from the same machine (so no network involved) and there is no change. I have tried using vMix Desktop Capture, and the Screen Capture tool from NDI 5.6 and 6.0, same results from all.

So far, the only workaround I have found is to have the source send in 4K, so that when vMix clobbers the quality, it still looks halfway decent at 1080p.

vMix Capture 03 May 2024 19-22-42.png (929kb) downloaded 10 time(s).
doggy  
#2 Posted : Tuesday, May 7, 2024 6:13:38 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 5,095
Belgium
Location: Belgium

Thanks: 284 times
Was thanked: 922 time(s) in 761 post(s)
Originally Posted by: sphbecker Go to Quoted Post
Bringing NDI sources into vMix v27 has a MASSIVE quality drop that I didn't see with v26. Example attached. As you can see, it looks like the 1080p signal was lowered to 480p and scaled back to 1080p, in the sloppiest way possible.

I can confirm the issue is not with NDI itself. I can open Studio Monitor on the same computer running vMix, and the image is crystal clear there, but looks terrible in vMix. I even tried capturing the source from the same machine (so no network involved) and there is no change. I have tried using vMix Desktop Capture, and the Screen Capture tool from NDI 5.6 and 6.0, same results from all.

So far, the only workaround I have found is to have the source send in 4K, so that when vMix clobbers the quality, it still looks halfway decent at 1080p.



Cant say i noticed any difference in quality (26<>27) myself.
Just did 5 full days (10+ hrs/day) of production with NDI camera's and graphics inputs received as NDI (WPF->SDK->NDI) in the usual good quality (1080p all full NDI).
sphbecker  
#3 Posted : Wednesday, May 8, 2024 6:36:32 AM(UTC)
sphbecker

Rank: Newbie

Groups: Registered
Joined: 12/27/2023(UTC)
Posts: 5
United States
Location: Texas

Thanks: 1 times
I found a workaround!! I was running vMix on a laptop with hybrid graphics (both Intel and NVidia GPUs). I used the NVidia control panel to manually assign vMix to always use the NVidia GPU. Now I see the NDI image nice and clear in vMix.

That is an easy workaround, and a best practice anyway. I wish vMix did more to suggest making that change when you first start it, instead of hoping the user runs across the help article suggesting the change.

I know this isn't an issue on laptops with Intel only, so my guess is that the NDI libraries included with vMix are automatically activating the GPU, but with vMix running on the Intel side, something is getting messed up with the image as it is passed from one GPU to the other.

EDIT: I did a clean install of Windows when I moved to vMix v27, so I "think" my old installation may have had hybrid graphics disabled system-wide, so not sure this really was a v27 issue at all.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.