logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
biski9  
#1 Posted : Thursday, August 3, 2023 12:41:40 AM(UTC)
biski9

Rank: Newbie

Groups: Registered
Joined: 8/3/2023(UTC)
Posts: 1
Luxembourg

Hi, I have two fullscreens being send out to 2 displays groups. The main monitor where I have my vmix opened has a fullscreen (with customized resolution) which I would like to behave as being on top. I have selected it in display settings ofcourse.

My external monitor has the fullscreen always on top like it is supposed to be. On the main monitor (selected in windows as such) the main vmix window is overlapping the fullscreen window. Why is my main monitor not behaving the same as my extended displays?

Thank you
doggy  
#2 Posted : Thursday, August 3, 2023 1:38:03 AM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 5,111
Belgium
Location: Belgium

Thanks: 285 times
Was thanked: 926 time(s) in 765 post(s)
Originally Posted by: biski9 Go to Quoted Post
Hi, I have two fullscreens being send out to 2 displays groups. The main monitor where I have my vmix opened has a fullscreen (with customized resolution) which I would like to behave as being on top. I have selected it in display settings ofcourse.

My external monitor has the fullscreen always on top like it is supposed to be. On the main monitor (selected in windows as such) the main vmix window is overlapping the fullscreen window. Why is my main monitor not behaving the same as my extended displays?

Thank you


ANd where will your vMix window go to them?
paco3346  
#3 Posted : Thursday, August 3, 2023 2:51:26 AM(UTC)
paco3346

Rank: Advanced Member

Groups: Registered
Joined: 9/10/2015(UTC)
Posts: 131
United States

Thanks: 2 times
Was thanked: 34 time(s) in 31 post(s)
I think this was intentional because it used to be that you could accidentally put your fullscreen over your main window and then have no way to disable it unless you already had a shortcut / API access.

As a hacky workaround- have your primary screen's fullscreen use a custom output area (in vMix fullscreen settings) and then drag your main window to take up the few remaining pixels. This only works if you can slice/scale on your display so that you don't see the bottom few pixels.
WaltG12  
#4 Posted : Thursday, August 3, 2023 3:34:17 AM(UTC)
WaltG12

Rank: Advanced Member

Groups: Registered
Joined: 7/4/2021(UTC)
Posts: 201
United States

Thanks: 6 times
Was thanked: 24 time(s) in 24 post(s)
Originally Posted by: doggy Go to Quoted Post
ANd where will your vMix window go to them?


Presumably on the bottom.

In fact, that's how it used to work, and was the reason Esc as "FullscreenOff" became my first shortcut. The first time, I had to Ctrl + Alt + Delete to open Task Manager to get out of it.

At some point, they modified that behavior and added the "On Top" setting, which I believe used to work to achieve the desired results, but testing it now, doesn't.

You can minimize and maximize the main vMix window, but that's kind of a hassle, even with something like a Stream Deck, and defeats the entire purpose of the "On Top" setting.

I'm wondering if it's a bug that they just haven't noticed or been able to fix yet, since, again, it defeats the entire purpose of the "On Top" setting.
dmwkr  
#5 Posted : Thursday, August 3, 2023 4:31:54 AM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 523

Thanks: 62 times
Was thanked: 119 time(s) in 108 post(s)
From the help files:

Quote:
On Top: Fullscreen window will always be on top of other windows if displayed on a different display. If displayed on the same display as vMix this option will have no effect.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.