logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
samirbridi  
#1 Posted : Monday, May 1, 2023 5:57:45 AM(UTC)
samirbridi

Rank: Advanced Member

Groups: Registered
Joined: 10/27/2020(UTC)
Posts: 31
Brazil
Location: Porto Alegre

Thanks: 7 times
Was thanked: 2 time(s) in 2 post(s)
I have a very light project, which has the following elements:

- 1 GT input (scoreboard)
- 3 MP4 inputs
- 1 input PNG
- Instant Replay
- 1 VLC input (rtmp signal)

With this information, vMix shows 100% GPU usage, which I've done in many other projects with much more videos, GT and also information, and the maximum I could do was reach 80% usage.
In the task manager it shows the graphics card usage at 22% (dedicated) and 40% (integrated).

My notebook has an RTX 3060 6GB, driver updated to date (04/30/23).

But anyone facing any bug in this regard?
mavik  
#2 Posted : Wednesday, May 3, 2023 4:06:52 AM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 1,119
Man
Location: Germany

Thanks: 3 times
Was thanked: 164 time(s) in 146 post(s)
This sounds a bit odd.
Things you can check:
https://www.vmix.com/kno...n-nvidia-optimus-laptops
Encoder MP4 in higher bitrate (less compression) or I-frame only
samirbridi  
#3 Posted : Friday, May 12, 2023 11:51:02 AM(UTC)
samirbridi

Rank: Advanced Member

Groups: Registered
Joined: 10/27/2020(UTC)
Posts: 31
Brazil
Location: Porto Alegre

Thanks: 7 times
Was thanked: 2 time(s) in 2 post(s)
Originally Posted by: mavik Go to Quoted Post
This sounds a bit odd.
Things you can check:
https://www.vmix.com/kno...n-nvidia-optimus-laptops
Encoder MP4 in higher bitrate (less compression) or I-frame only


Configuration is correct, and all necessary adjustments made. The project is the same one I used in previous versions, and the maximum peak it could hit was 70%... and now it's at 100% straight.

I believe they have made some change that is conflicting with the GPU driver, or even this recent NVIDIA driver may be causing an error, as it had this time.

I already found out that I'm not the only one like this, there are more people on facebook complaining and acquaintances too, all with the same detail as me about consumption rising absurdly
admin  
#4 Posted : Friday, May 12, 2023 11:55:52 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 5,122
Man
Location: Gold Coast, Australia

Was thanked: 4131 time(s) in 1485 post(s)
The indicator you mention use not GPU usage, it is GPU cache memory usage:

https://www.vmix.com/kno...n-in-the-vmix-status-bar

Replay and multiple videos may be enough to exceed this especially if they are higher resolution.
samirbridi  
#5 Posted : Friday, May 12, 2023 1:31:05 PM(UTC)
samirbridi

Rank: Advanced Member

Groups: Registered
Joined: 10/27/2020(UTC)
Posts: 31
Brazil
Location: Porto Alegre

Thanks: 7 times
Was thanked: 2 time(s) in 2 post(s)
Originally Posted by: admin Go to Quoted Post
The indicator you mention use not GPU usage, it is GPU cache memory usage:

https://www.vmix.com/kno...n-in-the-vmix-status-bar

Replay and multiple videos may be enough to exceed this especially if they are higher resolution.


Yes!

In this case, when the project was previously used, it had a maximum consumption of 80% (so to speak)... but now it is showing 100%. So far, I haven't noticed any problems working on it, but it scares me that it's showing that percentage, that is, it would be working at a maximum peak, which it didn't before. That detail I mention.

The project itself was all well optimized to work without problems, and that's right, but I was scared when in these last two versions of the program, it showed 100% usage.

I always try to work with a list of videos, GTs... just to load as little as possible into the project.

My board has the Resizable BAR activated, where according to the information, within the vMix we have to leave the "High Input Performance Mode" option deactivated, even with more than 6GB, correct? It was explained in a video to leave it like this, precisely so that the Resizable BAR works correctly.

I'm even in contact with my notebook vendor, to see if there's any Resizable BAR update to do, but I haven't heard back about it.
samirbridi  
#6 Posted : Friday, May 12, 2023 1:32:20 PM(UTC)
samirbridi

Rank: Advanced Member

Groups: Registered
Joined: 10/27/2020(UTC)
Posts: 31
Brazil
Location: Porto Alegre

Thanks: 7 times
Was thanked: 2 time(s) in 2 post(s)
One thing I was forgetting...

My streams are always in 1080p, I haven't done anything in 2k or 4k yet.

Resolution like 2k and up, I believe we need to be much more prepared, it will be a lot more processing.
RichDanby  
#7 Posted : Friday, May 12, 2023 7:50:29 PM(UTC)
RichDanby

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 127
United Kingdom

Thanks: 14 times
Was thanked: 25 time(s) in 23 post(s)
As I understand it, 100% GPU (cache mem) usage isn't a problem if you have Resizeable BAR enabled.

See the last section of this knowledge base article
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.