logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
geekazine  
#1 Posted : Sunday, February 12, 2023 7:38:43 AM(UTC)
geekazine

Rank: Newbie

Groups: Registered
Joined: 12/30/2020(UTC)
Posts: 4
United States
Location: Madison, WI

Thanks: 3 times
I run my show remote - vMix is on another computer in another room. Everything goes through a Stream Deck and Companion to switch. Graphics as well, which I created custom GT interfaces that connect to Google Sheets for the data.

I use DataSource AutoNextOn to advance the row on the Google sheet. In Companion it's "vmix:DataSource - Next Row"

This is what's not working.

vmix-next.jpg (31kb) downloaded 0 time(s).

I have tried "Google Sheets,Sheet1", "Google Sheets,Sheet1,1", and "Google Sheets,Show" (The name of the sheet), and my next/previous buttons do not work.

I just installed 26, so I downgraded to 25, but the problem did not go away. I also just updated Companion (after) to 2.4.2 to see if that was an issue, but the Next Row function still will not work.

At a loss, here. Any thoughts?

MThomas56  
#2 Posted : Sunday, February 12, 2023 9:01:42 AM(UTC)
MThomas56

Rank: Member

Groups: Registered
Joined: 12/11/2018(UTC)
Posts: 10
Man
United States

Was thanked: 3 time(s) in 2 post(s)
We also use Companion with our stream decks and vMix and actually added this same function last week for our new Google Sheet/Excel Data Sources.
The setup below works great for us, and allows you to move up and down in your data source rows.

In Companion (2.4.1 or higher)
Press action

vmix: DataSource - Prev Row
Name,Table: DataSourceName,Sheet1

vmix: DataSource - Next Row
Name,Table: DataSourceName,Sheet1

DataSourcename is your actual DataSource name in vMix
**I have never used spaces in a DataSource name, use a (-) or (_) if needed

That might be causing the issue. Spaces should generally be avoided when dealing with Data/Databases.

We also use another similar function in Companion to Select a Specific Data Source (Sheet/Row)

vmix: DataSource - Select Row
Name,Table: DataSourceName,Sheet1,0

Hope this helps you out.

Matt Thomas
thanks 1 user thanked MThomas56 for this useful post.
geekazine on 2/13/2023(UTC)
geekazine  
#3 Posted : Sunday, February 12, 2023 9:10:39 AM(UTC)
geekazine

Rank: Newbie

Groups: Registered
Joined: 12/30/2020(UTC)
Posts: 4
United States
Location: Madison, WI

Thanks: 3 times
Thanks for the info. When you set it up, the default is "Google Sheets". Nonetheless, I changed the name to "Google-Sheets" and made the adjustments on Companion, but still am not getting any movement.

Are you using Google Sheets, or one of the other presets?
IceStream  
#4 Posted : Sunday, February 12, 2023 9:22:54 PM(UTC)
IceStream

Rank: Advanced Member

Groups: Registered
Joined: 3/7/2012(UTC)
Posts: 2,605
Man
Location: Canada

Thanks: 33 times
Was thanked: 501 time(s) in 470 post(s)
@ geekazine

Try removing the space after the comma:
Google Sheets,Sheet1


Ice
thanks 1 user thanked IceStream for this useful post.
geekazine on 2/13/2023(UTC)
dmwkr  
#5 Posted : Sunday, February 12, 2023 9:23:11 PM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 521

Thanks: 62 times
Was thanked: 119 time(s) in 108 post(s)
On the screenshot there is a space after the comma. The name of the sheet has to follow directly after the comma.
thanks 1 user thanked dmwkr for this useful post.
geekazine on 2/13/2023(UTC)
geekazine  
#6 Posted : Monday, February 13, 2023 2:49:21 AM(UTC)
geekazine

Rank: Newbie

Groups: Registered
Joined: 12/30/2020(UTC)
Posts: 4
United States
Location: Madison, WI

Thanks: 3 times
So I am not sure what happened, but this morning it started working. I did change it to "Google-Sheets", and the space you guys saw was on my SD that was on the computer with vMix. I did remove it.

Another thing that happened was "Sheet1" did not work anymore (even though it was "Google Sheets,Sheet1" since I created it). It's now "Google-Sheets,Show"(the actual sheet name).

So a combination of things - and I'm guessing the upgrade to 26 - were what caused this to stop working. It's working now.

Thanks to everyone that helped out.
MThomas56  
#7 Posted : Tuesday, February 14, 2023 1:38:18 AM(UTC)
MThomas56

Rank: Member

Groups: Registered
Joined: 12/11/2018(UTC)
Posts: 10
Man
United States

Was thanked: 3 time(s) in 2 post(s)
Originally Posted by: geekazine Go to Quoted Post
So I am not sure what happened, but this morning it started working. I did change it to "Google-Sheets", and the space you guys saw was on my SD that was on the computer with vMix. I did remove it.

Another thing that happened was "Sheet1" did not work anymore (even though it was "Google Sheets,Sheet1" since I created it). It's now "Google-Sheets,Show"(the actual sheet name).

So a combination of things - and I'm guessing the upgrade to 26 - were what caused this to stop working. It's working now.

Thanks to everyone that helped out.


Glad to hear you got it working. always double check Sheet names.
Matt Thomas

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.