Live Production Software Forums

Welcome Guest! To enable all features please Login or Register.



Go to last post Go to first unread
#1 Posted : Thursday, December 22, 2022 9:57:39 AM(UTC)

Rank: Newbie

Groups: Registered
Joined: 12/17/2022(UTC)
Posts: 3
United States
Location: CA

Thanks: 1 times
Having issue with vMix Local Desktop Capture not functioning properly.

When clicking on Display 1 to capture the display, on vMix it captures half of the display and then the entire smaller display and sometimes there is a black space with white specs in addition...

I currently have 3 Displays attached to Alienware PC via displayport for all 3 monitors.They are connected to NVIDIA GeForce RTX 3090 which has 3 displayports and 1 hdmi ports.

2 of the monitors (DELL S2721QS 27" DISPLAY) are the same size 3840x2160 and then the third one is smaller 1600x900 (DELL E2020H 20" DISPLAY)

[Sidenote: previously I had a different display connected via HDMI and was thinking the difference between HDMI and displayport might have been the culprit, but have found out I still have this problem.]

12th Gen Intel(R) Core(TM) i9-12900KF

I've tried uninstalling and reinstalling vMix.
I've tried changing the resolution for the smaller display.

This makes one of the larger displays useless for our production.
Someone please help!

Screenshot 2022-12-21 151308.png (283kb) downloaded 4 time(s). Screenshot 2022-12-21 151247.png (936kb) downloaded 4 time(s).
#2 Posted : Thursday, December 29, 2022 1:56:44 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 12/17/2022(UTC)
Posts: 3
United States
Location: CA

Thanks: 1 times
Yeah so apparently how to kinda? fix this is to:

1. Close vMix.
2. Open up Windows Display Settings
3. Change the Display resolution for all 3 monitors to be EXACTLY the same...(in my example I set them all to the smaller displays max resolution of 1600x900)
4. Open vMix (your custom preset or default)
5. Check Display Capture. Should display the entire display for each display...
6. Go back to Windows Display settings and change everything back to your max resolutions while vMix is open.
7. Check vMix Display capture, it should be capturing the full display.

SO was happy that worked...but of course it worked till I powered the PC off and then a couple days later opened vmix up again and had the same issue.
So looks like you'll have to do this EVERY TIME you open vMix up, in order to capture the full display with no issues.
Other thing is that after you do Step 6, vMix interface looks tiny/hard to see.

This is frustrating...if anyone else has a better solution, let us know!!! I didn't get 4k displays to NOT use them at 4k lol
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.