logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
studiomamytwink  
#1 Posted : Thursday, November 6, 2014 12:13:13 PM(UTC)
studiomamytwink

Rank: Newbie

Groups: Registered
Joined: 11/6/2014(UTC)
Posts: 7
Location: Metz

Hi Martin,

I'm currently facing an issue with vMix 14.0.0.97 x64.

When I play a h264 video in vMix, I issue some lags, which increases when I add an uncompressed overlay with alpha channel. When I hit local recording, lag increases even more. Note : when I don't stream and record, but just read a video in vMix, it already lags more than VLC.

I do not issue any lag with the same configuration with my decklinks mini recorders. Only with playback videos.
I'm reading the video file from a SATA Hardrive and writing the output on an SSD Drive.

I tried ffdshow Video Decoder, Lav video decoder, and the installed Microsoft DTV-DVD and none of them seem to resolve the problem.
I'm using EVR video render, 0 hardware acceleration.

When i'm streaming 1080p25 3mbps, and recording h264 1080p25 12mbps, my CPU usage vary between 30 and 60%.

Here's what I issue :
http://www.twitch.tv/francoiscalvier/b/585577977

Here is my configuration :

Windows 7 64bits
Intel Core i7-4790K 4.00Ghz
NVidia GeForce GTX 760
32Go RAM
SSD 256Go Drive with vMix installed
1To Drive from which I read the video files

I still am on vMix Trial version, does it affect something in any way ?
Do you have any idea how to solve this problem ?

Thanks
admin  
#2 Posted : Thursday, November 6, 2014 12:26:31 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 5,170
Man
Location: Gold Coast, Australia

Was thanked: 4195 time(s) in 1501 post(s)
What happens when you try VMR in Settings -> Performance?

Could you upload the video to https://fileobject.com/ so I can run some tests?

Thanks,

Martin
vMix
studiomamytwink  
#3 Posted : Thursday, November 6, 2014 3:27:35 PM(UTC)
studiomamytwink

Rank: Newbie

Groups: Registered
Joined: 11/6/2014(UTC)
Posts: 7
Location: Metz

VMR Video render was set by default and it was worse. Switching to EVR Video Render reduced about 70% of the lagging.

Here is the original file (fileObject didn't work) :
https://www.wetransfer.c...5e920141105185347/e77707

Thanks,

François
studiomamytwink  
#4 Posted : Friday, November 7, 2014 8:46:00 AM(UTC)
studiomamytwink

Rank: Newbie

Groups: Registered
Joined: 11/6/2014(UTC)
Posts: 7
Location: Metz

Here's new information from a new test :

While streaming and recording 1080p25 in a PAL 25fps project, my CPU Usage vary between 30 and 60%, my GPU usage never goes up to 15% usage, but my render time vary between 70 and 90ms and my EX fps drops down from 25-26 to 20-23.

70ms per frame means it render 1 second video in 1,75 seconds right ?
Is there any way to indicate vMix to use more ressources from my computer ? In order to render frames under 40ms (25fps) ?

Thanks
studiomamytwink  
#5 Posted : Friday, November 7, 2014 9:11:52 AM(UTC)
studiomamytwink

Rank: Newbie

Groups: Registered
Joined: 11/6/2014(UTC)
Posts: 7
Location: Metz

I just noticed :

I tried to disactivate the fullscreen button (which send Multiview to my second monitor and Output to my third monitor), and render time dropped down to 17-24ms instead of 70-90ms when it's on.
admin  
#6 Posted : Friday, November 7, 2014 9:40:31 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 5,170
Man
Location: Gold Coast, Australia

Was thanked: 4195 time(s) in 1501 post(s)
Hi,

Can you confirm the following:

1. In vMix Settings what is the frame rate set to?
2. Are all three screens connected to the 760 graphics card or are some connected to a video port on the motherboard?
3. In vMix Settings under performance make sure Synchronize Output with Refresh Rate is Unticked.

Regards,

Martin
vMix
studiomamytwink  
#7 Posted : Friday, November 7, 2014 10:14:26 AM(UTC)
studiomamytwink

Rank: Newbie

Groups: Registered
Joined: 11/6/2014(UTC)
Posts: 7
Location: Metz

Hi Martin,

1. I tested it with 1080p25, 1080i29,97, 1080p50, 1080i50 : video render always increases to 70-90ms when my 3 monitors are on. (When I only active 2 monitors (my main with vMix + 1 output) or only 1, problem seem to be fixed)
2. All on 760 : 2 DVI Output, 1 HDMI
3. Always unticked

Thanks,
François
admin  
#8 Posted : Friday, November 7, 2014 10:53:16 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 5,170
Man
Location: Gold Coast, Australia

Was thanked: 4195 time(s) in 1501 post(s)
Thanks,

Check the refresh rate on each of the monitors in the NVIDIA Control Panel to make sure they all match.
They should all be set to 60hz if possible, even if vMix is set to 25

Regards,

Martin
vMix
studiomamytwink  
#9 Posted : Friday, November 7, 2014 11:28:30 AM(UTC)
studiomamytwink

Rank: Newbie

Groups: Registered
Joined: 11/6/2014(UTC)
Posts: 7
Location: Metz

Yes, all 3 of them are set to 60Hz.

Thanks
studiomamytwink  
#10 Posted : Thursday, November 13, 2014 9:18:54 PM(UTC)
studiomamytwink

Rank: Newbie

Groups: Registered
Joined: 11/6/2014(UTC)
Posts: 7
Location: Metz

Hi Martin,

I have good news,
All our problems were due to the fact that we disactivated "Aero" mode in Windows... We tried to reactivate it and...everything was fine...

We managed to stream our first show live this evening and it went well (we reached over 3.000 simultaneous viewers :) )

So thank you again for your time, vMix is definitly the perfect solution.


Regards,
François
http://www.mamytwink.com
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.