logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
sebrame  
#1 Posted : Thursday, May 12, 2022 1:28:14 AM(UTC)
sebrame

Rank: Advanced Member

Groups: Registered
Joined: 12/20/2017(UTC)
Posts: 30
Man
Location: Raleigh, NC

Thanks: 7 times
During vMix call, I hear my own mic in my headphones, even though my headphones are muted in vMix. At first, I thought it was just what was being picked up by my caller's speakers when I talked(they are not using headphones), but today I had to reboot my router mid-call, and while disconnected from the caller, I was still hearing my mic in my headphones. There's also a noticeable delay in my voice, which is hugely disconcerting.
zenvideo  
#2 Posted : Thursday, May 12, 2022 5:57:46 AM(UTC)
zenvideo

Rank: Advanced Member

Groups: Registered
Joined: 5/13/2014(UTC)
Posts: 486
Man
United Kingdom
Location: Manchester, UK

Thanks: 2 times
Was thanked: 176 time(s) in 124 post(s)
Assuming your microphone is supposed to faded up on the Master Output, I suggest you take a look at vMix's Audio Outputs in Settings. Make sure that whatever physical audio device you're connecting your headphones to is not the same one receiving the Master Output (eg Default Windows Playback Device).

In general, if your PC only has one audio output, I'd suggest you set the Master simply to Enabled (ie. not to a physical device) and the Headphones to Default Windows Playback Device. Then you can set up a headphone mix which doesn't include your own microphone, even though it is going out (to the stream/recording) via the Master Output.

sebrame  
#3 Posted : Thursday, May 12, 2022 7:53:56 AM(UTC)
sebrame

Rank: Advanced Member

Groups: Registered
Joined: 12/20/2017(UTC)
Posts: 30
Man
Location: Raleigh, NC

Thanks: 7 times
My mic was hot on Master. Hate I missed that...so simple.
sebrame  
#4 Posted : Friday, May 13, 2022 3:41:18 AM(UTC)
sebrame

Rank: Advanced Member

Groups: Registered
Joined: 12/20/2017(UTC)
Posts: 30
Man
Location: Raleigh, NC

Thanks: 7 times
Well, that wasn't the answer I'm afraid. Disabling Master on my mic, of course, kills my audio output totally, which would have been obvious if I hadn't gotten my hopes up too high.

All I've ever seen regarding vMix Call claims that it handles all of this for you. My setup is as simple as it gets.
dmwkr  
#5 Posted : Friday, May 13, 2022 7:24:22 PM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 397

Thanks: 51 times
Was thanked: 89 time(s) in 79 post(s)
How is your mic connected to vMix? What are your settings on the Audio Outputs? Have you followed zenvideo's advice on setting Master Output to "Enabled"?
sebrame  
#6 Posted : Friday, May 13, 2022 9:40:00 PM(UTC)
sebrame

Rank: Advanced Member

Groups: Registered
Joined: 12/20/2017(UTC)
Posts: 30
Man
Location: Raleigh, NC

Thanks: 7 times
Well, I thought I had followed zenvideo's advice, but realized that I had misunderstood "setting Master Output to "Enabled". I've found the correct setting and now it's definitely sorted.

Thanks so much!
zenvideo  
#7 Posted : Monday, May 16, 2022 11:59:42 PM(UTC)
zenvideo

Rank: Advanced Member

Groups: Registered
Joined: 5/13/2014(UTC)
Posts: 486
Man
United Kingdom
Location: Manchester, UK

Thanks: 2 times
Was thanked: 176 time(s) in 124 post(s)
Originally Posted by: sebrame Go to Quoted Post
Well, I thought I had followed zenvideo's advice, but realized that I had misunderstood "setting Master Output to "Enabled". I've found the correct setting and now it's definitely sorted.

Thanks so much!

I'm very glad to hear it, and happy to have helped :)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.