logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
mr_tbot  
#1 Posted : Wednesday, February 23, 2022 7:17:18 AM(UTC)
mr_tbot

Rank: Newbie

Groups: Registered
Joined: 2/23/2022(UTC)
Posts: 6
United States
Location: Las Vegas

Thanks: 2 times
Greetings! My name is Talbot - known in the community as "TBOT" - I'm new to these forums but I am not new to vMix. Additionally, I'm the head live stream engineer for a streaming service... and we have a large number of vMix licenses in use across the country!

I am running into a perplexing issue at a number of our venues as of late - and I'm trying to figure out if this is a vMix issue or an issue with Amazon IVS - which hosts our streaming platform's back end.

We use custom built rack systems which are pretty much identical in all of our venues across the country. We use the same stream settings (1080p - 30fps - 6000kbps, Keyframe interval of 2, CBR, Keyframe aligned, as well as some minor adjustments as IVS requests for settings.)

I am attaching our standard vMix stream settings (IVS standard) as well as what is received by IVS in Cloudwatch.

Stream Settings vMix.PNG (15kb) downloaded 3 time(s).
Stream Settings - Advanced vMix.PNG (17kb) downloaded 1 time(s).
AWS issue.png (43kb) downloaded 0 time(s).

Please notice that the keyframe interval in IVS is received at 4 instead of 2 - and that the bitrate is halved - in addition - the AVC profile seems to be received incorrectly

This only affects certain venues/streams, again - all at 30FPS for their master frame rate (thought we do have some at 60fps in special use cases). Other venues - which have identical set ups and show files - all report correctly with a keyframe of 2 - and a locked CBR bitrate of 6000. So whatever it is, it's throwing us off because it's not a problem we can reproduce from one venue to another. It seems to be completely random.

We are working with IVS to explore the issue being on their end, however I feel it only prudent to explore it possibly being an issue within vMix - and I wanted to inquire if anyone has any thoughts on why this may be happening - or if they are experiencing it themselves.

The problem is - we are running into issues with low latency streaming as it seems to deeply depend on the keyframe being interpreted properly. This bug has been a show stopper a few times, especially when utilizing ultra low latency systems as when the keyframe is not received correctly, we experience skips, hiccups, repeating... and generally show stopping issues on the receiving end. We've been circumventing the issue by using higher latency when this happens as it seems to not be so susceptible to the issue but I don't want this to continue to be our Band-Aid.

Thanks in advance for any thoughts or solutions you may have! Cheers!
MartLeib  
#2 Posted : Wednesday, February 23, 2022 5:21:28 PM(UTC)
MartLeib

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2017(UTC)
Posts: 190
Estonia

Thanks: 1 times
Was thanked: 51 time(s) in 42 post(s)
Uncheck "Use Hardware Encoder" in the streaming settings dialog and test again.
mr_tbot  
#3 Posted : Thursday, February 24, 2022 2:51:08 AM(UTC)
mr_tbot

Rank: Newbie

Groups: Registered
Joined: 2/23/2022(UTC)
Posts: 6
United States
Location: Las Vegas

Thanks: 2 times
Originally Posted by: MartLeib Go to Quoted Post
Uncheck "Use Hardware Encoder" in the streaming settings dialog and test again.



Hmm, can you give me some insight as to why this may help? All of these systems are 3080 and 3090 Nvidia GPUs... and like I've said we use these same settings across the board.... Including using the hardware encoder... I'll certainly try it next time this pops up... but I'd like to understand the logic.

Thanks!
admin  
#4 Posted : Thursday, February 24, 2022 3:36:42 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,897
Man
Location: Gold Coast, Australia

Was thanked: 3761 time(s) in 1386 post(s)
This can be caused by a frame rate mismatch.
For example setting the frame rate in Settings -> External Output to 59.94p when the master frame rate is 29.97p and vice versa, so double check they both match and restart.
thanks 2 users thanked admin for this useful post.
mr_tbot on 2/25/2022(UTC), rfaria on 8/20/2022(UTC)
mr_tbot  
#5 Posted : Thursday, February 24, 2022 3:52:49 PM(UTC)
mr_tbot

Rank: Newbie

Groups: Registered
Joined: 2/23/2022(UTC)
Posts: 6
United States
Location: Las Vegas

Thanks: 2 times
Originally Posted by: admin Go to Quoted Post
This can be caused by a frame rate mismatch.
For example setting the frame rate in Settings -> External Output to 59.94p when the master frame rate is 29.97p and vice versa, so double check they both match and restart.



Thanks for this! This confirms my suspicion.

Further testing on this today actually - seems to point to this being the possible culprit - however - I am unable to replicate it on purpose. It only seems to happen randomly - whether the settings are mismatched or not - however after matching everything back up between stream settings and external outputs and restarting my stream seems to fix it in 2 instances today.

What's annoying is I can't get it to break on purpose to confirm - I try to set the external output settings incorrectly and it doesn't break it... *facepalm*

Is there any official documentation on this that I've clearly missed? ...or is this one of those things I had to come across organically?
MartLeib  
#6 Posted : Thursday, February 24, 2022 9:01:21 PM(UTC)
MartLeib

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2017(UTC)
Posts: 190
Estonia

Thanks: 1 times
Was thanked: 51 time(s) in 42 post(s)
Originally Posted by: mr_tbot Go to Quoted Post
Originally Posted by: MartLeib Go to Quoted Post
Uncheck "Use Hardware Encoder" in the streaming settings dialog and test again.



Hmm, can you give me some insight as to why this may help? All of these systems are 3080 and 3090 Nvidia GPUs... and like I've said we use these same settings across the board.... Including using the hardware encoder... I'll certainly try it next time this pops up... but I'd like to understand the logic.

Thanks!


This bug is quite unique since I have experienced it multiple times, but same as you never had any real way to reproduce it after the fact. Most of the time I was able to get constant bitrate and solid keyframe frequency when using CPU to encode video not GPU. I have also gone so far, that I have used OBS for streaming instead of vMix when this issue has come up in the field.

Also what has helped is to check all checkboxes in the External Output settings - "vMix Video / Streaming" "Use Streaming Settings" "External Renderer" "Use Display Settings" and also match framerates in master settings and external settings, even, if you are not using external itself.

One time entire system reboot worked as well, but it has worked only once.
thanks 2 users thanked MartLeib for this useful post.
mr_tbot on 2/25/2022(UTC), rfaria on 8/20/2022(UTC)
mr_tbot  
#7 Posted : Monday, February 28, 2022 2:47:16 PM(UTC)
mr_tbot

Rank: Newbie

Groups: Registered
Joined: 2/23/2022(UTC)
Posts: 6
United States
Location: Las Vegas

Thanks: 2 times
I finally managed to recreate and fix this bug.

I wasn't just needing to match up framerates - I also needed to change the stream server by a single character and then back to get the settings to take hold. Without doing that, the problem persisted.

Here is a Gdrive folder containing 3 videos on this bug - how I finally recreated it, and solved it. Please watch in numerical order.

https://drive.google.com...h_H91_YZZioj?usp=sharing

@admin - this seems like something vMix support may want their eyes on. It's clearly a bug.

Thanks for everyone's help in narrowing down this issue - really top notch!

admin  
#8 Posted : Monday, February 28, 2022 4:27:38 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,897
Man
Location: Gold Coast, Australia

Was thanked: 3761 time(s) in 1386 post(s)
Hi,

Thanks for the videos.
This does not appear to be a bug unfortunately, as Use streaming settings was unticked, therefore the frame rate was manually set incorrectly as a result.
Note that a restart of vMix is sometimes required to fully apply any settings changes here, which is why it did not immediately change, and a change of stream key worked to manually reboot it.

If you see this issue even with the option ticked and vMix restarted, please send a support report via our web site:

https://www.vmix.com/contact-us.aspx

Regards,

Martin

mr_tbot  
#9 Posted : Monday, February 28, 2022 5:11:09 PM(UTC)
mr_tbot

Rank: Newbie

Groups: Registered
Joined: 2/23/2022(UTC)
Posts: 6
United States
Location: Las Vegas

Thanks: 2 times
Thanks for such a prompt reply!

Interesting as it doesn't request a restart after changing these external framerate settings - and that makes sense as the stream settings likely recalls the commands required to set these things correctly... though maybe not a bug per say - it's interesting that it doesn't warn you or request a restart.

I'll keep in mind that restarting after any setting change is best practice in general - as up until this point I have only restarted the software when I am requested... and changing the external framerate doesn't request a restart.

It would be nice if it did however as this is anything but obvious... and many of us have been chasing our tail on it for a minute.

Additionally, we did check "use stream settings" as this is default in all of our venues. Typically we don't even use the external feature except in a few select cases - and in those cases I've received warnings about mismatched framerates...

I know this isn't the feature request section but any chance of getting this flagged? Maybe a pop up that notifies the user that if the frame rate on external is not matched to the master frame rate that it can cause keyframe and bitrate issues such as this? Or even easier? Request a restart when the external settings are changed? That would solve it too.

Thanks a ton once again!

Kindest regards!

p.s. the next time this issue crops up i'll be sure to follow these restart steps and see if that helps. In my experience it didn't - but I want to confirm that before submitting a bug report at this point. Cheers!
admin  
#10 Posted : Monday, February 28, 2022 5:18:05 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,897
Man
Location: Gold Coast, Australia

Was thanked: 3761 time(s) in 1386 post(s)
Hi,

As long as vMix is up to date and you have Use streaming settings checked, it will always double check and correct any mismatched frame rates behind the scenes.
This option is always checked by default, but it looks like you have some old presets where this was manually unchecked, so to prevent this in the future go through all of these
check it again then save the preset.

If you do happen to find a situation where it is checked, and the issue still occurs please email us and send a report.
(Making sure the latest vMix is installed first).


Regards,

Martin
vMix
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.