logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
s220284  
#1 Posted : Wednesday, March 31, 2021 10:32:48 PM(UTC)
s220284

Rank: Newbie

Groups: Registered
Joined: 12/6/2020(UTC)
Posts: 6
United States
Location: New York

Thanks: 1 times
I'm toggling a lower third (built in GT Title Designer) that animates in and out. This is an easy button in vMix Panel Builder "OverlayInput1" Press the button. Graphic animates in. Press it again. Graphic animates out.

The issue:

I have a trigger set "OnOverlayIn" that plays a .mp3 sfx on an input. "OnOverlayIn" "Play" "input xx" -- this is perfect!

But...

When I tried, "OnOverlayOut" it waits until the animation is completely finished before it plays the outro sfx.

So, "OnOverlayOut" "Play" "input yy" instead of the audio and animated title being in sync, the graphic animates out, THEN, the audio plays.

I would truly appreciate any advice on how to automate this. Thanks to all.
doggy  
#2 Posted : Wednesday, March 31, 2021 10:37:34 PM(UTC)
doggy

Rank: Advanced Member

Groups: Registered
Joined: 12/27/2012(UTC)
Posts: 3,032
Belgium
Location: Belgium

Thanks: 175 times
Was thanked: 546 time(s) in 446 post(s)
As you noticed the trigger acts on finishing the command first

just add a play to the shortcut instead (one shortcut doing multiple things is possible)
s220284  
#3 Posted : Wednesday, March 31, 2021 11:02:25 PM(UTC)
s220284

Rank: Newbie

Groups: Registered
Joined: 12/6/2020(UTC)
Posts: 6
United States
Location: New York

Thanks: 1 times
Thanks for the quick response. Making a shortcut doesn't solve the problem -- unless I truly don't understand shortcuts. I'm trying to have one button toggle the in/out of the lower third. I want to add audio to the toggle press that initiates the graphic out. I need it to play on the same button that is now in a "toggled" state. I do not see any way to identify that button state or initiate a shortcut, trigger, activator or anything else on the "second press" of the button.

Press button -- graphic in, audio triggered in sync.

Press button again, graphic out, ==> audio triggered in sync <=== this is the part I cannot figure out.

Thanks again for your help.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.