logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
tholyoak  
#1 Posted : Tuesday, September 15, 2020 5:23:19 AM(UTC)
tholyoak

Rank: Newbie

Groups: Registered
Joined: 7/1/2015(UTC)
Posts: 9

Thanks: 2 times
Was thanked: 1 time(s) in 1 post(s)
I see the article about how recording vMix Calls with multicorder isn't officially supported, but then a couple options are given for doing it. The workaround with assigning the calls to the various Outputs appears to be meant to eliminate multiple files being created. I don't care how many files are created - those can easily be appended together. But the sound is not in sync with the video. Is there a workaround available for that?

We're doing a live-streamed conference and some of our speakers will be remote, and I'll be using vMix with vMix Call for that. We also need the option to be able to remix the video after it's done, so it would be best if we could record the vMix Callers separately.
CrimsonAvenger  
#2 Posted : Tuesday, September 15, 2020 8:38:27 PM(UTC)
CrimsonAvenger

Rank: Member

Groups: Registered
Joined: 5/28/2020(UTC)
Posts: 26
United Kingdom
Location: London

Thanks: 3 times
If you're going to use Multicorder for vMix calls, if you get multi-file recordings, here's how you use them afterwards:

You need to import the XML file to a video editor as a Final Cut Pro project.

This will then lay out the video files in the correct time order.

However, when the video drops out, you'll have a black screen. in vMix, when the call drops out temporarily, it holds the last shot of the caller as a freeze-frame. It won't do that in a video editor.

So what you'll need to do is drop a still of the final frame of each file in the gap to cover the blips.

Then render it all out as a single file and go and remix the video(s).

As for the audio issue - you can either check the latency on each caller while you're recording, or shift the audio by a few frames in the editor. Setting audio latency on the initial recording would be the way to go.

If you're talking about Multicorder files having audio out of sync with the video - yes, I've seen that too. Haven't seen it reported as a bug on the forums, been meaning to post it myself.

The solution to this - again - is to re-render the video. For some reason, loading the Multicorder file into vMix is where the de-synced audio occurs. Doesn't manifest in Windows Media Player, or within Adobe Premiere.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.