logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
pasingshot  
#1 Posted : Saturday, July 5, 2014 2:22:30 PM(UTC)
pasingshot

Rank: Advanced Member

Groups: Registered
Joined: 5/28/2014(UTC)
Posts: 58

Thanks: 32 times
Was thanked: 1 time(s) in 1 post(s)
Hi to all, I having problems to program the xml fil in uvmapping, this is my code:

<virtualSet>
<input name="Fondo" x="0" y="0" zoom="1">background.png</input>
<input name="PGrande" x="0" y="0" zoomX="1" zoomY="1" dynamic="true" uvmap="uvmapb.png">uvmapb.png</input>
<input name="PPequena" x="0" y="0" zoomX="1" zoomY="1" dynamic="true" uvmap="uvmapa.png">uvmapa.png</input>
<input name="Talent" x="0" y="0.15" zoom="0.3" dynamic="true">talent.png</input>
<zoom name="Close Up" x="0" y="-0.5" zoom="3" />
<zoom name="Medium Shot" x="0" y="-0.2" zoom="2" />
<zoom name="Full" x="0" y="0" zoom="1" />
<zoom name="Custom" x="0" y="0" zoom="1" />
</virtualSet>


I think that it's simple, but with this code vMix freezes (no response) and this thats vMix show me:

UserPostedImage

When I use the basic uvmap provided by Martin it's works perfectly.

Something is wrong in code? I erased some things (cropping, rotate...), but the result it's the same

Thanks for helping!

Regards!
admin  
#2 Posted : Saturday, July 5, 2014 10:07:11 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,507
Man
Location: Gold Coast, Australia

Was thanked: 2755 time(s) in 1151 post(s)
Hi,

Please provide all the files so I can test them.

Thanks,

Martin
vMix
pasingshot  
#3 Posted : Tuesday, July 8, 2014 4:14:15 AM(UTC)
pasingshot

Rank: Advanced Member

Groups: Registered
Joined: 5/28/2014(UTC)
Posts: 58

Thanks: 32 times
Was thanked: 1 time(s) in 1 post(s)
Sorry for the delay, you have a e-mail with the link for download.

Thanks!
admin  
#4 Posted : Tuesday, July 8, 2014 4:22:24 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,507
Man
Location: Gold Coast, Australia

Was thanked: 2755 time(s) in 1151 post(s)
Edit: got your email.
admin  
#5 Posted : Tuesday, July 8, 2014 4:27:22 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,507
Man
Location: Gold Coast, Australia

Was thanked: 2755 time(s) in 1151 post(s)
Hi,

First of all, this set loads fine for me so it may be a graphics card issue.
Couple of things to try:

1. Do not set the input filename to the same as the uv map. It should be a different placeholder image.
2. It looks like the UV maps are not gamma corrected. See the specifications document below:

http://www.vmix.com.au/k...ual-set-specification-10

Regards,

Martin
vMix
pasingshot  
#6 Posted : Tuesday, July 8, 2014 5:05:33 AM(UTC)
pasingshot

Rank: Advanced Member

Groups: Registered
Joined: 5/28/2014(UTC)
Posts: 58

Thanks: 32 times
Was thanked: 1 time(s) in 1 post(s)
Thanks for the help

The uv map I'm using is the same you provided us in the post preview of vmix13, what I do not know is whether to modify it in photoshop must return to correct the gamma. When you say do not use the same filename, you want say that it's must be used for example blank file, right? I'll check if the graph it's all right, but when I load the virtual set you provided us (studio 147A Wide) I have no problem for load the set. I will continue with the tests. I will keep you informed.

Thank you very much for your help, it is a privilege to help us with our problems.

Regards!
admin  
#7 Posted : Tuesday, July 8, 2014 6:52:22 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,507
Man
Location: Gold Coast, Australia

Was thanked: 2755 time(s) in 1151 post(s)
Might need to check the bit setting for your photoshop project.
For example the following creates a correct UV map:

1. Create a new photoshop project with Color Mode set to RGB Color 16 bit
2. Add the UVMap1080p.png as a new layer.
3. Adjust the image to the desired position and skew.
4. Save a new PNG file from File -> Save As.

This should create the correct PNG file to use as a UV map.

thanks 1 user thanked admin for this useful post.
pasingshot on 7/8/2014(UTC)
pasingshot  
#8 Posted : Tuesday, July 8, 2014 7:27:43 AM(UTC)
pasingshot

Rank: Advanced Member

Groups: Registered
Joined: 5/28/2014(UTC)
Posts: 58

Thanks: 32 times
Was thanked: 1 time(s) in 1 post(s)
Thanks, i'll try it!
pasingshot  
#9 Posted : Tuesday, July 8, 2014 12:33:23 PM(UTC)
pasingshot

Rank: Advanced Member

Groups: Registered
Joined: 5/28/2014(UTC)
Posts: 58

Thanks: 32 times
Was thanked: 1 time(s) in 1 post(s)
I retested again and I having the same problems, I suspect that I have some ussue with some windows update, I'll format the pc and restart again.

Thanks for the help.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.