logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
mikekay  
#1 Posted : Saturday, May 23, 2020 11:23:28 AM(UTC)
mikekay

Rank: Advanced Member

Groups: Registered
Joined: 4/14/2015(UTC)
Posts: 72
Location: Ottawa

Thanks: 1 times
Was thanked: 3 time(s) in 1 post(s)
I can use a laptop - my android phone, but 2 clients who use iphones are getting the same issue -they connect, no audio or video - on their screen everything looks good - the cam and mic icons are green, but I know in both cases they did not get the "vmix wants to access - camera and mic" message.

I read below that this is hit and miss with iphones - but I have a show to manage Sunday and need to get this working....

Both phones over IOS 11 - using Safari - same issue

Any help appreciated.
mikekay  
#2 Posted : Sunday, May 24, 2020 12:48:10 AM(UTC)
mikekay

Rank: Advanced Member

Groups: Registered
Joined: 4/14/2015(UTC)
Posts: 72
Location: Ottawa

Thanks: 1 times
Was thanked: 3 time(s) in 1 post(s)
Please anybody...any ideas? Have 1 day to get this resolved.
mikekay  
#3 Posted : Sunday, May 24, 2020 1:35:32 AM(UTC)
mikekay

Rank: Advanced Member

Groups: Registered
Joined: 4/14/2015(UTC)
Posts: 72
Location: Ottawa

Thanks: 1 times
Was thanked: 3 time(s) in 1 post(s)
Here is the solution - if iphone users simply click the link - it does not work....if they copy and paste the link - it works....
admin  
#4 Posted : Sunday, May 24, 2020 2:01:21 AM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,460
Man
Location: Gold Coast, Australia

Was thanked: 2663 time(s) in 1124 post(s)
Hi,

This is usually due to the iPhone user selecting a different browser (such as Chrome or FireFox) to open the links by default
so it doesn't end up opening in Safari which is a requirement for vMix Call on iOS devices.

Regards,

Martin
vMix
Xtreemtec Media  
#5 Posted : Wednesday, May 27, 2020 5:41:04 AM(UTC)
Xtreemtec Media

Rank: Member

Groups: Registered
Joined: 4/9/2020(UTC)
Posts: 13
Man
Netherlands
Location: Daarlerveen

Thanks: 4 times
Was thanked: 4 time(s) in 1 post(s)
Actually just tested this on my iPhone 11. If i past the quick URL into FB messenger. And from my phone hit the link, it opens in a "in sub browser" Kind of preview browser. This gives the common logon screen. Hit your name and go.. After this you get no connection as you do not get the pop-up asking for acces to your camera.

If you hold the link and say Open in Safari it opens up in the safari browser and yes then it does work.

I do not have Chrome or Firefox on my iPhone. But the Quick preview browser does not support the means to connect to Vmix. So you might look into pushing for Safari.

When i push the link by Whatsapp the link gets opened in Safari right away and it works..

So it seems more a matter of how the person on the other side is receiving the link. And how the iPhone handles it to open this.
CrimsonAvenger  
#6 Posted : Thursday, May 28, 2020 5:15:16 PM(UTC)
CrimsonAvenger

Rank: Member

Groups: Registered
Joined: 5/28/2020(UTC)
Posts: 15
United Kingdom
Location: London

Thanks: 3 times
Sounds like the way the FB app/Messenger has security set up.

Opening in Safari is required to trigger the permission request and approval for access to mic and camera.

Opening the link within FB or Messenger is like opening it in a walled garden that just won't trigger the hooks to request access permissions.

So if you're sending the link via FB or FB messenger, you might to want to ensure you advise them to open it in a new browser. Figure out the standard steps to take and then just have it for a copy & paste to go with the link.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.