logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
grantcoll  
#1 Posted : Friday, March 20, 2020 2:16:51 PM(UTC)
grantcoll

Rank: Advanced Member

Groups: Registered
Joined: 10/7/2017(UTC)
Posts: 31
Location: Hamilton

Thanks: 4 times
Was thanked: 1 time(s) in 1 post(s)
I Open Chrome and navigate to vmixcall.com. Enter in my name and the password. I only see like a TV pattern in the small self box at top left and the webcam is not activated. I can see the Output from vmix.

It looks like some popup is blocked, but I can't fix it. I have allowed popups for www.vmixcall.com. When I click the small camera logo at the right of the address bar, it says: Continue allowing https://www.vmixcall.com to access your camera and microphone, which appears to be correct, but the Microphone and Camera picklists are greyed out. In the Camera one it has vMix Video External 2. I don't know why this is, as the webcam is not called that. Being greyed out means I can't change them. It has manage button, and that takes me to settings, where I can see that I can allow access to camera and microphone, and can allow popups but the problem still exists.

Chrome version is 80.0.3987.149
Windows 10 64bit

I try with Firefox, and it works perfectly, and also using Chrome from my Android phone and it works fine.

Any ideas anyone ? (I am presuming this is a chrome/windows 10 setting, since Firefox from the same computer works fine)

Edited with an update
I have another Windows 10 computer and this one works. The popup under the URL comes up, I click Allow and then the webcam works ok. So something different as the first computer does not offer the popup.

This same problem reported in another forum entry: Chrome won't let me select video input

Also, my problem goes away if I uninstall vmix. But with vmix installed, I get the screen of coloured bars selected by Chrome, which is vMix Video External 2, and it is greyed out. Even changing in settings it doesn't work as you have to refresh, and then it goes back. Maybe this is Chrome fault. I have another computer and it does not have this problem.

Further update. I have just found a forum for a game called Roll20, which uses a similar facility, and many people are having the same trouble. When using Chrome, the cameras, in particular webcam, are greyed out, and one selected, which is not the default. Same problem but with different applications. The only common thing is chrome. Something that might help this, maybe if Martin can take a look at the very last paragraph, a developer thinks there may be a constraints conflict, which Firefox is ignoring, but Chrome is seeing an issue and greying out the built in cam.
https://app.roll20.net/f...amera-controls-in-chrome


Another here from the Chrome bugs site. Again, go to the bottom and find that they again come to the conclusion that when constraints are used to select, it is likely that Chrome selects the wrong camera. Maybe rather than waiting for Chrome bug, which will likely result in new bugs, apparently if constraints are not used, then Chrome will use the default. Martin can you help please ?
https://bugs.chromium.or.../issues/detail?id=693746
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.