logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
JoeFloyd  
#1 Posted : Tuesday, June 4, 2019 5:08:22 AM(UTC)
JoeFloyd

Rank: Newbie

Groups: Registered
Joined: 3/6/2019(UTC)
Posts: 2
Man
United States
Location: Alaska

Trying to integrate the Mackie MCU PRO into my VMix workflow for hotkeys and audio control.

Have been successful in reading fader input from the control surface - the digital fader moves in correlation to the physical fader movement. There appears to be a problem with MIDI out communication, though, as the motorized fader returns to zero about a second after it is set. This movement is not reflected on the digital fader. As soon as the physical fader is touched again, the digital fader snaps to zero and follows fader movement again. I have set up both the activator and shortcuts as suggested in the User Guide.

These are the settings used:

shortcut.jpg (32kb) downloaded 2 time(s). activator.jpg (56kb) downloaded 1 time(s).

I am sure I have missed something in the setup, possibly on the Mackie driver side - VMIX sees the control surface in the shortcut "MIDI Settings" menu as well as the activator "Enable Devices" menu, but will not display the Controller in the MIDI Channel Mappings menu. Does anybody have any insights?

Thanks!
barriod  
#2 Posted : Sunday, April 5, 2020 6:23:50 AM(UTC)
barriod

Rank: Newbie

Groups: Registered
Joined: 4/5/2020(UTC)
Posts: 2
Spain
Location: Sevilla

Good, I also have the same problem, I have a behringer x-touch table, and the fades do the same to me, at the second they go back to low. I have tried all kinds of configurations but nothing.
In the behringer I have the option to put it in Mackie mode or HUI mode I think I have tried everything but I have not managed to get the fades to stay in place.
did you manage to solve it?
marcusp  
#3 Posted : Wednesday, April 29, 2020 7:50:05 PM(UTC)
marcusp

Rank: Newbie

Groups: Registered
Joined: 4/29/2020(UTC)
Posts: 4
United Kingdom

I now have the same problem. Sadly, I didn't look at the forum before buying my new X-Touch. All ideas welcome (or even better, added support for Mackie Controllers!)
gp47  
#4 Posted : Wednesday, May 20, 2020 7:43:33 PM(UTC)
gp47

Rank: Newbie

Groups: Registered
Joined: 5/20/2020(UTC)
Posts: 2
United States

Was thanked: 2 time(s) in 1 post(s)
I did a bit of poking around and found that the Mackie faders use PitchBend rather than ControlChange. ControlChange treats the second and third bytes separately as note and velocity, while PitchBend combines the two bytes for its value.

Because it only uses 7 of the 8 bits in the note and velocity bytes, the note field has a maximum value of 127. However, as you probably noticed when you set the Shortcut, vMix reads the note value as 1024. This exceeds the 127 value and it appears the vMix code isn't handling this as we would expect. In fact, there are some erratic MIDI signals being sent, so I'm not sure that the code is handling the overflow properly).

Regardless, the activator is sending a MIDI signal like B0 00 96 and the Mackie is expecting a signal of E0 7F 96, leading the Mackie motorized fader to reset.

I was able to get around this using Bome to translate the MIDI signal. The motorized faders now respond as expected when the digital interface is modified and retain their position. I haven't tried to program the Mackie further yet, so I'm not sure what other issues exist.

The Mackie is a great control board and it would be wonderful if vMix would provide better support for it.
thanks 2 users thanked gp47 for this useful post.
lem120 on 6/16/2020(UTC), eduardocfs on 6/16/2020(UTC)
lem120  
#5 Posted : Tuesday, June 16, 2020 2:49:53 AM(UTC)
lem120

Rank: Newbie

Groups: Registered
Joined: 5/27/2020(UTC)
Posts: 2
Italy

Thanks: 1 times
Originally Posted by: gp47 Go to Quoted Post
I was able to get around this using Bome to translate the MIDI signal. The motorized faders now respond as expected when the digital interface is modified and retain their position. I haven't tried to program the Mackie further yet, so I'm not sure what other issues exist.


Hi and thank you for your solution.
I'm very interested in how you did it.
BroadcastTechie  
#6 Posted : Tuesday, August 25, 2020 3:38:52 AM(UTC)
BroadcastTechie

Rank: Newbie

Groups: Registered
Joined: 8/25/2020(UTC)
Posts: 2
United Kingdom

(I realise that a lot of what I've just written is in fact a repeat of the info above, but I didn't realise this until after I'd posted as I only skim read the thread then went to work it out from scratch - that will teach me to not skim read!)
---

I've just been experimenting with an icon Platform M+ (using the Mackie profile) and Bome translator (classic) - might be missing something, but I'm also using loopMIDI to create a loopback interface between vmix and the M+.
Not got a full setup working and probably won't, but I'll leave this as a hint for anyone else searching for a solution.

Controls from the M+ into vMix shortcuts so far just works - although I can't work what do with the pots at the top of the faders, CW they send note velocities of 1-6? depending on how fast, and CCW 65-70. It would be great to map these to the channel gain control to allow quick boosting of sources.

Sending back...
Create a Loopback interface and enable in vMix. Set the Bome input to the loopback and output to the Mackie panel.
Master volume for example I'm sending out of vMix as a ControlChange (on channel 16 Note 0), event MasterVolume and type Fader.
In Bome the translator Incoming is "BF 00 pp" which translates the controller channel 16, note 0 value (pp is the value) and the Outgoing is "E8 pp pp" which is pitch bender 8 (0 indexed, 0=first fader) and pp pastes the values in. In the full Translator software you can do more maths to properly convert the value, but this method works well.

Similar for the other faders.

To make the "Mute" (this example is for fader / input 2) button work I used Bome to invert the value, so one translator is triggered "90 11 00" (90 = note on, then the note/button number, then the value), and outgoing is "90 11 7F". Repeat but reverse the values to turn the light off again. This way when the channel is active the light is off, and inactive the channel is essentially muted.
In vMix the activator is a Note control, channel 1, note 17 (17 dec = 11 hex) and again type fader - this is important - button doesn't work!

Edit: also I enabled MIDI thru so that simple button commands work as normal.

Hope that makes sense!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.