logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
-TA_  
#1 Posted : Friday, January 18, 2019 10:49:55 PM(UTC)
-TA_

Rank: Advanced Member

Groups: Registered
Joined: 6/12/2015(UTC)
Posts: 51
Location: Finland

Thanks: 1 times
Was thanked: 4 time(s) in 1 post(s)
Hi!

I have a GoPro3 connected via HDMI to Magewell USB3 dongle and vMix. vMix sees picture as 1920x1080 25p which is wanted.
But when I connect GoPro via Magewell 4 port HDMI card (pcie) vMix sees it as 50p. Can't find any setting where is could change it to 25p.

In vMix camera settings are 1920x1080 50i.

Any ideas ?

R.Tommi
DWAM  
#2 Posted : Saturday, January 19, 2019 12:34:01 AM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,121
Man
France
Location: Bordeaux, France

Thanks: 149 times
Was thanked: 606 time(s) in 469 post(s)
GoPros are well known to not respect strict output standards.
I have to set my GoPro 3 Black output to 1080p50 to get it seen by my BMD capture card as 1080i50!
So try to play around with the output settings and see what happens.
Alternatively you can use a converter with frame rate conversion like Decimators to correct this issue.

You might also need a HDMI signal booster if you want long runs of HDMI. Some of them seem to correct this framerate issue too.

Guillaume
-TA_  
#3 Posted : Saturday, January 19, 2019 1:59:32 AM(UTC)
-TA_

Rank: Advanced Member

Groups: Registered
Joined: 6/12/2015(UTC)
Posts: 51
Location: Finland

Thanks: 1 times
Was thanked: 4 time(s) in 1 post(s)
I tried to change GoPros output settings but turns out that no matter what you set it will send always 1080p50 out from HDMI.

Just thinking about why the other Magewell sees it 25p and other 50p. I thought all Magewells do conversion if I select 1080i50 input at vMix ?

Not a big issue but my main cam is 1080i50 so Instant Replay won't accecp GoPro which is connected via 4 port Magewell :-)

-Tommi
elvis55  
#4 Posted : Saturday, January 19, 2019 2:17:47 AM(UTC)
elvis55

Rank: Advanced Member

Groups: Registered
Joined: 3/17/2017(UTC)
Posts: 128
Switzerland
Location: Luzern - Schweiz

Thanks: 10 times
Was thanked: 16 time(s) in 16 post(s)
DWAM  
#5 Posted : Saturday, January 19, 2019 2:18:31 AM(UTC)
DWAM

Rank: Advanced Member

Groups: Registered
Joined: 3/20/2014(UTC)
Posts: 2,121
Man
France
Location: Bordeaux, France

Thanks: 149 times
Was thanked: 606 time(s) in 469 post(s)
EDID are wrong, signal is "interpreted" by connected devices.
Try with HDMI booster or splitter or DoctorHDMI
Or go for Decimator
richardgatarski  
#6 Posted : Saturday, January 19, 2019 2:48:51 AM(UTC)
richardgatarski

Rank: Advanced Member

Groups: Registered
Joined: 2/18/2014(UTC)
Posts: 1,397
Location: Stockholm

Thanks: 111 times
Was thanked: 213 time(s) in 177 post(s)
Tommi,
I am not sure about what your issue is. But I am pretty sure that what vMix shows in the Input setting is not what the camera sends, but rather what vMix has adjusted the signal to. Some drivers (e.g. Yuan's) can actually via Input/Settings/Advanced/Properties show the specs of the incoming video (e.g. resolution and frame rate). But, AFAIK Magewell's non-USB drivers do not show any info. The same goes for all USB-grabbers, including Magewells.

Furthermore, what the souce (e.g. your GoPro) sends to the device (e.g. Magewell USB or 4-input card) is determined by EDID handshaking between these two devices. Frequently resulting in something that one does not really want. This can be managed by EDID-managers, like Dr HDMI.

Maybe Dr HDMI can help you, see this video about connecting GoPro's to various video mixers.
zenvideo  
#7 Posted : Saturday, January 19, 2019 2:55:46 AM(UTC)
zenvideo

Rank: Advanced Member

Groups: Registered
Joined: 5/13/2014(UTC)
Posts: 369
Man
United Kingdom
Location: Manchester, UK

Thanks: 1 times
Was thanked: 140 time(s) in 94 post(s)
Originally Posted by: richardgatarski Go to Quoted Post
AFAIK Magewell's non-USB drivers do not show any info.

They do if you access the device via Direct Show then you can access the Magewell-specific Property panel and make various changes to the settings. However, vMix defaults to using the SDK to access the card, because that way they can use the lower latency mode, but it means you can't access the Property panel unless you tick the "Show legacy" box when creating the input, in which case the Magewell inputs show up twice in the list, allowing you to choose the DirectShow access version. Then you can access the Property panel via the list of Filters in the Settings for that input.

-TA_  
#8 Posted : Saturday, January 19, 2019 3:01:32 AM(UTC)
-TA_

Rank: Advanced Member

Groups: Registered
Joined: 6/12/2015(UTC)
Posts: 51
Location: Finland

Thanks: 1 times
Was thanked: 4 time(s) in 1 post(s)
And now GoPro is 25p. Thanks Martin !


Ah found it

"Show legacy" is found where ?
Magewel Customer Support  
#9 Posted : Monday, January 21, 2019 1:24:14 PM(UTC)
Magewel Customer Support

Rank: Newbie

Groups: Registered
Joined: 1/7/2019(UTC)
Posts: 4
China
Location: Nanjing, Jiangsu

For Magewell USB Capture products, please install USB Capture Utility with which you can check detailed info of both input and output signals.
For Magewell Pro Capture products (PCIe), please check the property of the capture device in which detailed info of both input and output siganls can be reflected.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.