logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
chrisis  
#1 Posted : Thursday, June 28, 2018 8:13:20 PM(UTC)
chrisis

Rank: Member

Groups: Registered
Joined: 5/24/2018(UTC)
Posts: 28
Location: Christchurch

Thanks: 1 times
Was thanked: 5 time(s) in 4 post(s)
As per the topic, my Replay recording is stopping randomly. I'm stumped as to the root cause. Here's a demo of it:

(apologies for the potato quality, I used OBS studio to record and I almost never use the app...


Note at 1:20/21 in the recording, the decklink camera on the right seems to have some sort of glitch, and that's when the recording stops.

Here are some details of my setup:

Software
vMix 21.0.0.47 x64
Blackmagic Design Desktop Video 10.10

Hardware
Decklink Duo 2
-> SDI 1 = Input 59.94fps
-> SDI 2+4 = Output 59.94fps
-> SDI 3 = Input 59.94fps

SDI 1 is receiving the AUX output from an ATEM TV Studio HD, whereas SDI 3 receives its input direct from the computer generating the image (HDMI via a Blackmagic HDMI to SDI converter, again at 59.94fps). I have a feeling that the replay recording is stopping because of the glitch on the SDI 3 input but I'm not sure this is the case, and I'm also not sure what could be causing the glitch itself.

Any ideas as to how to solve this would be hugely appreciated!
chrisis  
#2 Posted : Thursday, June 28, 2018 8:18:35 PM(UTC)
chrisis

Rank: Member

Groups: Registered
Joined: 5/24/2018(UTC)
Posts: 28
Location: Christchurch

Thanks: 1 times
Was thanked: 5 time(s) in 4 post(s)
chrisis wrote:

SDI 1 is receiving the AUX output from an ATEM TV Studio HD, whereas SDI 3 receives its input direct from the computer generating the image (HDMI via a Blackmagic HDMI to SDI converter, again at 59.94fps). I have a feeling that the replay recording is stopping because of the glitch on the SDI 3 input but I'm not sure this is the case, and I'm also not sure what could be causing the glitch itself.

Any ideas as to how to solve this would be hugely appreciated!


Additional info:
Replay is recording a single camera, the SDI(3) input. After switching to recording the SDI(1) input instead, the recording doesn't stop - there are no graphics glitches on that input.

So I guess this might not be a replayer issue, it might be an issue with that input glitching.
chrisis  
#3 Posted : Sunday, July 1, 2018 10:00:27 PM(UTC)
chrisis

Rank: Member

Groups: Registered
Joined: 5/24/2018(UTC)
Posts: 28
Location: Christchurch

Thanks: 1 times
Was thanked: 5 time(s) in 4 post(s)
An update. There's definitely an issue with the input, so I've switched camera input to an NDI capture input instead. However, I still have a problem with Replay recording stopping. Whenever there is what I've been calling a "state change" on the PC that's got NDI capture running on it, replay recording stops. Let me explain:

I'm doing an esports recording. The source PC runs Heroes of the Storm, and has Newtek's NDI Scan Converter running on it. The game output has several states:
1. Draft view
2. Game view
3. Post game view

The normal process has the game go from 1 state to the other in sequence. If I have replay recording at the time of switching from one state to another, the recording stops. However, the recording light remains on - it just doesn't write data to the disc. To recover, I stop the recording and restart it, and we are back in business.

I'm confused as to why the recording stops at all though. In the past I've been able to start replay recording at the start of a broadcast, and then stop it at the end - 6 hours later of uninterrupted recording. Now I have to constantly check back after each state change and restart the recording. Surely this is not normal?
admin  
#4 Posted : Sunday, July 1, 2018 10:18:12 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,154
Man
Location: Gold Coast, Australia

Was thanked: 2245 time(s) in 1011 post(s)
Hi,

As long as the video format remains the same (size and frame rate), vMix Replay should autorecover and resume recording after a few seconds.
In the replay folder there should be some log files that show what is happening in more detail.

If you like, you can drop us an email at info@vmix.com.au and submit a support report from Settings -> About. We should be able to see what is happening.

Regards,

Martin
vMix
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.