logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
FoolOnTheHill  
#1 Posted : Monday, October 11, 2021 5:28:18 AM(UTC)
FoolOnTheHill

Rank: Newbie

Groups: Registered
Joined: 9/30/2021(UTC)
Posts: 5

Thanks: 2 times
I set up a scheduled event for my Facebook page with the persistent streamkey to livestream, started streaming, and Vmix reported all well (red Stream button).

On Facebook, on the video setup screen, the stream appeared, realtime, as seen at #1 in the attached screenshot, but Facebook didn't "create" the live video (#2).


I've not experienced this problem before, where the stream clearly makes it to FB, isn't generally viewable. I couldn't find a way to publish it. It did not appear in the corresponding Facebook event nor on the live_videos tab.

edit screen with preview censored cropped.png (227kb) downloaded 3 time(s).
richardgatarski  
#2 Posted : Monday, October 11, 2021 7:39:17 AM(UTC)
richardgatarski

Rank: Advanced Member

Groups: Registered
Joined: 2/18/2014(UTC)
Posts: 1,630
Location: Stockholm

Thanks: 122 times
Was thanked: 256 time(s) in 216 post(s)
Facebook is giving us a hard time with constant changes in their extremely confusing interface for live streamers.

It seems from your screen shot that you did not publish the event. That is, did not complete all necessary steps.

I guess a persistent key will always work, even though no event is grabbing it.

My advice is that you experiment and do a few test events to understand how it all works.

Our experience is that the initial unique key is frequently changed betweeen when we create the live event and its time to go live. And that even if we selelect manual start, Facebook changes that to start on scheduled time.

In sum, Me and my team are pretty annoyed...
FoolOnTheHill  
#3 Posted : Monday, October 11, 2021 10:03:14 AM(UTC)
FoolOnTheHill

Rank: Newbie

Groups: Registered
Joined: 9/30/2021(UTC)
Posts: 5

Thanks: 2 times
Thanks for the quick reply. The event is actually published as part of the scheduling process. For instance, you can see next week's event here: https://www.facebook.com/events/263917668957811/

But you're likely right, in a sense. Either we encountered a bad bug, or there's some publishing step in advance, or after we were going live, that I should have taken, but didn't. If I can figure out what that is, I'll be fine.
richardgatarski  
#4 Posted : Monday, October 11, 2021 8:12:01 PM(UTC)
richardgatarski

Rank: Advanced Member

Groups: Registered
Joined: 2/18/2014(UTC)
Posts: 1,630
Location: Stockholm

Thanks: 122 times
Was thanked: 256 time(s) in 216 post(s)
Actually, we just ran inte the very same issue. Facebook receives the stream from vMix, but it is impossible to start the stream.
I blame Facebook and they really need to put their live UI together...
thanks 1 user thanked richardgatarski for this useful post.
FoolOnTheHill on 10/11/2021(UTC)
richardgatarski  
#5 Posted : Monday, October 11, 2021 8:38:04 PM(UTC)
richardgatarski

Rank: Advanced Member

Groups: Registered
Joined: 2/18/2014(UTC)
Posts: 1,630
Location: Stockholm

Thanks: 122 times
Was thanked: 256 time(s) in 216 post(s)
For some reason our live stream video did not have a title and description (both are required). Adding those and saving the changes med the Send live button work as expected. Will look into why we ran into this, might be a human error on our side. But from past experience it might also be that Facebook "forgot".
In any case Facebook should warn if something is missing instead of just showing grey...
thanks 1 user thanked richardgatarski for this useful post.
FoolOnTheHill on 10/11/2021(UTC)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.