logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
kiki_korea  
#1 Posted : Friday, September 24, 2021 4:29:09 PM(UTC)
kiki_korea

Rank: Newbie

Groups: Registered
Joined: 9/24/2021(UTC)
Posts: 3
Korea, Republic Of
Location: 서울시

Hi, we are making a program with vMix call, connecting caller form different countries.
Recnetly we are having a low frame rate issue while the caller is using iPhones outside.

There were two cases,

1. From Newyork, using iPhoneX and Safari, 5G with about 20Mbps upload speed
2. From Napoli, using iPhone 12 and both Safari and chrome, 4G with about 40Mbps upload speed

Both callers' resolution was great, so when they are staying still, it seems good. But when they are moving the screen(which is pretty necessary) the frame rate and bit rate goes awfully down, like below 10 fps

We've done for about 1 hour, but it didn't recover.

It is very weird, because when we've done with the same vMix setting in Ireland(using iPhone11, safari) and London(using new ZFlip, firefox), there was no problem at all. (London's data speed was even much lower, like around 15Mbps..)

Is there anyone who can help me? Any ideas to try? It is a torture...
admin  
#2 Posted : Friday, September 24, 2021 5:00:03 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,789
Man
Location: Gold Coast, Australia

Was thanked: 3412 time(s) in 1303 post(s)
Hi,

There is currently an issue with WebRTC, Safari and ipv6 on iOS 14 and higher.
It happens on cellular networks that enforce ipv6 only connectivity on iOS devices.
(We have so far confirmed this for some Australian ISPs)

This prevents direct connections over WebRTC on these devices.
In our tests using any browser based calling app on iPhones will experience similar issues.
(So not limited to vMix Call)

To confirm if a cellular network is enforcing ipv6 only, go to the following page in Safari on the phone:
https://webrtc.github.io...rconnection/trickle-ice/

Scroll down and tick Acquire microphone/camera permissions
then click Gather Candidates.

The IPs in the list will all be ipv6 (using : between numbers) and no ipv4 (using . between numbers) indicating the cellular
network is enforcing ipv6 only.

Unfortunately there is no solution at this time.

Regards,

Martin
vMix
thanks 1 user thanked admin for this useful post.
eduardocfs on 9/24/2021(UTC)
kiki_korea  
#3 Posted : Friday, September 24, 2021 5:20:06 PM(UTC)
kiki_korea

Rank: Newbie

Groups: Registered
Joined: 9/24/2021(UTC)
Posts: 3
Korea, Republic Of
Location: 서울시

Thanks Martin,

Is there any other detour to try? If we try to downgrade the iOS to 13 or so, would it work?

admin  
#4 Posted : Friday, September 24, 2021 5:24:16 PM(UTC)
admin

Rank: Administration

Groups: Administrators
Joined: 1/13/2010(UTC)
Posts: 4,789
Man
Location: Gold Coast, Australia

Was thanked: 3412 time(s) in 1303 post(s)
Not sure when the problem was introduced, all we know is we have tested iOS 14 and 15.

The only potential workaround is full ipv6 support enabled on the network on the vMix side as well.
That is obviously not possible for many as it can be very technical to setup and many broadband ISPs do not support it properly as of yet.
But if you happen to have that as an option, it might be worth testing.

Regards,

Martin
vMix

thanks 1 user thanked admin for this useful post.
eduardocfs on 9/24/2021(UTC)
Lennart  
#5 Posted : Saturday, September 25, 2021 6:07:09 AM(UTC)
Lennart

Rank: Advanced Member

Groups: Registered
Joined: 11/9/2014(UTC)
Posts: 100
Man
Denmark
Location: Copenhagen, Denmark

Thanks: 22 times
Was thanked: 15 time(s) in 14 post(s)
Couldn't it be a solution to use a VPN? Sort of converting the connection to IPv4?
kiki_korea  
#6 Posted : Monday, September 27, 2021 11:42:52 AM(UTC)
kiki_korea

Rank: Newbie

Groups: Registered
Joined: 9/24/2021(UTC)
Posts: 3
Korea, Republic Of
Location: 서울시

We've checked caller's cellular network, and it seems that it doesn't 'force'the ipv6. There were both ipv6 and ipv4 in the lists.

Maybe it's location problem? or browser, or something.

I'm thinking of using VPN as a last option to try, since it would slow down the data speed which is critical to video calls.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.