logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Pepsi(~)  
#1 Posted : Friday, July 23, 2021 8:59:17 PM(UTC)
Pepsi(~)

Rank: Advanced Member

Groups: Registered
Joined: 9/9/2020(UTC)
Posts: 90
Netherlands
Location: Noord-Brabant

Thanks: 3 times
Was thanked: 12 time(s) in 11 post(s)
I've been banging my head for the last 2 days.
I did receive complaints from the business I work in that during broadcasts the audio was wrong.
I did some digging.
on 2 new systems both installed with NDI5.
System 1 has VLC with the NDI plugin playing a music video
System 2 Studio monitor recording the stream. the audio is out of sync. and has unrecognizable spikes/pauzes in it.

I tried the webcam input. and only used the audio to input to Voicemeeter Banana. and did a recording that way.... same poor result.

I reverted back to NDI4 all issues solved.
thanks 1 user thanked Pepsi(~) for this useful post.
Castaway Studios on 7/24/2021(UTC)
stigaard  
#2 Posted : Friday, July 23, 2021 10:50:14 PM(UTC)
stigaard

Rank: Advanced Member

Groups: Registered
Joined: 5/20/2015(UTC)
Posts: 488
Man
Denmark
Location: Copenhagen, Denmark

Thanks: 355 times
Was thanked: 98 time(s) in 78 post(s)
So it is related to NDI Tools, and not vMix. Post the issue at newteks NDI forum.

https://forums.newtek.co...ral-ndi-discussions.364/
Pepsi(~)  
#3 Posted : Friday, July 23, 2021 10:52:20 PM(UTC)
Pepsi(~)

Rank: Advanced Member

Groups: Registered
Joined: 9/9/2020(UTC)
Posts: 90
Netherlands
Location: Noord-Brabant

Thanks: 3 times
Was thanked: 12 time(s) in 11 post(s)
Originally Posted by: stigaard Go to Quoted Post
So it is related to NDI Tools, and not vMix. Post the issue at newteks NDI forum.

https://forums.newtek.co...ral-ndi-discussions.364/


I know. it is just a warning. and I use VMIX for my Live Events for the last year.
Castaway Studios  
#4 Posted : Saturday, July 24, 2021 12:11:42 PM(UTC)
Castaway Studios

Rank: Newbie

Groups: Registered
Joined: 5/10/2020(UTC)
Posts: 6
Man
Australia
Location: Collingwood

Thanks: 6 times
Originally Posted by: Pepsi(~) Go to Quoted Post
Originally Posted by: stigaard Go to Quoted Post
So it is related to NDI Tools, and not vMix. Post the issue at newteks NDI forum.

https://forums.newtek.co...ral-ndi-discussions.364/


I know. it is just a warning. and I use VMIX for my Live Events for the last year.


Appreciate the heads up. When our whole workplace and income is using Vmix, everything is relevant.
I'll hold off for now and would be grateful for any updates.
Pepsi(~)  
#5 Posted : Thursday, July 29, 2021 12:35:22 AM(UTC)
Pepsi(~)

Rank: Advanced Member

Groups: Registered
Joined: 9/9/2020(UTC)
Posts: 90
Netherlands
Location: Noord-Brabant

Thanks: 3 times
Was thanked: 12 time(s) in 11 post(s)
today I downloaded a newer version of NDI tools. 5.0.3.0
the initial issue I had was with 5.0.0.0
I will post an update if the issue is still there.
Len56  
#6 Posted : Thursday, July 29, 2021 2:19:44 AM(UTC)
Len56

Rank: Advanced Member

Groups: Registered
Joined: 3/30/2014(UTC)
Posts: 224
Man
United Kingdom
Location: London, UK

Thanks: 23 times
Was thanked: 27 time(s) in 23 post(s)
Originally Posted by: Pepsi(~) Go to Quoted Post
today I downloaded a newer version of NDI tools. 5.0.3.0
the initial issue I had was with 5.0.0.0
I will post an update if the issue is still there.


Hi How do you know its version 5.0.3.0 I cannot find a version number anywhere?
Pepsi(~)  
#7 Posted : Thursday, July 29, 2021 3:26:31 AM(UTC)
Pepsi(~)

Rank: Advanced Member

Groups: Registered
Joined: 9/9/2020(UTC)
Posts: 90
Netherlands
Location: Noord-Brabant

Thanks: 3 times
Was thanked: 12 time(s) in 11 post(s)
Out of my head:
Open explorer
Goto the program directory
Goto NDI folder
goto Stiudio monitor folder
Right click StudioMonitor application.
goto the tab details.
There you can see the version number
ASAudioVideo  
#8 Posted : Friday, July 30, 2021 12:41:22 AM(UTC)
ASAudioVideo

Rank: Newbie

Groups: Registered
Joined: 2/21/2018(UTC)
Posts: 4
Man
United States
Location: North Hollywood, CA

Was thanked: 2 time(s) in 2 post(s)
Hey Pepsi we ran into the same issue where I work and had to do the same thing. After downgrading to ndi 4 everything seemed to work ok.
Did the small 5.0.3.0 update fix the issue for you. Have you tried again since you installed it?
I’m wondering if we need to wait for vmix itself to go to 5.0 internally. My understanding is that vmix does not fully use the “tools” libraries but it uses the sdk libraries instead which are “baked in” to vmix at compile. I believe the current version is based on ndi 4.5/4.6 sdk so maybe there is some sort of conflict having the ndi 5 tools loaded in a machine with ndi 4.5/4.6 libraries running the software. Just a guess maybe Martin or one of the other vmix guys can chime in.
Pepsi(~)  
#9 Posted : Monday, August 2, 2021 10:49:51 PM(UTC)
Pepsi(~)

Rank: Advanced Member

Groups: Registered
Joined: 9/9/2020(UTC)
Posts: 90
Netherlands
Location: Noord-Brabant

Thanks: 3 times
Was thanked: 12 time(s) in 11 post(s)
I tried 5.0.3.0 and it works. but I had to make sure that I have different settings.
Only the VLC plugin does give me issues. sometimes no audio at all.

But for VMix I have these settings on my system with MS Teams.

My Settings:
Control panel - Sound - Recording - Line (properties)
--Tab: Listen
----Unchecked - Listen to this device
----Playback: Default Playback Device
--Tab: Levels
----Line:100
--Tab: Advanced
----44100Hz (CD Quality)
----both checkboxes checked
Control panel - Sound - Communications
--Do Nothing

VMIX
--Settings
----Outputs/NDI/SRT
------Select your NDI source gear wheel
--------Audio Channel (for me Master. make sure you do a level check for other channels) Master
--------unchecked 20dB Boost
--Audio Mixer
--Audio source 100%
----master 33% -10dB

Newtek Webcam input
--select VMIX source as input
--Audio
-- +20dB

Microsoft Teams
--Do not join a call (yet)
--Click on "Settings and more" (the 3 dots next to your avatar)
--Click on Settings
--Click on Devices
----Speaker is my physical speaker output
----Microphone - Line (NewTek NDI Audio)
----Automatically adjust mic sensitivity - OFF
----Noise Suppression - OFF (pre windows 21H1) (low with 21H1) (otherwise loud static noise with low it is usable but not great)
----Camera - NewTek NDI Video
mavik  
#10 Posted : Wednesday, August 4, 2021 5:26:41 AM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 768
Man
Location: Germany

Thanks: 3 times
Was thanked: 121 time(s) in 108 post(s)
You don't have to wait. You can do manually as well right away.
https://www.vmix.com/kno...version-in-vmix-manually
Pepsi(~)  
#11 Posted : Wednesday, August 4, 2021 5:50:59 AM(UTC)
Pepsi(~)

Rank: Advanced Member

Groups: Registered
Joined: 9/9/2020(UTC)
Posts: 90
Netherlands
Location: Noord-Brabant

Thanks: 3 times
Was thanked: 12 time(s) in 11 post(s)
@mavik upgrading of VMIX to NDI5 is not related to this topic.
It is the NDI webcam that is the issue or the studio monitor or the vlc plugin.
aldoyh  
#12 Posted : Wednesday, August 11, 2021 3:14:25 AM(UTC)
aldoyh

Rank: Newbie

Groups: Registered
Joined: 11/11/2017(UTC)
Posts: 6
Location: Bahrain

Thanks: 1 times
Has anyone managed to get NDI Remote working?
Pepsi(~)  
#13 Posted : Wednesday, August 11, 2021 3:18:51 AM(UTC)
Pepsi(~)

Rank: Advanced Member

Groups: Registered
Joined: 9/9/2020(UTC)
Posts: 90
Netherlands
Location: Noord-Brabant

Thanks: 3 times
Was thanked: 12 time(s) in 11 post(s)
The current version only supports lan configuration. Not yet over the internet.
So nice within the corp wan network. Between europe and north america.

Sorry that was bridge.


Remote not yet tested
aldoyh  
#14 Posted : Wednesday, August 11, 2021 3:29:09 AM(UTC)
aldoyh

Rank: Newbie

Groups: Registered
Joined: 11/11/2017(UTC)
Posts: 6
Location: Bahrain

Thanks: 1 times
Well, since the release never worked and now I'm on 5.0.5 and still doesn't work via LAN.
mavik  
#15 Posted : Wednesday, August 11, 2021 4:38:39 AM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 768
Man
Location: Germany

Thanks: 3 times
Was thanked: 121 time(s) in 108 post(s)
Same here. Currently medialooks does NDI over WAN but adds extra cost that we all want to avoid.
aldoyh  
#16 Posted : Wednesday, August 11, 2021 9:47:57 AM(UTC)
aldoyh

Rank: Newbie

Groups: Registered
Joined: 11/11/2017(UTC)
Posts: 6
Location: Bahrain

Thanks: 1 times
But the big question is, why would you announce and release something that doesn't work? Or have in beta to avoid the embarrassment! @NewTek
pba  
#17 Posted : Tuesday, August 24, 2021 8:38:24 AM(UTC)
pba

Rank: Advanced Member

Groups: Registered
Joined: 10/14/2015(UTC)
Posts: 135
Location: Hungary

Thanks: 36 times
Was thanked: 23 time(s) in 19 post(s)
For me, NDI5 is really unstable, its not production ready. I rolled back to NDI4.5 which is rock stable.
LuqSD  
#18 Posted : Friday, August 27, 2021 9:17:00 AM(UTC)
LuqSD

Rank: Newbie

Groups: Registered
Joined: 7/20/2021(UTC)
Posts: 1
Poland
Location: Wrocław

I was on work this weekend, and installed NDI5 2 DAYS BEFORE THE WORK,

NDI5 IS NOT READY FOR PRODUCTION!


i had so many problems, 2 pc over 10gbit lan coudn't see each other in vmix ndi. I was trying everythink, read forum, no luck.

Today i solved this problem just by uninstalling NDI5.

Tryed to uncheck ip6 but it wasn't problem ip6!

I will try ndi5 later after stable version will be realease.
Paul Fuhrmann  
#19 Posted : Sunday, October 3, 2021 6:36:58 AM(UTC)
Paul Fuhrmann

Rank: Advanced Member

Groups: Registered
Joined: 6/2/2020(UTC)
Posts: 67
Man
Germany
Location: Berlin

Thanks: 8 times
Was thanked: 9 time(s) in 8 post(s)
make sure both applications run in 48kHz

as your teams run in 44.1 but vMix is straight 48 only thismught be your issue.
Pepsi(~)  
#20 Posted : Monday, October 4, 2021 7:00:03 PM(UTC)
Pepsi(~)

Rank: Advanced Member

Groups: Registered
Joined: 9/9/2020(UTC)
Posts: 90
Netherlands
Location: Noord-Brabant

Thanks: 3 times
Was thanked: 12 time(s) in 11 post(s)
Originally Posted by: Paul Fuhrmann Go to Quoted Post
make sure both applications run in 48kHz

as your teams run in 44.1 but vMix is straight 48 only thismught be your issue.


a good suggestion..
but I see the same issue when using VLC with NDI plugin. to the virtual webcam.


can someone point me how I can change the frequency in VMix? for NDI output?
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.