logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
mppfeffer  
#1 Posted : Tuesday, August 4, 2020 5:55:29 AM(UTC)
mppfeffer

Rank: Member

Groups: Registered
Joined: 6/18/2020(UTC)
Posts: 18
United States

Thanks: 3 times
I am testing vMix call after installing a RODECaster Pro to our studio setup. Previously, the calls came in fine and the callers had no complaints. However, the host of the show was hearing an echo that was quite disorienting. The RODECaster Pro has solve that issue but now the caller complains of an echo on their end. I have tried rerouting the audio with no success.

I am using the Master, Bus A, and Bus B. The Master goes into the interface and I return the audio back into Bus A (This is where the final mix is recorded) and only added Bus B in an effort to fix the vMix call issue. If I route the caller to Bus B and turn off the Master on their input, they can hear everything without an echo but the host cannot hear the caller. As soon as the Master is turned back on, the host hears the caller and the caller hears the echo. How can I fix this? I am so close to finally having our studio set up and really need to fix this issue!

Thanks in advance!
dmwkr  
#2 Posted : Tuesday, August 4, 2020 6:02:58 AM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 332

Thanks: 44 times
Was thanked: 76 time(s) in 68 post(s)
That's what I tried to post on your other thread you probably just deleted... :)

If you have the Rodecaster as an Output in vMix (headphones, master or bus) you should probably activate the USB mix-minus in your Rodecaster.
mppfeffer  
#3 Posted : Wednesday, August 5, 2020 3:21:51 AM(UTC)
mppfeffer

Rank: Member

Groups: Registered
Joined: 6/18/2020(UTC)
Posts: 18
United States

Thanks: 3 times
Originally Posted by: dmwkr Go to Quoted Post
That's what I tried to post on your other thread you probably just deleted... :)

If you have the Rodecaster as an Output in vMix (headphones, master or bus) you should probably activate the USB mix-minus in your Rodecaster.


I have enabled USB mix minus in my Rodecaster. The echo is still there. The only way I have been able to remove the echo is to turn the headphones on the caller input off or nearly all the way down, but then I can't hear the caller and their audio is too low to be recorded.
dmwkr  
#4 Posted : Wednesday, August 5, 2020 4:08:05 AM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 332

Thanks: 44 times
Was thanked: 76 time(s) in 68 post(s)
Can you outline your complete audio setup? The host has a mic on the Rodecaster, right? Is he also monitoring through the Rodecaster? What are your Outputs for Master and Headphones? Do you use the Rodecaster to process the call?

What is your firmware on the Rodecaster? They introduced Multitrack Recording through USB with 1.1. Do you bring in the host mic as a single input?
mppfeffer  
#5 Posted : Wednesday, August 5, 2020 5:52:27 AM(UTC)
mppfeffer

Rank: Member

Groups: Registered
Joined: 6/18/2020(UTC)
Posts: 18
United States

Thanks: 3 times
Right now we are running the most recent version of vMix. The host uses a RODE Broadcaster condenser mic which is connected via XLR to the RODECaster Pro. I have the RODECaster set as an input on vMix, which sends the final mix into Bus A (this is also where our recording receives its audio). The callers' audio source is Bus B. I have everything that I want the caller to hear routed to Bus B. The callers' input is routed to both the Master and Bus B. If I only rout it to B, the host cannot hear them but they do not hear themselves echoing. As soon as they are routed to the Master, the problem is reversed (host hears them but they hear an echo).

The host does monitor through the RODECaster and we have the latest firmware. I DO have the USB mix-minus enabled as well. And yes, the host's mic is a single input. I think I've answered all of your questions. Is it possible that the caller is hearing the echo because I am routing their input into Bus B? If so, is there another way to rout them so that they are hearing the mix-minus AND the host is hearing them?

P.S. I have been told to mute the headphones in the general audio settings for the callers' inputs and it does eliminate the echo but also makes it so that the host and the recorder do not receive audio from the callers.
dmwkr  
#6 Posted : Wednesday, August 5, 2020 7:00:18 AM(UTC)
dmwkr

Rank: Advanced Member

Groups: Registered
Joined: 2/23/2019(UTC)
Posts: 332

Thanks: 44 times
Was thanked: 76 time(s) in 68 post(s)
Ok, the Call input is doubled somewhere. Does the host monitor with headphones or speakers? If speakers, this could be it.

Otherwise I would suggest to start from scratch. What have you set up in Settings / Audio Ouputs? For starters it should be:
Master: Enabled
Headphones: Rodecaster
Buses A and B: Enabled

Bring in the hosts' mic as a single track into vMix (not the mixed output of the Rodecaster), mute it in the headphones and see if it helps. See the Multitrack option here: http://en.rode.com/blog/...DECaster-Pro-Multitrack. (That's what I meant with single input.)

Routing in the vMix Audio Mixer
M - Everything you need for your stream and recording. Single track of the hosts' mic, vMix Call, ... Set your recording to Master.
Bus B - Everything you want the caller to hear, set it as source for caller.

Optional:
Bus A - Could be the Bus where you route all inputs you want the host to hear, and then solo it in the Audio Mixer, if the host hears himself.

Originally Posted by: mppfeffer Go to Quoted Post
Is it possible that the caller is hearing the echo because I am routing their input into Bus B?


No, this shouldn't be a problem. The auto mix-minus for vMix Call is still in effect.
mppfeffer  
#7 Posted : Friday, August 7, 2020 12:00:54 AM(UTC)
mppfeffer

Rank: Member

Groups: Registered
Joined: 6/18/2020(UTC)
Posts: 18
United States

Thanks: 3 times
Originally Posted by: dmwkr Go to Quoted Post
Ok, the Call input is doubled somewhere. Does the host monitor with headphones or speakers? If speakers, this could be it.

Otherwise I would suggest to start from scratch. What have you set up in Settings / Audio Ouputs? For starters it should be:
Master: Enabled
Headphones: Rodecaster
Buses A and B: Enabled

Bring in the hosts' mic as a single track into vMix (not the mixed output of the Rodecaster), mute it in the headphones and see if it helps. See the Multitrack option here: http://en.rode.com/blog/...DECaster-Pro-Multitrack. (That's what I meant with single input.)

Routing in the vMix Audio Mixer
M - Everything you need for your stream and recording. Single track of the hosts' mic, vMix Call, ... Set your recording to Master.
Bus B - Everything you want the caller to hear, set it as source for caller.

Optional:
Bus A - Could be the Bus where you route all inputs you want the host to hear, and then solo it in the Audio Mixer, if the host hears himself.










I have tried this exact setup and STILL the caller is hearing themselves on about a half-second. It doesn't make any sense, as I have set up the mix-minus. I've tried basically every routing and channel matrix configuration that I can think of. If the host hears the caller, the caller hears themselves in a delayed echo. If there is no echo, the host cannot hear the caller. This is beyond frustrating! With that said, I greatly appreciate you taking the time to provide these suggestions and tips.

I am still open to other suggestions. Thank you ALL so much!
NMG4  
#8 Posted : Thursday, November 19, 2020 12:08:31 PM(UTC)
NMG4

Rank: Newbie

Groups: Registered
Joined: 11/18/2020(UTC)
Posts: 3
Ireland
Location: Dublin

Thanks: 1 times
Did you ever get this issue resolved? I'm having the same problem when adding a vmix call and Skype NDI.

cHEERS, nIALL.
Eric Dean Freese  
#9 Posted : Saturday, April 17, 2021 8:09:08 AM(UTC)
Eric Dean Freese

Rank: Newbie

Groups: Registered
Joined: 10/16/2019(UTC)
Posts: 5
United States
Location: Cedar Rapids, Iowa

I am also having this issue....any resolution?
andreypetr  
#10 Posted : Saturday, April 17, 2021 9:58:10 AM(UTC)
andreypetr

Rank: Advanced Member

Groups: Registered
Joined: 1/31/2017(UTC)
Posts: 82
Location: Russia

Thanks: 1 times
Was thanked: 9 time(s) in 9 post(s)
You guys should also be posting Audio devices and Audio buses configuration if you have this issue. Most likely than not you are sending a master mix without mix-minus to the caller.
twokingsfilms  
#11 Posted : Tuesday, April 20, 2021 3:59:57 AM(UTC)
twokingsfilms

Rank: Member

Groups: Registered
Joined: 5/19/2020(UTC)
Posts: 23
United States

Thanks: 2 times
Was thanked: 1 time(s) in 1 post(s)
Experiencing this same issue - here's what I have found, along with my setup:

- Every caller is remote (obviously) -- so everyone is clearly using all sorts of different mics/cameras to call in.
- Every caller is using headphones
- This has happened no matter WHO calls in (in other words I have had this happen with 6 different callers across multiple configurations)
- vMix calls are routed to Bus B
- If 1 person calls in and EVERYONE mutes -- no problems.
- As soon as a second person unmutes, things CAN happen
- I say CAN, because this issue, while persistent, is not heard on every single sentence. It appears to only be heard if the speaker raises their voice even slightly, or, specifically, women's voices seem to trigger it a bit more then men's
- What is the issue? -- The person who spoke AND the other calls AND the master all hear the last few words echoed very quietly -- so literally everyone, including the speaker, hears the echo/repeat
- We are using vMix Advanced Call and everyone has all check boxes turned off -- HOWEVER, we have tested with "Echo Cancellation" turned ON and still we get this repeated dialogue
- In one test, it seemed I was able to eliminate the problem by going to each person's call and turning on an aggressive noise gate -- but this created it's own problems AND ultimately did not fix the issue
- There is no outside mixer involved, the entire broadcast is through vMix -- so call calls come into vMix Call, are routed to Bus B (the callers are only sent Bus B), and Bus B is sent to the Master - nothing else fancy or confusing
- Using vMix Pro

Here's hoping someone can help all of us experiencing this issue! It's incredibly frustrating *sad face*

Thanks all!
polsten  
#12 Posted : Tuesday, April 20, 2021 7:41:12 AM(UTC)
polsten

Rank: Newbie

Groups: Registered
Joined: 10/8/2020(UTC)
Posts: 8
Man
Germany
Location: Berlin

HeyHo,

Had this Issues 3 times in the Last Year. 2 in the last 3 weeks....

It was allways the same Problem,.. One Caller speaks, none other Participant is speaking(all Callers Audio is On in vMix). Caller speaking gets with a delay about 1-2 Sec his own Audio back to his Audio-Out.
OK, i thought its routing Problem, checked it is not. Doublechecked with my Phone as a Caller, Ipad, Notebook,... didnt had the Problem.
(and Yes all Caller had Headphones)

I use a X-Touch-Compact for Audio-Control. 8 faders are linkt via Shortcuts and Activators to/from vMix Caller INputs.
So to a walkthrough for me was, to manual took faders/audio from non speaking Callers down. Echo was cancelled.
OK for now, did well.

But the main Problem was, 6 Callers and this Problem with the Echo did only appear for ONE Caller. (all Caller AudioSource MAIN)
Really not shure where the Problem started.


If an @Admin could look at this Thread would be nice.
mavik  
#13 Posted : Tuesday, April 20, 2021 10:41:54 PM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 752
Man
Location: Germany

Thanks: 3 times
Was thanked: 117 time(s) in 105 post(s)
Make sure you use the seperate bus for the callers and use that bus as the return feed to them so that the mix minus works as designed.
Route the callers to the master in addition to make them audible on the stream.
twokingsfilms  
#14 Posted : Wednesday, April 21, 2021 3:25:11 AM(UTC)
twokingsfilms

Rank: Member

Groups: Registered
Joined: 5/19/2020(UTC)
Posts: 23
United States

Thanks: 2 times
Was thanked: 1 time(s) in 1 post(s)
Mentioned above that I have done exactly as you described @mavik - with various callers across various configurations and this is not a fix. I honestly appreciate the reply, as any help is better than no help, but I'm wondering if there isn't something that we're all missing? The basic answer of route your audio is one we all seem to agree would make the most sense, but we can also say that at least, a number of us in this thread, are already doing that correctly, so the issue seemingly lies elsewhere. Is there another fix we could try?
mavik  
#15 Posted : Thursday, April 22, 2021 5:02:48 AM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 752
Man
Location: Germany

Thanks: 3 times
Was thanked: 117 time(s) in 105 post(s)
When this happens try to isolate the issue and try to trace it down to it's origin. Try to minimize the setup until it's gone. When you notice the change you know what step was responsible for it.
CrimsonAvenger  
#16 Posted : Saturday, April 24, 2021 9:11:47 PM(UTC)
CrimsonAvenger

Rank: Advanced Member

Groups: Registered
Joined: 5/28/2020(UTC)
Posts: 35
United Kingdom
Location: London

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
FYI

We run vmix in Amazon AWS, using Parsec for remote and vMix call for talkback. We have Macs.

And an echo when we’re on the line for pre-recording.

The echo with us is caused by crosstalk on our headsets. Tried numerous other sound cards, numerous headsets, numerous headset splitters.

Only a separate headphone and mic setup fixed it.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.