logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Riculus  
#1 Posted : Thursday, April 8, 2021 4:28:21 AM(UTC)
Riculus

Rank: Member

Groups: Registered
Joined: 10/15/2013(UTC)
Posts: 12
Location: New York

Thanks: 7 times
Hi All,
I'm getting the following error when I try to connect my PTZoptics camera via NDI.
I'm using Vmix 21.

The selected device can be used as an NDI source. Please visit new.tk/ndihax to learn how to activate.

I downloaded the NDI 4 tools and still have the same issues.

Thank you for your help



Capture.PNG (866kb) downloaded 0 time(s).

matkeane  
#2 Posted : Thursday, April 8, 2021 4:51:49 AM(UTC)
matkeane

Rank: Advanced Member

Groups: Registered
Joined: 10/6/2020(UTC)
Posts: 44
France

Was thanked: 10 time(s) in 10 post(s)
Originally Posted by: Riculus Go to Quoted Post
I'm using Vmix 21.


I think that might be your problem. You'd have to check the release notes, but more recent versions of vMix have used updated versions of the NDI SDK.
zenvideo  
#3 Posted : Thursday, April 8, 2021 5:27:11 AM(UTC)
zenvideo

Rank: Advanced Member

Groups: Registered
Joined: 5/13/2014(UTC)
Posts: 427
Man
United Kingdom
Location: Manchester, UK

Thanks: 2 times
Was thanked: 160 time(s) in 110 post(s)
I'd say it's almost certainly the fact that you're using vMix 21, a version created before NDI|HX2 existed. Back then, earlier versions of NDI Tools included a specific driver to decode NDI|HX but, in later versions of the NDI SDK & Tools, that capability was incorporated into the NDI library DLLs (which is what vMix uses and includes in their installation). As such, installing NDI Tools is no longer relevant to how vMix works, so installing or updating NDI Tools will not fix your problem, because vMix v21 would have been compiled using an earlier version of NDI (v3.x ?), and include/use the relevant DLL for that version.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.