logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
mitchstein443  
#1 Posted : Thursday, October 3, 2019 3:54:57 AM(UTC)
mitchstein443

Rank: Advanced Member

Groups: Registered
Joined: 4/11/2015(UTC)
Posts: 61
Man
United States
Location: Home

Thanks: 6 times
Was thanked: 3 time(s) in 3 post(s)
For about 4-5 years now (maybe longer) I've been running vmix on a dedicated desktop (was a laptop now a desktop) machine to send out a playlist (rtmp) to my video server for a 24/7 streaming roku channel and web channel.. (tvbydemand.com channel 1).

The dedicated machine runs in my bedroom and it has functioned fantastically 24/7 for all these years , what I' like to do is utilize the server itself to host a virtual machine dedicated to vmix, so the problem I am encountering is:

I get video but no audio, I pdated all vbox drivers and now I get audio and no video.

The reason it is in a virtual machine, is that the dedicated computer (vmix) has to boot without a password in order to load vmix and the playlist and a powershell script that handles the titling and streaming starts and stops and the advertising inserts.

also my server does not have a soundcard and virtual drivers do not seem to want to work for me at all..


Here are the specs,

server 2012 r2 64 bit all updates installed, Virtual box 6.0 all updates installed. windows 10 enterprise all updates installed running under a vm with 8 gigs ram 4 cores.

With the vbox "tools" installed I get sound but no video, with Vbox tools not installed I get video but not audio.

Has anyone run vmix under a virtual box successfully if so what are thhe settings i need?

I am leaning towards it being a codec issue, because it will overlay gif files and jpg files and send the video out it just will not render mp4 files (same files I am currently using on my desktop) avi or wmv files..

The files render and stream in vlc, obs studio and using ffmpeg directly... But I like the vmix interface above all of them... Any help at all will be greatly appreciated..
Martinzo  
#2 Posted : Thursday, April 1, 2021 10:49:12 AM(UTC)
Martinzo

Rank: Newbie

Groups: Registered
Joined: 3/31/2021(UTC)
Posts: 2
Australia
Location: Sydney

I would try another virtual machine for it, from my perspective, this could be the main reason why is it not working.
AndreaBur  
#3 Posted : Monday, April 5, 2021 4:14:30 PM(UTC)
AndreaBur

Rank: Newbie

Groups: Registered
Joined: 4/5/2021(UTC)
Posts: 1
United States
Location: New York

Do you think this can be the reason why it's not working? There can be a lot of different reasons, but actually, trying a different virtual machine can help in this case. I did go through a similar situation 6 months ago, I have been using a scuffed virtual machine and all the programs which I tried to run on it were so scuffed, some options didn't work at all. Now I use another one and can open vmdk file and work with them. Such a relief when there no this kind of errors and everything is smooth.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.