logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Cainnech  
#1 Posted : Wednesday, March 31, 2021 8:48:49 AM(UTC)
Cainnech

Rank: Newbie

Groups: Registered
Joined: 3/31/2021(UTC)
Posts: 1
Belgium

Hi all,

We are currently trying to set up a configuration where we can produce a webinar through vMix. We would like to stream to Microsoft Teams but after the initial tests it turns out that Teams Meeting is absolute rubbish when it comes to displaying content from a laptop through vMix. The image is completely blurry eventhough it's crystalclear in vMix.

The problem is linked to the compression used by the Microsoft Teams client so using Teams Meeting is a no-go.
However, there supposedly is a way to stream directly from vMix to a Microsoft Teams Live Event, which we would like to try as it allows us to be in control of the stream and not the Teams Client.

In that case, vMix is streaming the output to the Microsoft Stream-server which then displays that on the Teams Live Event-page.
We have been following the different steps as they are outlined on this page (https://docs.microsoft.com/en-us/stream/live-create-event)
We have also been watching this video (Livestream to Microsoft Teams Live Event with vMix ) which also explains the process very well.

We can set up the meeting fine, we can also get the RTMP-link and copy that into vMix. But when we start the stream, after a little while the preview on the Teams Live Event-page tries to open the stream but fails to do so and shows an error message stating it can't play the video.

Initially we thought it might have been some issues due to the network configuration and firewall. But we checked those and those ports are not blocked.
To verify this, we repeated the same procudure but this time we used OBS to stream the output to Microsoft Stream and this works without any issue. So we know it's not related to the network.

So it seems our issue is linked to vMix itself, since it works with OBS.
Did anyone encounter a similar issue before and was able to resolve it?

If so, it would be great if you could share your possible solution.

Thanks
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.