logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
dunk.flight  
#1 Posted : Friday, January 29, 2021 7:03:53 AM(UTC)
dunk.flight

Rank: Member

Groups: Registered
Joined: 12/7/2020(UTC)
Posts: 15
United Kingdom
Location: sussex

Thanks: 1 times
I did a test call with 2 presenters today dialling in with Vmix Call.

Both were using a MacBook pro / Air with a Sony Alpha6400 camera and Elgato Cam Link 4k adapter. Both callers were unable to use this camera for the call and resorted to built in cam.

Booth used Chrome. Clicked on manage preferences, permissions, camera but nowhere was the Sony coming up to select. They also tried in Safari but couldn't find the camera either. Both callers could use the camera if they used zoom or google hangouts.

They are high profile guests for the stream and didn't want to spend time troubleshooting for the test.

I dont have any of this gear to test with and they will not have anything else. Clearly the equipment works but not making it to the browser permissions.

What can I do to get them into VmixCall. My backup options were either:

get them in zoom and capture a second screen,

or possibly get them to install NDI tools and use Scan Converter & Virtual Input as Chrome usual see's NDI as a camera option in permissions. Thats a last resort as clients should not need to do this?

Is this anything bizarre like a firewall or the Elgato Cam link needing permissions elsewhere, or the output Res to high for a browser to see it?

Help Please on how to get them in.

Cheers
Follo  
#2 Posted : Friday, January 29, 2021 10:03:34 AM(UTC)
Follo

Rank: Advanced Member

Groups: Registered
Joined: 10/10/2019(UTC)
Posts: 30
Man
Germany
Location: Bonn

Thanks: 1 times
Was thanked: 9 time(s) in 3 post(s)
Hi,

the only thing that maybe helps is set the framerate from the Sony Alpha 6400 to 30 or 60 FPS @1080.
Be sure that they have the latest Elgato Game Capture Software for(macOS) and that they have the latest firmaware for the Elgato Cam Link 4k.

https://www.elgato.com/de/gaming/downloads
https://help.elgato.com/...d-Elgato-Gaming-hardware

Also check:
In recent versions of macOS, Elgato Cam Link 4K will need to be given Permission to use your Mac's Camera and Microphone. You can do that via the Security (or Security & Privacy) section of the System Preferences.

Here is a video how to set up the Sony A6400.



Hope it helps.

Best regards
dunk.flight  
#3 Posted : Friday, January 29, 2021 8:32:06 PM(UTC)
dunk.flight

Rank: Member

Groups: Registered
Joined: 12/7/2020(UTC)
Posts: 15
United Kingdom
Location: sussex

Thanks: 1 times
thanks very much. I will pass this info on and see if I have any luck
DaveT  
#4 Posted : Thursday, February 4, 2021 6:03:51 AM(UTC)
DaveT

Rank: Advanced Member

Groups: Registered
Joined: 4/28/2020(UTC)
Posts: 31
United States
Location: San Francisco

Was thanked: 5 time(s) in 4 post(s)
I can confirm that we've had this same issue with www.vmixcall.com across many El Gato devices, especially on our Macs. It's not the camera from what I can tell, it's the El Gato device and how the browser/VMIX Call reads it. We do happen to use a lot of a6100s and a6400s but we've seen it across the board with other cameras used such as Sony FS5, C100/C300, Canon dSLRs, etc....

The issues with this have been greatly reduced (basically eliminated) with http://beta.vmixcall.com where you can select your camera within the call itself. It was a nightmare before. I know this beta website was moved over to advanced.vmixcall.com, but oddly enough we have an issue where the only camera source that shows is "camera 1" and it's not responsive. No issues with beta.vmixcall.com though.

The El Gato/browser issue is not exclusive to VMix Call. We've seen it with numerous sites from Hangouts/Meets to Discord. But www.vmixcall.com by far was given us the most difficulty with it.

We've used other brands too and all run into similar issues, but just have seen it a lot more with El Gatos.
dunk.flight  
#5 Posted : Thursday, February 4, 2021 6:23:39 AM(UTC)
dunk.flight

Rank: Member

Groups: Registered
Joined: 12/7/2020(UTC)
Posts: 15
United Kingdom
Location: sussex

Thanks: 1 times
Perfect timing. Was about to reply to the first answer. Just tried the call again with updates and had the same issues. Chrome just greys out the options for Elgato.

I will try advanced call and see how that goes. Ive not heard of Beta... Sounds risky for the clients im dealing with. Is it solid.

If advanced doesn't go well then my backup is screen grab zoom and return feed.

Spoke to Elgato who gave me some tips on backend OS resets. Thing is I cant be asking guests to do the work. Its poor from a service POV when they say but it works everywhere else, Its your platform.

Im glad others have the problem so Im not alone,
dunk.flight  
#6 Posted : Thursday, February 4, 2021 7:21:23 AM(UTC)
dunk.flight

Rank: Member

Groups: Registered
Joined: 12/7/2020(UTC)
Posts: 15
United Kingdom
Location: sussex

Thanks: 1 times
Does anyone have a Camlink 4k and a Mac that would be happy to do a test with myself for a workaround???
DaveT  
#7 Posted : Wednesday, February 17, 2021 6:34:31 AM(UTC)
DaveT

Rank: Advanced Member

Groups: Registered
Joined: 4/28/2020(UTC)
Posts: 31
United States
Location: San Francisco

Was thanked: 5 time(s) in 4 post(s)
We've used beta.vmixcall.com exclusively for months w/ no problems.
dunk.flight  
#8 Posted : Wednesday, February 17, 2021 6:50:27 AM(UTC)
dunk.flight

Rank: Member

Groups: Registered
Joined: 12/7/2020(UTC)
Posts: 15
United Kingdom
Location: sussex

Thanks: 1 times
Thanks. I used advanced call and it worked perfectly. It seems to solve most issues with callers. Not had any probs since. Elgato could not explain it to. Me.
cisti3ooo  
#9 Posted : Monday, March 8, 2021 11:55:35 PM(UTC)
cisti3ooo

Rank: Newbie

Groups: Registered
Joined: 3/8/2021(UTC)
Posts: 1
Italy
Location: Torino

Look for Sony Imaging edge Webcam driver, for a less expense/best effort approach to your setup

https://support.d-imagin...ony.co.jp/app/webcam/en/

It doesn't solve the elgato issue, but avoid using it.
mavik  
#10 Posted : Friday, March 12, 2021 7:22:30 AM(UTC)
mavik

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2017(UTC)
Posts: 691
Man
Location: Germany

Thanks: 3 times
Was thanked: 110 time(s) in 99 post(s)
Panasonic offers USB tethering as well. Just for the "other" brand users.
Funderburk4178  
#11 Posted : Tuesday, March 16, 2021 8:05:04 PM(UTC)
Funderburk4178

Rank: Newbie

Groups: Registered
Joined: 3/16/2021(UTC)
Posts: 1

We are all use external cameras connected to a UVC HDMI to USB device. on our staff that have had this same issues, and looking for some help. In this case, an El Gato Camlink 4K, El Gato HD60S+, and Magewell USB All Callers wäre experts in Touchdesigner and well known to virtual webcams.

Walgreenslistens
mjc  
#12 Posted : Thursday, March 18, 2021 3:58:25 AM(UTC)
mjc

Rank: Newbie

Groups: Registered
Joined: 3/18/2021(UTC)
Posts: 3
United States
Location: Boston

Confirming that the 'advanced' link works!
dunk.flight  
#13 Posted : Thursday, March 18, 2021 5:29:13 PM(UTC)
dunk.flight

Rank: Member

Groups: Registered
Joined: 12/7/2020(UTC)
Posts: 15
United Kingdom
Location: sussex

Thanks: 1 times
I can confirm. Using Vmix Advanced call solved all problems with Elgato cam link4k and Sony camera. Combined with Chrome or Firefox ive had no problems with any camera.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.