logo

Live Production Software Forums


Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Josemite  
#1 Posted : Wednesday, October 14, 2020 12:35:29 PM(UTC)
Josemite

Rank: Member

Groups: Registered
Joined: 6/4/2020(UTC)
Posts: 25
United States
Location: California

Thanks: 13 times
Was thanked: 4 time(s) in 4 post(s)
I switch computers often (studio vs mobile). I export/import my vMix shortcuts & Streamdeck profile ... but the "Key/Control" mapping for the keys on the El Gato Streamdeck will be different depending on which computer it's plugged into, basically breaking all the key associations on the new computer.

I'm dealing with at least 62 vMix shortcuts (keeps growing), which are updated fairly frequently.

Anybody have a solution? Is there like some Streamdeck live config file I can copy and paste to overwrite the one on the laptop?

Thanks!
Vince Beck  
#2 Posted : Wednesday, October 14, 2020 2:51:10 PM(UTC)
Vince Beck

Rank: Advanced Member

Groups: Registered
Joined: 7/28/2019(UTC)
Posts: 304
United States
Location: Santa Rosa

Thanks: 1 times
Was thanked: 38 time(s) in 38 post(s)
You need to do a full backup using the Streamdeck software (profile>backup all) from the old system to the new one, as well as export and re-import shortcuts . You would do the same thing if you had projects with different mappings.
thanks 1 user thanked Vince Beck for this useful post.
Josemite on 10/14/2020(UTC)
Josemite  
#3 Posted : Wednesday, October 14, 2020 3:11:10 PM(UTC)
Josemite

Rank: Member

Groups: Registered
Joined: 6/4/2020(UTC)
Posts: 25
United States
Location: California

Thanks: 13 times
Was thanked: 4 time(s) in 4 post(s)
Originally Posted by: Vince Beck Go to Quoted Post
You need to do a full backup using the Streamdeck software (profile>backup all) from the old system to the new one, as well as export and re-import shortcuts . You would do the same thing if you had projects with different mappings.


That worked, thanks!

Really glad I asked, this would have been a pain to do manually.
tony marone  
#4 Posted : Wednesday, March 3, 2021 5:56:57 PM(UTC)
tony marone

Rank: Advanced Member

Groups: Registered
Joined: 1/16/2010(UTC)
Posts: 50
Man
Location: usa

Was thanked: 3 time(s) in 2 post(s)
Sorry, does not work for me. Any other ideas? Thanks
richardgatarski  
#5 Posted : Wednesday, March 3, 2021 6:19:40 PM(UTC)
richardgatarski

Rank: Advanced Member

Groups: Registered
Joined: 2/18/2014(UTC)
Posts: 1,558
Location: Stockholm

Thanks: 121 times
Was thanked: 240 time(s) in 202 post(s)
Originally Posted by: tony marone Go to Quoted Post
Sorry, does not work for me. Any other ideas? Thanks


https://forums.vmix.com/...f-the-Elgato-Stream-Deck
Josemite  
#6 Posted : Thursday, March 4, 2021 5:25:35 AM(UTC)
Josemite

Rank: Member

Groups: Registered
Joined: 6/4/2020(UTC)
Posts: 25
United States
Location: California

Thanks: 13 times
Was thanked: 4 time(s) in 4 post(s)
Originally Posted by: tony marone Go to Quoted Post
Sorry, does not work for me. Any other ideas? Thanks


What are you trying exactly that is not working? Maybe document your steps.

BTW, I just ran through this with latest vMix update and Streamdeck update to make sure it was all working.

My steps:

1. Comp 1: Export my vMix shortcut config file
2. Comp 1: Create my backup all from Streamdeck
3. Comp 1: Save my .vMix file
4. Wait for my Creative Cloud to sync those 3 files (*.vmix,*.config,*.streamDeckProfilesBackup)
5. Comp 2: Restore in Streamdeck the backup profile
6. Comp 2: Open same .vMix
7. Comp 2: Import vmix shortcut config file
8. Comp 2: Restart vMix


Added info:
I'm on Windows 10 and use a creative cloud drive and its folder mapped to the same drive letter on both machines (v:\Creative Cloud\), and put all my inputs and resources under that location. Also useful, because I send my *.vmix and *.streamDeckProfilesBackup and vMix shortcut *.config there too.

Wish I could just have a live config file for Streamdeck & one for vMix shortcuts that was synced across both machines live, but using a 'Backup All' under Streamdeck profile and exporting out the shortcut *.config is working for me.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.